Fog client retains proxy settings from old Forefront server



  • We have been using FOG for over a year, with great success. But since some weeks we are experiencing problems with FOG snapins not being executed on our clients (not all, but some). Upon investigation, we noticed in fog.log that the FOG client is still trying to connect to our old proxy server (which we don’t have anymore since 6 months). We removed WPAD settings from DHCP, tried clearing the DNS and even removed all instances from the registry where our old proxy was referenced to.

    This is the error we get continuously in fog.log. But only on some systems, not all systems.

    25/02/2016 17:05 FOG::UserTracker Attempting to connect to fog server…
    25/02/2016 17:05 FOG::HostnameChanger Attempting to connect to fog server…
    25/02/2016 17:05 FOG::UserTracker Failed to connect to fog server!
    25/02/2016 17:05 FOG::UserTracker De proxynaam kan niet worden opgehaald: 'tmg-peda’
    25/02/2016 17:05 FOG::UserTracker bij System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
    bij System.Net.WebClient.DownloadString(Uri address)
    bij FOG.UserTracker.track()

    Any help would be appreciated, we have been searching for a solution for days…

    Kind regards

    Stefan



  • @Wayne-Workman I’ve found the solution late friday night. It wasn’t a FOG problem, but a Windows problem with the proxy settings. FOG seemed to be the only client that used that proxy setting so I found a way to disable it. The registry setting is:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\Internet Settings]
    “ProxySettingsPerUser”=dword:00000000

    This solves the problem for us, maybe it may come in handy for some other users of FOG.

    Thank you all for the great support!

    Stefan


  • Moderator

    @Stefan73be Let’s step back and do some basic troubleshooting to see if we can identify what may or may not be the issue. Can you try to uninstall the fog client on one of the computers, and then reinstall and see if the issue is resolved? Also, do new fog client installations work?


  • Senior Developer

    @Stefan73be the fog client doesn’t get any proxy information from the fog server, but if the fog server is setup for proxy it may not be able to communicate back with the client.

    The fog client does not take any separate settings to get the proxy information either. Meaning the only place for network to look at proxy is the IE setting.

    Make sure to disable them and then restart the fog client. The other possibility is the client isn’t even looking at the fog server which is completely separate from proxy settings at all.



  • @Tom-Elliott update: i changed the proxy setting in IE to something non-existent, but the Fog client still retains the old server (TMG-PEDA) as its proxy. I changed the proxy on the FOG server, same result.
    Is there any place on the client-computer where fog stores some sort of information on how to connect to the server? In the ini file i can’t see any proxy settings, just the ip address of the FOG server.

    Thank you for helping us out, we’ve been struggling with this for several days…



  • @Tom-Elliott So the fog client only gets its proxy setting from the fog server? Then i’ll try and put something different on the server and then remove it, maybe that works.


  • Senior Developer

    @Stefan73be the fog client never accepted any information for proxy.



  • @Tom-Elliott Tom, we have removed all proxy settings from IE, from the system, from the default user, from other browsers, from the registry, … without any result. All other software works without a problem, it’s just the fog client that retains the old settings.


  • Senior Developer

    @Stefan73be then the issue is not fog. It’s your windows setup using proxy stuff. Maybe your image has proxy info setup? Look in Internet explorer settings. Look in connections and I’ll guess proxy stuff is setup there.



  • @Wayne-Workman It’s version 1.2.0, the latest version afaik.



  • @Tom-Elliott Thank you for the reply, but it is not set on the server. The proxy settings are blank.


  • Senior Developer

    Look in FOG Configuration->FOG Settings->Proxy

    Remove the settings that are in there and you should be good.


  • Moderator

    What version of fog, exactly? Look at the number in the cloud, top left of the login screen.


Log in to reply
 

431
Online

38918
Users

10688
Topics

101398
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.