NFS errors, and troubleshoot step failure implications



  • I’m getting the infamous NFS failure, as seen here: https://wiki.fogproject.org/wiki/index.php/Image_Upload:_Error_Checking_Mount
    Except mine says “Network is unreachable” instead of “Permission denied”

    What’s the implication of making the recommended change in the above article and then failing on the second troubleshooting step here?
    Pics:
    alt text
    alt text


  • Moderator

    @_mateo said:

    Since I’ve taken so much of your time I’d like to contribute, if I can!

    We always need people to answer basic questions here on the forums for newbies. We always need people to update the Wiki, add hardware reported to the hardware lists, to convert tutorials posted in the forums into polished Wiki articles. to add common problems to the wiki based on things posted in the forums. There are lots of ways to contribute.

    The easiest way is to maybe once a day (mornings are best) just quickly browse through the recent threads and see if there are any you know the answers to. Probably 30% to 40% of things posted here are newbie questions.



  • Upload succeeded!



  • @Sebastian-Roth @Wayne-Workman
    So a regular desktop (HP EliteDesk 800 G1 TWR) is currently uploading… I should’ve tested this earlier.
    Anywho, is there a way that I can help with getting the minis to work? I can just image them by hand, no biggie. Since I’ve taken so much of your time I’d like to contribute, if I can!



  • @Sebastian-Roth Ah, darn. I’m only getting a loopback address. So maybe DHCP isn’t figured out… Or it’s because of this device. Which brings me to @Wayne-Workman 's question, this is the only device I’ve tried to image. Which I now realize is bad variable control. MY B. I’ll try a regular desktop.


  • Developer

    @_mateo Have you surely resolved the DHCP issues from your other post? I am wondering if the fogclient is getting confused while trying to receive an IP via DHCP as well. While you are in the shell type ip addr show and shot another picture for us.

    Possibly the HP EliteDesk 800 G2 mini is kind of new and your FOG 1.2.0 kernels are not able to bring up the NIC.


  • Moderator

    That error doesn’t give me a fog-problem kind of vibe. It’s specifically telling you there is an issue with the network, “Network is unreachable”. Now, that could mean a number of things. It could mean that the patch cable is bad, loose, wired wrong, it could mean the port on the switch you’re using is bad, could mean the motherboard in the computer your using is bad, it could mean that DHCP wasn’t delivered fast enough for the 2nd polling of DHCP, It could mean that portfast is not enabled on your switches. It might even be something as simple as an IP conflict.

    Let’s take a step back. Does FOG work on anything else where you are? Has fog ever worked where you are?



  • Oh yeah. Ubuntu 14.04, fog 1.2.0. Using work LAN’s DHCP.
    Fog is running on HP Compag 8200 Elite. Computers to be imaged are HP EliteDesk 800 G2 mini PCs


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.