2 bonded nics working slowing down imaging speed



  • Working on trunk 5704 , and somehow connecting the 2 nics installed , imaging speed slows down from 5 gbps to 2 gbps or less.
    I really have no clue what could be wrong , this is what i have:

    bond0     Link encap:Ethernet  HWaddr e8:39:35:63:fa:bb
              inet addr:192.168.137.51  Bcast:192.168.137.255  Mask:255.255.255.0
              inet6 addr: fe80::ea39:35ff:fe63:fabb/64 Scope:Link
              UP BROADCAST RUNNING MASTER MULTICAST  MTU:1500  Metric:1
              RX packets:41730895 errors:0 dropped:7809 overruns:0 frame:0
              TX packets:267044696 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:4307169179 (4.3 GB)  TX bytes:400834971999 (400.8 GB)
    
    em1       Link encap:Ethernet  HWaddr e8:39:35:63:fa:bb
              UP BROADCAST RUNNING SLAVE MULTICAST  MTU:1500  Metric:1
              RX packets:20472650 errors:0 dropped:0 overruns:0 frame:0
              TX packets:175896638 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:2338763038 (2.3 GB)  TX bytes:264037377930 (264.0 GB)
              Interrupt:20 Memory:fe500000-fe520000
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:50744 errors:0 dropped:0 overruns:0 frame:0
              TX packets:50744 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:18541428 (18.5 MB)  TX bytes:18541428 (18.5 MB)
    
    p255p1    Link encap:Ethernet  HWaddr e8:39:35:63:fa:bb
              UP BROADCAST RUNNING SLAVE MULTICAST  MTU:1500  Metric:1
              RX packets:21258245 errors:0 dropped:0 overruns:0 frame:0
              TX packets:91148058 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:1968406141 (1.9 GB)  TX bytes:136797594069 (136.7 GB)
              Interrupt:16```
    
    Linux fog1 3.19.0-25-generic #26~14.04.1-Ubuntu SMP Fri Jul 24 21:16:20 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
    
    root@fog1:~# cat /etc/network/interfaces
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    auto bond0
    iface bond0 inet static
       bond-slaves none
       bond-mode 2
       bond-miimon 100
       address 192.168.137.51
       netmask 255.255.255.0
       network 192.168.137.1
       broadcast 192.168.137.255
       gateway 192.168.137.1
       hwaddress ether e8:39:35:63:fa:bb
    auto em1
    iface em1 inet manual
       bond-master bond0
       bond-primary em1 eth1
    auto p255p1
    iface p255p1 inet manual
       bond-master bond0
       bond-primary em1 p255p1


  • Without configuring the p255p1 and em1 the network ainºt working.(as i have no connection to server)

    It works like this :

    auto em1
    iface em1 inet manual
      bond-master bond0
      bond-primary em1
    
    auto p255p1
    iface p255p1 inet manual
      bond-master bond0
    
    auto bond0
    iface bond0 inet static
      bond-slaves em1 p255p1
      bond-mode 2
      bond-miimon 100
      address 192.168.137.51
      netmask 255.255.255.0
      gateway 192.168.137.1```
    
    and this is what i get :
    
    ```root@fog1:~# ip addr show
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host
           valid_lft forever preferred_lft forever
    2: p255p1: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc mq master bond0 state UP group default qlen 1000
        link/ether e8:39:35:63:fa:bb brd ff:ff:ff:ff:ff:ff
    3: em1: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master bond0 state UP group default qlen 1000
        link/ether e8:39:35:63:fa:bb brd ff:ff:ff:ff:ff:ff
    4: bond0: <BROADCAST,MULTICAST,MASTER,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
        link/ether e8:39:35:63:fa:bb brd ff:ff:ff:ff:ff:ff
        inet 192.168.137.51/24 brd 192.168.137.255 scope global bond0
           valid_lft forever preferred_lft forever
        inet6 fe80::ea39:35ff:fe63:fabb/64 scope link tentative dadfailed
           valid_lft forever preferred_lft forever```

  • Moderator

    @mitzayapa said:

    This is what i should have then ?

    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    # The loopback network interface
    
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    
    auto em1
    iface em1 inet manual
      bond-master bond0
      bond-primary em1
    
    auto p255p1
    iface p255p1 inet manual
      bond-master bond0
    
    auto bond0
    iface bond0 inet static
      bond-slaves em1 p255p1
      bond-mode 2
      bond-miimon 100
      address 192.168.137.51
      netmask 255.255.255.0
      gateway 192.168.137.1
    

    It’s seem to be good, it’s not necessary to configure your p255p1 and em1 interfaces :

    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    # The loopback network interface
    
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    
    #auto em1
    #iface em1 inet manual
    #  bond-master bond0
     # bond-primary em1
    
    #auto p255p1
    #iface p255p1 inet manual
    #  bond-master bond0
    
    auto bond0
    iface bond0 inet static
      bond-slaves em1 p255p1
      bond-mode 2
      bond-miimon 100
      address 192.168.137.51
      netmask 255.255.255.0
      gateway 192.168.137.1
    

  • Moderator

    @mitzayapa I agree that looks reasonable. Restart the network service and see what you have with ip addr show

    I do have to say I’ve only seen where they bond like adapters. This should work but now you have two network drivers loaded. Again not a problem, just not standard.



  • This is what i should have then ?

    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    # The loopback network interface
    
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    
    auto em1
    iface em1 inet manual
      bond-master bond0
      bond-primary em1
    
    auto p255p1
    iface p255p1 inet manual
      bond-master bond0
    
    auto bond0
    iface bond0 inet static
      bond-slaves em1 p255p1
      bond-mode 2
      bond-miimon 100
      address 192.168.137.51
      netmask 255.255.255.0
      gateway 192.168.137.1
    

  • Moderator

    @mitzayapa Sorry I was reading fast before I started my commute into work. I read p255p1 as your primary interface. I thought it was strange, but I’ve seen some pretty strange stuff in the last few days.

    As for the bonding, what you have is correct, you still need to assign the normal IP address stuff to the bond0 interface.

    At the very least these:

    address 192.168.137.51
    netmask 255.255.255.0
    gateway 192.168.137.1
    

  • Developer

    I used round robin, it gave both speed and resilience, however that was on an unmanaged switch.



  • The p255p is the second NIC I added to the server.

    em1 - built in
    p255p - 1gigabit ethernet card

    auto em1
    iface em1 inet manual
      bond-master bond0
      bond-primary em1
    
    auto p255p1
    iface p255p1 inet manual
      bond-master bond0
    
    auto bond0
    iface bond0 inet static
      bond-slaves em1 p255p1
      bond-mode 2
      bond-miimon 100
      ... -> is there missing something or thats all ?

  • Moderator

    @Sebastian-Roth In some of the ubuntu examples they always use bond-slaves none. Not sure why. I would agree with your setting.

    As for the primary, I still think I would use the onboard nic for primary, but again I don’t know what a p255p network interface is. Also if the xor mode (bond mode 2) (not really intelligent but fast) isn’t properly sharing the bandwidth during 3 or more installs at the same time, I would switch to bond-mode 5 or setup lacp on the switch and use bond-mode 4.


  • Developer

    I’d suggest this config:

    auto em1
    iface em1 inet manual
      bond-master bond0
      bond-primary em1
    
    auto p255p1
    iface p255p1 inet manual
      bond-master bond0
    
    auto bond0
    iface bond0 inet static
      bond-slaves em1 p255p1
      bond-mode 2
      bond-miimon 100
      ...
    


  • Whould any of you be kind and paste a corrected interfaces file for my configuration?



  • True , there´s no eth1 device in my config. Just delete it ?


  • Developer

    And why bond-primary em1 eth1?? You don’t have eth1 as ifconfig shows.


  • Moderator

    Well, I think this line is in error
    bond-primary em1 p255p1
    Since you already have that defined for em1 or I would only select one, probably the internal one for primary.

    Secondly I think I would use bond mode 5 or if you have access to the switch setup LACP mode.

    Did you deploy only one client in the test above or more than one? The packets transmitted seem to indicate the second nic is not being used. If you had only two actors in the conversation I would understand the packet mismatch.



  • em1 is the builtin NIC , p255p1 is the one I added.

    Ive tested it for some days now , with more than one client , so can u tell me what should i remove/add to my config ?
    From the last reboot the server was at first connected through buildin NIC then after a few hours ive connected the second NIC



  • The os is Linux fog1 3.19.0-25-generic #26~14.04.1-Ubuntu , i deploy up to 12 pc´s at once what; i olso have dnsmasq enabled.

    Whats missing from my config ?


  • Moderator

    Ok, I see from the kernel you are using ubuntu.

    I also noticed that all of your network traffic is passing over p255p1 what is that network adapter?


  • Moderator

    I have seen slighlty slower speeds (between two actors) when using bonding, because when you enable bonding you also add a bunch of code between the OS and the network interface. But 50% loss is a bit much.

    Just looking at your bonding configuration it looks like there are a few things missing. What OS are you using here?

    Also what is your idea for using bonding? How many devices will you deploy at once?


  • Moderator

    @mitzayapa Hi, have you configured your switch to enable LACP ?

    I use it on a debian 8 (in vmware esxi 5.5) with that interfaces config :

    auto bond0
    iface bond0 inet static
    	address 172.20.0.4
    	netmask 255.255.0.0
    	gateway 172.20.1.50
    	slaves eth0 eth1
    	bond_mode balance-alb
    	bond_miimon 100
    	bond_downdelay 200
    	bond_updelay 200
    

Log in to reply
 

414
Online

38920
Users

10688
Topics

101408
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.