Client Computers not able to find FOG in PXE



  • Dear All,
    I am new FOG user. I have installed FOG 1.2.0 successfully without any error on CentOS 6.3 server as per the installation procedure mentioned on fogproject portal. Post installation of FOG, as a initial testing, I have performed below steps –
    Logged in to http://<server-ip>/fog/management

    Then click on the Add New Host button. Entered MAC address (seperated by :) and a hostname and clicked the Add button.
    Now click on the Tasks button (the star).
    Then click on List All Hosts and find the host you just created and click on the Advanced button.
    Now under Advanced Actions click on Memtest86+ and confirm that you would like to start the task.
    Now click on Active Tasks and you should see the task that you just created listed.
    Lastly, start the client computer that you created a task for and ensure that in BIOS, PXE boot has the highest boot priority. If everything worked correctly, you should see memtest86+ load.

    But when I am trying to pxe boot from client desktop, it is not connecting to FOG server even if I have mentioned FOG server IP as "Boot server Host name- Option 066) on Windows based DHCP server.

    I want to deploy CentOS, Fedora, Ubuntu destributions through this FOG server, please let me know the procedure to configure the same.

    Please help for the same.

    Thanks in advance.


  • Moderator

    @krishnakulkarni said:

    how to upload existing captured image of CentOS on FOG?

    I’m not sure if that’s a typo or poor English… no offense.

    You can not upload an already captured image of anything to fog, unless the capture was done with another fog server.

    If you’re simply asking how to capture an image of a CentOS machine, this is pretty basic. Network boot the machine, register it with FOG. Create a image definition in the web interface. Assign that image to the just-registered host via the web interface. in the host’s basic tasks area, choose upload. Then network boot the host again.



  • Thanks a lot for your help, now able to boot from PXE :)

    One more help is required, will you kindly tell me how to upload existing captured image of CentOS on FOG?

    Thanks.


  • Testers

    DHCP settings are explained here if you need anymore info on them,

    https://wiki.fogproject.org/wiki/index.php/Modifying_existing_DHCP_server_to_work_with_FOG


  • Testers

    Did you add option 67 in DHCP as undionly.kpxe? You need both 66 and 67


Log in to reply
 

427
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.