SOLVED Optiplex 7040: Unable to register Host

  • I am extremely new to the Linux realm and imaging department but I was able to get FOG installed and running.

    Here is what I have running.

    FOG 1.2.0 on CentOS 7
    Kernal Version: 3.19.3

    I was able to get an Optiplex580 to register and pull and image. It’s actually in process right now, so I’m pretty sure it’s going to work!

    However, I have an Optiplex 7040 that I cannot get to register.

    It says:

    Cannot register host for the following reason.

    Then it just lists all the system information and when it says “Attempting to send inventory” it just goes into an endless loop.

    Here is the network card and partition information.
    Intel® Ethernet Connection (2) I219-LM
    Multiple Partition - Single Disk (Not Resizable)

    The thing is, I had this same issue on CrucibleWDS. This particular model would not register but all others would just fine. I was thinking it was just a lack of functionality, but that does not seem to be the case. I don’t know if it is a network driver or a hard drive problem.

    I am not sure if it matters, but this unit is using an SSD drive that is on SATA port 3. All others have been on 0. I would expect if it was a hard drive problem, I would see that once it tried to capture the image.

  • Upgrading to trunk actually worked. I was able to get the machine to register the host. This issue is resolved.

  • Moderator

    @bberrelez one step at a time. Please include picture of the error. There are ways to update the fog client OS without upgrading to the trunk.

  • Moderator

    @bberrelez said:

    I am booting in LEGACY mode, UEFI is not selected.

    Ok you are booting legacy mode. Do you see the FOG menu at all? If you can see the FOG menu, but then you pick register host no joy?

    The question is where does it fail? When you select register, you should see it transfer the FOG Client OS to the 7040. The FOG Client OS has two parts a bzImage and a hard drive.

    If you could take a picture of the error with your mobile and post it here we could maybe see where the problem is.

  • Thank you for both for the replies.

    The machine only has one NIC.

    " or you can try downloading just the new kernel/init files"

    Is this just updating the kernal from within FOG? Or is this another method?

    I suppose I could upgrade to trunk. I will give that a try and let you know if that resolves the issue.

  • @george1421

    Sorry for the late reply. I am booting in LEGACY mode, UEFI is not selected.

  • Moderator

    @bberrelez Can you please see and confirm the PCI ID of the network card in those Optiplex 7040’s. Here it says it should be 8086:156f and it should be supported in kernel 4.1–4.2, 4.4, 4.5-rc+HEAD. So the easiest would be to upgrade to trunk - or you can try downloading just the new kernel/init files.

  • Moderator

    Thinking about this a bit more. You are running the ipxe (linux) kernel in the fog menu, when you select an option you load the fog kernel (bzImage) which you noted was 3.19.3. Its possible that that kernel doesn’t know how to configure the nic adapter. Do I understand there is two ethernet ports in that workstation? Is it possible that the FOG kernel is trying to use one adapter where the ipxe kernel is using the other (just wildly guessing here)

  • Moderator

    I don’t have a 7040, but I can confirm that I can register 9020/7020s and earlier without issue.

    Just for clarity are you booting in BIOS mode or UEFI mode?