Can't boot to PXE



  • @Sebastian-Roth

    My DHCP server is the 192.168.1.6.
    It has option 66 with string 192.168.1.14 which is the Fog server.
    192.168.1.59 is the IP address assigned to the client which was trying to boot to PXE.
    This pcpap file recorded all my DC (which is also my DHCP server) traffic during the boot of the client machine.
    Option 67 is also enabled with parameter undionly.kpxe which I don’t really know what to do with it.

    Thanks


  • Senior Developer

    This is an interesting one again! I don’t see any DHCP server offering an IP address to the client!! WHAT?? It does do a kind of normal DHCP DORA (Discover, Offer, Request, Ack). But without ever handing IP information to the client (always 0.0.0.0 as if it is configured to be a DHCP Proxy server). It only sends next-server (option 66) to the client.

    But I doubt this is really the case because a little later on I see the client (same MAC address and now IP 192.168.1.59) asking a different server (192.168.1.6) on port 4011. Please tell us which is which in your network and who should be handing out which information? Do we see all the DHCP traffic in this pcap file?



  • @george1421 Oh yeah I remember what you’re talking about. You actually have to enable pxe booting. Yup uefi stack for uefi network booting.

    But still, no DHCP options 066 and 067


  • Moderator

    @Wayne-Workman I just checked a 790 on the bench behind me (I understand we are talking about an XPS vs Business class) and under System Configuration->Integrated nic there are the options I mentioned. The WOL setting tells the computer what you want to happen when it receives a WOL command. Let me fire up a 9020 and see, but I’m going to suspect the same settings there too.

    [Edit] Same well changed one Enabled w/Cloud desktop. The 9020 also has a check box for enable uefi stack [/edit]



  • @george1421 I think those options are in the WOL area of the firmware. I’ve had it work with both “LAN” and “LAN /w PXE”

    If you have it just set to “LAN”, then the regular boot order takes over after the WOL happens. In my building, the normal boot order is LAN -> HDD but of course, lan always works and fog tells the comp to boot to the HDD.

    The alternative which is painfully more work is to set the boot order to HDD first, and then set WOL to LAN /w PXE


  • Moderator

    @Wayne-Workman That remind me, the dells have an option for the network adapter for Disabled, Enabled, Enable with PXE, Enabled with PXE and Image server. That setting MUST be set to Enabled with PXE (only). Some one else just had that setting wrong and it wouldn’t boot correctly.



  • @george1421 said:

    And it still confuses me how/where the proxy redirect is happening to get that error message?

    When some computers (like optiplex 380 for example) are told to network boot, but DHCP doesn’t give options 066 and 067, they will listen for a ProxyDHCP automatically and when that fails, they will says some message about no ProxyDHCP offers received. I’ve seen this at my house a few times when I’ve changed around DHCP / turned off dnsmasq. My living room computer is configured to try to boot to the network first.



  • @george1421 said:

    what is the IP address of the dhcp server listed?

    192.168.1.83


  • Moderator

    @Wayne-Workman On the plus side Arch:00000:UNDI:002001 is a BIOS client. Since I can review a pcap file from this computer, what is the IP address of the dhcp server listed? Does that match what the OP thinks the dhcp server is? And it still confuses me how/where the proxy redirect is happening to get that error message?



  • @george1421 @roee I looked at the file. There is only one DHCP server, but it is not handing out option 066 or 067

    The Vendor Class Identifier for the attempts that I see is PXEClient:Arch:00000:UNDI:002001

    So this is a legacy system, so you should set Option 067 to undionly.kkpxe and set option 066 to the FOG server’s IP address.


  • Moderator

    @roee Just for clarity, you don’t have any lingering older image deployment systems hanging about like acronis, altiris, windows deployment server, windows RIS do you? FWIW FOG doesn’t use ProxyDHCP unless you specifically configure it. So that’s why I think there is something else in your environment.


  • Moderator

    @Sebastian-Roth (a.k.a Mr PCap) when you have time your opinion please…



  • Well, did a clean install again.
    Option 66 and 67 applied. no option 60.
    Still the same thing.
    Client receives IP from DHCP but than this error: “PXE-55: ProxyDHCP service did not reply on port 4011”.
    Attached pcap file. I didn’t see anything out of the ordinary but I hope you will…
    0_1453907925957_pcap.pcapng

    thanks a lot you all!


  • Moderator

    @roee said:

    I feel like i’m missing something because when I boot a machine using its NIC it fails to reach PXE with the error “ProxyDHCP service did not reply on port 4011”.

    ** had the same issue when tried to work with Acronis PXE so its probably a very basic thing that I’m missing.

    These two statements makes me think there is something else in the environment that is sending proxy dhcp info (like dnsmasq or left over bits of some other imaging software). Especially since Acronis PXE was mentioned and also having the same exact issue. This is where a capture (pcap) of the dhcp startup dialog would tell us what actors are in play in the dhcp setup.



  • I decided to install the VM and Fog from scratch cause the web interface stopped accepting my login.
    I think I messed it up way too much…
    Will update.

    Thanks guys.



  • @Sebastian-Roth

    Thank you for the reply.
    My DHCP server is a Windows 2012R2. I tried setting up the the options but that didn’t cause to any different result.
    The fog and dhcp server are on the same subnet.
    According to the attached articles, I need to remove option 60, do I keep options 66 and 67?


  • Senior Developer

    @Sebastian-Roth To add on, from the sounds of this, I looked at the article pertaining to the “did not reply to request” and it would sound like maybe the systems are NOT on the same subnet/vlan in which case you’d need to add ip helpers to the switch to get them to look at the DHCP server to begin with.


  • Senior Developer

    @roee I’m very confused what you’re asking.

    What FOG is suggesting is absolutely needed. Microsoft has no idea what FOG is actually trying to do.

    From Microsoft’s perspective, you aren’t required to have option 60, 66, or 67, but for what it’s worth, FOG needs you to set 66 and 67. 66 Would be the IP/Hostname of the FOG Server, and 67 would be the bootfile (undionly.kpxe).

    Did you install FOG with DHCP service as well? Maybe they’re conflicting at this point. I don’t understand what Option 60 has to do with any of this though.


  • Senior Developer

    So what are you using as DHCP server? Sounds like it is Microsoft Server. Take a look at this: https://wiki.fogproject.org/wiki/index.php/Modifying_existing_DHCP_server_to_work_with_FOG

    Are DHCP server and client on the same subnet? Might this be helpful too? http://prajwaldesai.com/pxe-e55-proxydhcp-did-not-reply-to-request-on-port-4011/


  • Moderator

    Do you have a dnsmasq service or proxy dhcp service running somewhere?

    This makes me suspicious: [error “ProxyDHCP service did not reply on port 4011” ]

    For FOG you need option 66 set to the IP address of your FOG server and option 67 to point to the kernel you need to load probably undionly.kpxe

    If you have the skills probably the best thing to figure out what is going on is to create a pcap file of the dhcp process. What you want to do is setup the wireshark to listen on a mirrored port used by your test computer. Start wireshark scanning using the filter of bootp || tftp then boot the target computer via PXE. Once you have the pcap file then post it here. One of the devs here loves to read through pcap files. This will really tell us what is going on.



272
Online

7.2k
Users

14.4k
Topics

135.5k
Posts