Host pc/laptop not booting to the fog menu.



  • Hi guys,

    I am new to the fog system, so I built one on virtualbox to test it and it worked fine so now I built a fog server on an ubuntu 14.04 LTS, the config quite simple mostly by default dhcp and dns on another windows server so did the 66 & 67 job.

    what’s happening with me is the following when I boot the host laptop it looks like everything going well until it reach the ipxe initilizing and say about 30 seconds it reboot.

    I found the following errors under /var/log/syslog:

    n 19 18:24:06 fogcloningsrv-Precision-T1500 in.tftpd[22586]: tftp: client does not accept options
    Jan 19 18:24:06 fogcloningsrv-Precision-T1500 dhcpd: DHCPREQUEST for 172.19.51.136 (172.19.24.90) from 20:47:47:bc:9a:96 via eth0
    Jan 19 18:24:06 fogcloningsrv-Precision-T1500 dhcpd: DHCPACK on 172.19.51.136 to 20:47:47:bc:9a:96 via eth0
    Jan 19 18:24:11 fogcloningsrv-Precision-T1500 dhcpd: DHCPINFORM from 172.19.51.179 via eth0
    Jan 19 18:24:11 fogcloningsrv-Precision-T1500 dhcpd: DHCPACK to 172.19.51.179 (18:03:73:ce:da:34) via eth0
    Jan 19 18:25:15 fogcloningsrv-Precision-T1500 dhcpd: DHCPDISCOVER from 20:47:47:bc:9a:96 via eth0
    Jan 19 18:25:16 fogcloningsrv-Precision-T1500 dhcpd: DHCPOFFER on 172.19.51.136 to 20:47:47:bc:9a:96 via eth0
    Jan 19 18:25:19 fogcloningsrv-Precision-T1500 in.tftpd[22602]: tftp: client does not accept options
    Jan 19 18:25:19 fogcloningsrv-Precision-T1500 dhcpd: DHCPREQUEST for 172.19.51.136 (172.19.24.90) from 20:47:47:bc:9a:96 via eth0
    Jan 19 18:25:19 fogcloningsrv-Precision-T1500 dhcpd: DHCPACK on 172.19.51.136 to 20:47:47:bc:9a:96 via eth0
    Jan 19 18:25:20 fogcloningsrv-Precision-T1500 dhcpd: DHCPINFORM from 172.19.51.60 via eth0
    Jan 19 18:25:20 fogcloningsrv-Precision-T1500 dhcpd: DHCPACK to 172.19.51.60 (bc:30:5b:c9:ac:89) via eth0
    Jan 19 18:25:37 fogcloningsrv-Precision-T1500 dhcpd: DHCPINFORM from 172.19.51.179 via eth0
    Jan 19 18:25:37 fogcloningsrv-Precision-T1500 dhcpd: DHCPACK to 172.19.51.179 (18:03:73:ce:da:34) via eth0
    Jan 19 18:26:00 fogcloningsrv-Precision-T1500 dhcpd: DHCPINFORM from 172.19.51.152 via eth0
    Jan 19 18:26:00 fogcloningsrv-Precision-T1500 dhcpd: DHCPACK to 172.19.51.152 (18:03:73:be:b2:e8) via eth0
    Jan 19 18:26:28 fogcloningsrv-Precision-T1500 dhcpd: DHCPDISCOVER from 20:47:47:bc:9a:96 via eth0
    Jan 19 18:26:29 fogcloningsrv-Precision-T1500 dhcpd: DHCPOFFER on 172.19.51.136 to 20:47:47:bc:9a:96 via eth0


  • Moderator

    Lets try to get a little clarity around your setup here.

    You have install fog, is it safe to assume you installed 1.2.0, or did you install the current fog trunk version (i.e. pre 1.3.0)?

    Is it safe to assume you are using a Microsoft dhcp server? (your event log might suggest something different). One might think you have two dhcp servers covering the same subnet.

    What exactly did you set options 66 and 67 to?

    What is the IP address of your fog server?


  • Moderator

    @Abbas Those are messages, not errors. Your fog server is running DHCP, because those messages are from dhcpd. Did you want to run DHCP on your fog server?


Log in to reply
 

368
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.