Fail install on DHCP service installation 1.3.x



  • Hi,

    I’ve cloned fogproject through git. When I run install, the installation fails on starting up dhcp server (I’ve asked to install dhcp service as well)

    This is the error:

    /lib/common/functions.sh: line 238: let: octet4+=: syntaxerror: operator expected
    Could not find DHCP file
    

    (I’ve translated from dutch, so I hope the error is clear)-


  • Moderator

    @bakgat First look inside of /var/log You should see some files in there with the name fog_error_[version].log Errors from the installer are redirected to these files. Post the last few lines of those files (or the whole log). It’ll help with figuring out what’s going on.

    The dhcp configuration file on CentOS 7 / Fedora it’s located at /etc/dhcp/dhcpd.conf
    You might also try to install dhcp manually. on CentOS 7 and Fedora 19-21 you’d use yum install dhcp, on Fedora 22 and up it’s dnf install dhcp

    You might also see what is written for start and end ranges inside of /opt/fog/.fogsettings if that file exists.



  • @Wayne-Workman
    Thank you for the solution.
    I’ve added this manually. The error about the expected operator is clearly solved.

    But now I get

    Could not find dhcp config file
    

    when Fog tries to start DHCP



  • This post is deleted!

  • Moderator

    @Developers

    In your fog trunk directory: lib/common/functions.sh

    Line 1501

    Change it from:

    [[ -z $startrange ]] && startrange=$(addToAddress $network)
    

    To:

    [[ -z $startrange ]] && startrange=$(addToAddress $network 10)
    

    @bakgat You can do this manually if you want to get going right now, or you can wait for the next developmental push, which will likely be sometime today.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.