Dell optiplex 3020 "drmk v8.00 can't load kernel file"



  • Hello everybody,

    In my organization we have been using fog for about 2 years now, with its ups and downs, on about 700 PCs. Recently we needed to image a group of 20 new Optiplex 3020s and we used a Windows 7 image, that had previously worked on other machines.

    The image has been sysprepped and it contains some first-startup scripts, mainly for drivers and domain integration. It was not developed by me.

    After the imaging process, the computers all failed to boot to windows, displaying the message:
    “drmk v8.00 can’t load kernel file”

    Looking that up I found out it’s an issue with the default dell partition, which works in a way similar to the windows System Reserved partition.

    I have:

    • Successfully downloaded and imaged another (somewhat older) Optiplex 3020 with this image
    • Upgraded and downgraded the bios version on above said test machine, and it imaged correctly again
    • Used G-Parted to remove that partition and do a clean image on one of the “broken” machines - still problematic.
    • Ran dell diagnostics on an imaged computer - everything checks out
    • Few more small fixes I can’t really remember

    We have resorted to using just a bunch of HDDs and copying the image directly using 3rd party tools, but this is obviously not an ideal solution. So, the problematic situation has been solved (/avoided), but the original problem remains and I would like some ideas on the cause and what I may have done wrong.

    Some additional information:

    • The computers came prepackaged with an ubuntu 15.04 installation. I have seen mentions of others that after installing Ubuntu their problem came up.
    • They contained a small dell partition (~150MB) and all the rest of the disk was a single partition.
    • This is not the first time we have used such machines, nor is it the first time we have used this image.

  • Moderator

    While this doesn’t appear to be a FOG problem I did a quick google-fu search (as I’m sure you did).

    I did find this article. https://forum.acronis.com/forum/70905#comment-252812

    Can you confirm that post deployment the dell utility partition is marked as active as listed in the above post?

    As always, its helpful to know what OS you are trying to deploy and what version of FOG you are running (the numbers in the cloud on the FOG management page will tell us a bit more than just 1.2.0 or such)


  • Testers

    Have you tried dbaning the problematic machines, or even just a full wipe from FOG? I know that I have had issues before if the drive has some odd data on it. Also check the BIOS settings for UEFI/BIOS start up in each machine and match those settings.


Log in to reply
 

499
Online

39003
Users

10720
Topics

101771
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.