Imaging issue, dhcp server?



  • First of all: Happy New Year guys :) , now i have a problem you guys might give me a hint how to solve.

    I´m now testing trunk version , 5704 , every i want to image a client , i choose the image through quick image , select the image , then it gives me a black screen and freezes.This has to do with an external router that i have , because if i disable dhcp on that router works like charm.

    The thing is i need that routers dhcp enabled, please point me in the right direction how to solve this.

    thank you in advance


  • Developer

    @mitzayapa Great to see that you were able to fix this yourself. Looking at the packet dump helps quite often!



  • did that , nothing chages , it tries to pull default.ipxe from router 192.168.137.1

    what can i do ?

    here’s the tcpdump file if it helps.

    0_1453625717390_pxeboot.pcap

    nevermind, it works after

    cp /tftpboot/undionly.kpxe /tftpboot/undionly.0

    thread solved, thank you all for the help provided.


  • Developer

    @mitzayapa Looks like PXE information is being sent by your cable modem as well as dnsmasq. Please read through this post - from start to end (!): https://forums.fogproject.org/topic/6355/dnsmasq-proxydhcp-tries-to-pull-ipxe-default-from-wrong-ip

    We’ve been working on updating the embedded iPXE script and I thought we’ve got this solved by some checks. By the looks of your screenshot I guess that you don’t have the latest iPXE binaries installed. Just try downloading the latest undionly.kpxe on your FOG server:

    cd /tftpboot
    sudo mv undionly.kpxe undionly.kpxe.orig
    sudo wget -O undionly.kpxe "http://sourceforge.net/p/freeghost/code/HEAD/tree/trunk/packages/tftp/undionly.kpxe?format=raw"
    

  • Moderator

    @mitzayapa What OS are you running FOG on?

    Did you know you have to restart dnsmasq after every config change for those changes to take effect ?

    Ubuntu/Debian:
    service dnsmasq status
    service dnsmasq stop
    service dnsmasq start

    Fedora/CentOS/RHEL:
    systemctl status dnsmasq
    systemctl restart dnsmasq

    @mitzayapa said:

    Will dnsmasq affect the imaging speed?

    No, not at all.

    @mitzayapa said:

    This has to do with an external router that i have , because if i disable dhcp on that router works like charm.

    The thing is i need that routers dhcp enabled,

    Why? Just leave your FOG server on all the time and let it do DHCP. If you’re bothered by the power consumption, go get a $40 Raspberry Pi and setup DHCP on that, set it and forget it. Or go get an old flashable router at a yard sale or at the store for 30 bucks and flash it with DD-WRT and put that imediately behind your cable modem device, this will allow you control over DHCP. Or just a old computer always-on running Fedora or CentOS in the basement with just DHCP setup on it would do the job too.

    There are lots of options you can pursue.



  • The ip was ok.This is what it contains:

    
    #!ipxe
    cpuid --ext 29 && set arch x86_64 || set arch i386
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param platform ${platform}
    param product ${product}
    param manufacturer ${product}
    param ipxever ${version}
    param filename ${filename}
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain http://192.168.137.51/fog/service/ipxe/boot.php##params
    

  • Senior Developer

    @mitzayapa edit the file /tftp boot/default.ipxe and change the IP address to match your fog server. If it already matches then I don’t know how much further I can try to help. The router, at that point, is looking at itself for next-server.



  • hey guys ,
    so i’ve disabled fog’s DHCP , installed dnsmasq as instructed , but now i clients get can´t reach default.ipxe; for some reason it points at the dhcp cable-router.This is what i get:

    0_1452417566842_Sin título.jpg

    192.168.137.51 is the fog server (it has dhcp disabled)
    192.168.137.1 is the cable-router

    Will dnsmasq affect the imaging speed?(the cable-router is a 10/100)

    Sorry for replying so late , thanks for the enormous help provided.

    here’s what i have in /etc/dnsmasq.d/fog.conf :

    # Don't function as a DNS server:
    port=0
    
    # Log lots of extra information about DHCP transactions.
    log-dhcp
    
    # Set the root directory for files available via FTP.
    tftp-root=/tftpboot
    
    # The boot filename, Server name, Server Ip Address
    dhcp-boot=undionly.kpxe,,192.168.137.51
    
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    dhcp-no-override
    
    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Booting FOG Client", 1
    
    # The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    # Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    # This option is first and will be the default if there is no input from the user.
    pxe-service=X86PC, "Boot to FOG", undionly
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe
    
    dhcp-range=192.168.137.51,proxy
    


  • Any update on this @mitzayapa ?


  • Moderator

    @george1421 There is also this: http://sourceforge.net/projects/fogupdateip/?source=directory

    It will configure dnsmasq for you.

    And you could let your server receive DHCP for it’s address as well.


  • Moderator

    @mitzayapa said:

    I only have the cable-router and the fog server that provide dhcp service.

    IF these two dhcp servers are in the same broadcast domain (L2 network) you WILL have an issue. My recommendation is to disable the dhcp server in the FOG server. If your cable-router doesn’t support pxe booting (most don’t) then setup dnsmasq on your FOG server to fill in the missing bits.

    Here is something I put together for centos 7, if you are running ubuntu this can still get you started. https://forums.fogproject.org/topic/6376/install-dnsmasq-on-centos-7

    I was able to supply dhcp pxe boot information on my home kit using a linksys WRT54 internet router using the stock firmware and a fog server with dnsmasq enabled.



  • Sounds like you have your Fog Network on the same as your normal router that provides your internet. I would just use an extra NIC in your machine and set it to another IP Scheme. Then just use the one Gateway from your main router in order to access the internet on your server.

    Just a thought.


  • Senior Developer

    For further clarification, are both dhcp server’s trying to issue ip addresses within the same scope?


  • Senior Developer

    @mitzayapa So you have 2 dhcp servers in the same network?



  • I only have the cable-router and the fog server that provide dhcp service.


  • Senior Developer

    @mitzayapa I’m not asking if it can or can’t be disabled, you’ve already established that.

    Do you have another DHCP Server?



  • its a Thomson TWG870 cable-router that provides internet connection, i would disable the dhcp but i really can’t.It has to be enabled.


  • Senior Developer

    I don’t know what the router is. If turning off dhcp fixes it, do you have a secondary dhcp server running?


Log in to reply
 

462
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.