Stopping web service... Failed! during Storage Node install



  • Good afternoon and Merry Christmas (when it comes) to one and all.

    I’ve just tried installing new storage node (git version 4542) and it fails at this stage:

     * Skipping package: httpd.....................................(Already Installed)
     * Skipping package: php-process...............................(Already Installed)
     * Updating packages as needed.................................OK
    
      Confirming package installation.
    
     * Checking package: httpd.....................................OK
     * Checking package: php-process...............................OK
    
      Configuring services.
    
    
         What is the storage location for your images directory? (/images)
     * Setting password for FOG User...............................OK
     * New password set for:
                    username: fog
                    password: *************
    
     * Stopping web service........................................Failed!
    
    

    I’ve seen this post reference Centos 7 but this is on Centos 6.5. Despite that I did try solution from Wayne in the other call re installing as normal node up to php-fpm install then cancelling and reinstalling as storage node, didn’t work for me unfortunately.

    Has anyone else seen this and have any other suggestions at all?

    regards, Kiweegie.



  • @Wayne-Workman Hi Wayne, I had to give up on the Storage node set up and go with a separate Normal node as I need to get this back up and running sooner than later :)

    The node which is causing issue is the storage node for head office so I’m just going to set up that box as a normal node instead and split the roles so we have one node for head office and one for the remote sites. It may even make things simpler.

    I can spin up another Storage node at some point to aid in diagnosis of the original issue but for now my priority is getting our FOG solution back up and running again.

    regards Kiweegie


  • Moderator

    @Kiweegie What ever happened with the errors about TFTP and PXE?


  • Moderator

    @Kiweegie No its not hard. If you get it wrong, after you upload the image it will not be able to move it to the /images folder and on the target computer’s screen you will see unable to login to fog account with password xxxxx that gave me the idea to search the gui for the right password and update the fog user in linux.

    The best solution is for when the developers get back from holiday to fix the installer so it works right. But if you are in a tight spot and need it now this route will work.



  • @george1421 Hi George

    not difficult at all based on those instructions let me give that a crack.

    Kiweegie


  • Moderator

    Here is a bug for the normal node setup too. It says as you saw failed setting up storage. But if you run the installer a second time it will install OK.

    If you go this route, you will have to go into the fog settings and get the linux account information for the fog user. You will need to setup the linux password for the fog user to match what is configured in the fog database. It sounds hard, but just get the settings from the default storage node pane and then do a passwd fog xxxxxxxx from the console as root. Where xxxxxxx is the password gleaned from the storage node pane.



  • @George1421 Hi George thanks for the effort. I’d actually reinstalled FOG Storage Node again using Centos 6.5 before I saw your post. I’m seeing same error again but gratified its not just me…

    I thought about rebuilding this as a normal node instead and have one normal node to govern my remote sites and one for main office. I get a failure message on normal node set up too now.

     * Setting up storage..........................................Failed!
    

    GUI shows Storage nodes and Storage groups etc and seems to be editable so perhaps a red herring though I’ve found another post from yourself George with the same issue.

    I’m not going to throw too much more effort at new normal node setup for the time being and will sit tight hoping on resolutuion of the original storage node issue.

    regards Kiweegie.


  • Moderator

    The storage node also failed under centos 6.5 but at a different spot.

    * What is the storage location for your images directory? (/images)  
    * Setting up fog user............................................OK
    * Stopping web service........................................Failed!
    

  • Moderator

    @Kiweegie I will confirm on Centos 6.5 to save you time. I have a template already setup in ESXi to spin up a new instance. I just haven’t do this test yet. I’ll have a go-no answer for you in about 30 minutes.



  • Well just for giggles I tried this on a vanilla install of Ubuntu 14.04.3 with only SSH installed and got this

         What is the storage location for your images directory? (/images)
     * Setting up fog user............................................OK
    OK
     * Stopping web service........................................OK
     * Setting up Apache and PHP files.............................OK
     * Testing and removing symbolic links if found................OK
     * Backing up old data.........................................OK
     * Copying new files to web folder.............................OK
     * Creating config file........................................OK
     * Downloading inits, kernels, and the fog client..............OK
     * Enabling apache and fpm services on boot....................Failed!
    

    Assuming the installer should still work with Ubuntu this would look to be an issue with the FOG installer.

    I’m going to try minimal Centos 6.5 install next then Centos 7 though from Waynes comments he had same issue on a Centos 7 Storage node installation. What is different in the Normal vs Storage node installation that could cause this?

    regards Kiweegie.


  • Moderator

    @Wayne-Workman said:

    @george1421 a full install is fine. It’s the storage node install that fails. I had the exact same issue with a new CentOS 7 install

    Let me make sure i understand this. The issue is with the storage node install, right? If so I can spin up a new centos 6.5 instance in about 10 minutes. I can confirm this with a clean install if needed. But I’m not seeing this as an issue unless the FOG installer is bringing in other repositories. That also doesn’t explain how/who php5.6 is install on this target computer. Either way I can confirm this on a clean install.


  • Moderator

    @george1421 a full install is fine. It’s the storage node install that fails. I had the exact same issue with a new CentOS 7 install


  • Moderator

    @Kiweegie The error message says that you have php 5.6 installed on this system, additionally you have other repositories enabled for this client. I see epel and remi, rpmforge all enabled. This is the cause of the issue with this box you have conflicting packages.

    This part is a guess (although probably spot on) you are trying to install this RPM php-fpm which is for php 5.36 which is conflicting with 5.6. I would assume the right package for 5.6 is php56-fpm. This is not a FOG problem but a system owner issue (Merry Christmas). You probably have other stuff loaded on this FOG server that needed php5.6, which would explain the other repositories being loaded.

    I have FOG trunk running on Centos 6.5 without issue, including the trunk upgrades. My dev FOG environment is running Centos 7 without issue too. But in both cases I only have FOG running on these servers.


  • Moderator

    @Kiweegie said:

    Would you recommend I upgrade to Centos 7 going forward?

    Absolutely. Enjoy the Balvennie. :-)



  • @Wayne-Workman Hi Wayne, I’ve got Centos 6.5 on all the other FOG boxes (main server and 7 storage nodes plus this problem one). Would you recommend I upgrade to Centos 7 going forward? Good excuse to start playing with version 7 I guess but want to keep as close to FOG best practice as possible.

    Don’t expect to hear back from anyone til new year now. Go crack open a beverage of your choice (I’m leaning towards an 18 year old Balvennie myself) and have a great Christmas everyone… :)

    Cheers, Kiweegie.


  • Moderator

    @Kiweegie Hey great work so far, You figured out the php-fpm problem!

    The log files that you had to create manually are likely because CentOS 6.5 keeps it’s apache logs in a different place than CentOS 7 and late Fedora does. Not a big deal I guess - just means if you ever want to see apache errors you’ll have to go digging in the OS instead of using FOG’s built-in log viewer via the web interface. I suppose this isn’t too big of an issue, 6.5 is old and the @Developers barely have time to keep up with the latest distributions if you can understand, they are just volunteers with lives, families, and 40 hr a week jobs.

    for this issue:

     * Setting up and starting TFTP and PXE Servers................Failed!
    

    Look back in trunk/lib/common/functions.sh and look at lines 230 through 291, and remove the >/dev/null 2>&1 bits.

    As you know, that will allow you to see the output from the various commands and let you know exactly where it’s failing. I looked through that section of code and a lot is happening in there - we really need to see the output from all those commands before we can really know what’s going on.



  • Ok I restarted server and tried again, no longer hanging at Adding needed repository… but still hangs at Stopping web service…Failed!

    So I tried installing php-fpm manually which fails due to dependency

    # yum install php-fpm
    Loaded plugins: fastestmirror
    Setting up Install Process
    Loading mirror speeds from cached hostfile
     * base: mirror.mhd.uk.as44574.net
     * elrepo: lon.mirror.rackspace.com
     * epel: epel.check-update.co.uk
     * extras: mirror.ukhost4u.com
     * remi-safe: remi.check-update.co.uk
     * rpmforge: ftp.nluug.nl
     * updates: mirror.ukhost4u.com
    Resolving Dependencies
    --> Running transaction check
    ---> Package php-fpm.x86_64 0:5.3.3-46.el6_6 will be installed
    --> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_6 for package: php-fpm-5.3.3-46.el6_6.x86_64
    --> Finished Dependency Resolution
    Error: Package: php-fpm-5.3.3-46.el6_6.x86_64 (updates)
               Requires: php-common(x86-64) = 5.3.3-46.el6_6
               Installed: php-common-5.6.16-1.el6.remi.x86_64 (@remi-php56)
                   php-common(x86-64) = 5.6.16-1.el6.remi
               Available: php-common-5.3.3-40.el6_6.x86_64 (base)
                   php-common(x86-64) = 5.3.3-40.el6_6
               Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
                   php-common(x86-64) = 5.3.3-46.el6_6
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    
    

    So I tried installing php-common and got

    Package matching php-common-5.3.3-46.el6_6.x86_64 already installed. Checking for update.
    Nothing to do
    

    So it looks like the php-fpm FOG tries to install requires a lower version of php-common than is installed. So quick fix was to remove php-common then install php-fpm and let yum sort out dependencies.

    The install progresses further but again fails as follows.

     * Stopping web service........................................OK
     * Setting up Apache and PHP files.............................OK
     * Testing and removing symbolic links if found................OK
     * Backing up old data.........................................OK
     * Copying new files to web folder.............................OK
     * Creating config file........................................OK
     * Downloading inits, kernels, and the fog client..............OK
     * Enabling apache and fpm services on boot....................OK
     * Creating SSL CA.............................................OK
     * Creating SSL Private Key....................................OK
     * Creating SSL Certificate....................................OK
     * Creating auth pub key and cert..............................OK
     * Resetting SSL Permissions...................................OK
     * Setting up SSL FOG Server...................................OK
     * Restarting Apache2 for fog vhost............................OK
     * Changing permissions on apache log files....................chmod: cannot access `/var/log/httpd/error_log': No such file or directory
    chmod: cannot access `/var/log/httpd/access_log': No such file or directory
    OK
     * Setting up storage..........................................Failed!
    

    So I created the missing file - actually 2 files as it also failed asking for error_log too.

    touch /var/log/httpd/access_log
    touch /var/log/httpd/error_log
    

    Then re-ran installer which now runs all the way through but finally fails at this:

     * Setting up storage..........................................OK
     * Setting up and starting TFTP and PXE Servers................Failed!
    

    I found a couple of links on the forum with this error but neither had solutions which worked for me. Specifically this link and this one.

    Hopefully someone will see this post holidays and have a solution.

    regards Kiweegie.



  • Thanks Wayne

    Think systemctl is a systemd command so works on Centos 7 but not 6.5. I tried just running service httpd stop and service php-fpm stop but errored out saying httpd not running and php-fpm not installed.

    I’ve therefore removed the >/dev/null 2>&1 bits from lines 943, 946, 948, 949 in trunk/lib/common/functions.sh and re-ran installer but now just hangs at this.

      This script should be run by the root user on Fedora, or with sudo on Ubuntu.
    
    
      Here are the settings FOG will use:
             Base Linux: Redhat
             Detected Linux Distribution: CentOS
             Installation Type: Storage Node
             Server IP Address: <storage_node_IP>
             Interface: eth0
             MySql Database Host: <Main_FOG_Server_FQDN>
             MySql Database User: fogstorage
             MySql Database Password: [Protected]
    
    
      Are you sure you wish to continue (Y/N) y
    
      Installation Started...
    
      Installing required packages, if this fails
      make sure you have an active internet connection.
    
     * Adding needed repository....................................
    

    I have to do CTRL+C to terminate the installation at this point.

    regards Kiweegie


  • Moderator

    remove the >/dev/null 2>&1 bits inside of trunk/lib/common/functions.sh

    This will allow you to see the errors. You’ll be working in lines 943, 946, 948, 949 (for svn 4566).

    But most likely, php-fpm (or php5-fpm) isn’t installed.

    If you don’t want to edit those lines, you can just execute those lines manually like this:

    Not sure which ones apply to CentOS 6.5 but no harm in running them all.

    systemctl stop apache2 php5-fpm
    systemctl stop httpd php-fpm
    service httpd stop
    service php-fpm stop
    

Log in to reply
 

508
Online

39008
Users

10722
Topics

101856
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.