Need help installing and running FOG 1.2.0 on Ubuntu 15.10 Desktop



  • First off let me explain what type of hardware/software I have and currently using.

    Hardware: HP EliteBook 2540p ( I have access to others but using this one due to its i7 processor)
    Cisco Catalyst 3560 Series PoE-24 Switch

    Software: Ubuntu Desktop 15.10
    DBAN 2.3.0

    I’m trying to set up a simple PXE Server to wipe machines when connected.

    I followed the instructions from the this video

    The problem is on the laptop when setting my static IP the controller shows (enp0s25) instead of (etho)

    Next setting the IP’s, I’m confused as to what range I have to enter. Cause I have two sets of ranges. The Cisco switch is pushing out a 10.130.8.1 while I’m getting a 169.254.5.132 from the controller on the laptop.

    I followed the instructions through to the part where its says press enter for the default information I get past that for the web server part. I try to load the dban.iso in but the limit is 8MB and the iso is 16MB. I see that in the Group Management it has it own options to deploy various wipes.

    When I have the group set I start up the client. It loads up and searches for the PXE Server but is unable to find it. Fails and returns to its post boot screen.

    I’m at a lose as to what to do. Can anyone plz assist? Thanks in advance


  • Moderator

    @Wallae said:

    I’ve tired uploading the DBAN.iso(16MB) to the server but the limit of 8MB is stopping me from doing so.

    What are you using to upload? Where is there an 8MB limit?


  • Moderator

    @Wallae said:

    I believe you have the EFI version of Ubuntu installed. I only really have experience with the regular (old style) one, since I experienced too many issues with it when I tried it out.

    As far as I know, they changed the way they manage interfaces slightly, so I’m guessing there will be a file under /etc/network/interfaces.d that you need to edit instead.



  • @Wallae

    when I do the sudo vi /etc/network/interfaces command I get

    E325: Attention
    Found a swap file by the name "/etc/network/.interfaces.swp"
    owned by: root dated: Wed Dec 16 05:45:29 2015

    its asking me to either delete it or recover it.



  • @Quazz

    When I do it on the machine with the server I see

    if-down.d  if_post-down.d  if-pre-up.d   interfaces   interfaces.d  run
    

  • Moderator

    @Wallae Can you do

    sudo ls /etc/network
    

    And tell us if there are any files there? There should always be an interfaces file there, but it may have been pushed to interfaces.bak in which case do…

    sudo mv /etc/network/interfaces.bak /etc/network/interfaces
    


  • @Quazz

    I used this guide and used Ubuntu Server 14.04 LTS. Problem is when I did the sudo vi /etc/network/interfaces command to edit the IP schema I get a blank page with nothing on it. Most of the parts I have to configure are not showing up when I try to edit them. So starting off it is starting bad. I will re-install the server again and try again with that one on a different machine.



  • @Quazz

    For test propuses and to fix this issue, I’m going to use a basic netgear switch. A Host PC and a Client PC, this way I can follow the instructions to the letter and have the Host running. As far as loading an image to push down to the clients how would I go about doing that?


  • Moderator

    @Wallae said:

    If you want to get the old naming scheme (eth0, eth1, etc) do the following in terminal

    sudo apt-get remove biosdevname
    
    sudo update-initramfs -u
    

    You will need to reboot after.

    As for installation guides

    https://forums.fogproject.org/uploads/files/1443813159297-imaging-server.pdf

    is generally considered one of the best ones even if some things may not apply to your specific situation, it should help you get started at least.

    I highly recommend getting a static IP at any rate.



  • @Sebastian-Roth
    Sorry for the long wait, was out for the weekend. At this time I cannot provide a screenshot of the settings. I will try to take photos with my phone. I was able to make the change in editing the connections for the Ethernet port. When selecting the type of IPv4 connection I saw “Local Link” in the selection among Automatic, Manual, Local Link, etc.

    The Cisco switch I’m working with has been configured to allow port 1 to hand out IP’s. As for the 10.130.8.1 IP that is from a mistake I made when figuring out which port to connect to on the switch.

    The role of DHCP has not been configured on the FOG Server as I’ve been having issues with it. So I have did not install it when installing the FOG Server.

    The issue I’m having now is that the image I’m trying to push down to the clients is not being pushed. The clients see the PXE Server and await for a command from the server. I have tired to use the built in programs of the FOG Server but they do not seem to work. I’ve tired uploading the DBAN.iso(16MB) to the server but the limit of 8MB is stopping me from doing so.


  • Developer

    @Wallae said:

    Next setting the IP’s, I’m confused as to what range I have to enter. Cause I have two sets of ranges. The Cisco switch is pushing out a 10.130.8.1 while I’m getting a 169.254.5.132 from the controller on the laptop.

    Hey, welcome to the FOG community. Those 169.254.x.x are local-link addresses (see here: https://en.wikipedia.org/wiki/Link-local_address). Clients choose those addresses when they are not able to get a proper one from the DHCP server.

    Ok soo shortly after posting this I changed the Ethernet settings to Local Link and it worked.

    Where exactly did you change this setting? Maybe provide a photo of the settings screen so we know what you are talking about.

    The main question is: Who (which devices) is actually playing the DHCP role aka who is handing out IP addresses to the clients?? With the FOG installer you can choose to have it setup a DHCP server on the FOG server or not. What do you mean by “The Cisco switch is pushing out a 10.130.8.1”??



  • Ok soo shortly after posting this I changed the Ethernet settings to Local Link and it worked. The PXE Server is now being seen by the other clients when booted up. The only problem is now the PXE Boot Menu doesn’t show up when it boots to it. Also it resumes its regular post boot process shortly after.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.