Upload never gets moved out of the /images/dev/#### folder



  • My setup:
    Ubuntu 14.04 LTS
    I have an external USB drive plugged in and mounted to /media/external with the entry in fstab
    I have deleted the default storage node and added one called usb with the localhost ip address and the path /media/external
    The fog user account on Linux was changed to a new password and that password was updated in both the storage entry and the TFTP setting. I also for good measure set the same password to the fog webpage account.

    I finally got things working to a point, but when I do an image upload it goes to the /images/dev/{DeviceID} folder and stays there. The job seems complete and there are no errors. I have read many articles and have made sure that the folder is owned by fog and that chmod is 777. I have tested FTP with the fog user and it comes up just fine… Not sure where to go from here…

    Also I don’t think related, I have to start dhcpd after each reboot and RESTART tftp each reboot for them both to work. (I assume it’s a separate issue and can open a different thread for them).



  • @TThax use the ? to get the image listing. upgrading fog resets the image numbers. If using one of the listed numbers doesn’t work, it’s a bug. Post the issue in bug reports. (This is a fine example of what a “minor” bug is)



  • @Wayne-Workman

    Actually, one more quick question. When I do a full host registration now, and I select the image number. It isn’t saving what image I selected, and I have to go into host management and select it in there. What would cause that?



  • @Wayne-Workman

    Good to know!

    Also, I have now uploaded 3 images and they are all working perfectly. Thanks again for all of your help!



  • @TThax Web browsers auto-fill functionality is the cause of this most of the time. It’ll fill in a blank field with what should be there, most of the time… but it’s not actually set.

    Those fields in fog are configured to tell browsers to not auto-fill them, but Chrome seems to not care about these requests.



  • @Wayne-Workman

    It makes me feel really dumb too, but in fairness, the password WAS correct there. I just deleted and retyped it and it worked.



  • @TThax said:

    @Wayne-Workman

    The strange thing is that the password was correct, but I went ahead and deleted and retyped it, and now it works. So bizarre. Thanks so much for your help! I bet the next upload works just fine.

    Good lord, if that was the problem the whole time, that makes me feel really dumb.

    Well, enjoy fog trunk! Fee free to comment on your experience, don’t hesitate to come report bugs or ask for help (not saying you’ll have a lot, but it’s just good manners to make you feel welcome).



  • @Wayne-Workman

    The strange thing is that the password was correct, but I went ahead and deleted and retyped it, and now it works. So bizarre. Thanks so much for your help! I bet the next upload works just fine.



  • @TThax said:

    FOGFTP: Login failed. Host: 10.1.1.42, Username: fog, Password: , Error: ftp_login(): Login incorrect.

    If that’s the actual error and you haven’t edited it,

    Your issue is… somehow you have no password stored in your storage settings.

    Look inside of Storage Management -> [your storage node name] -> Password.

    Really watch to make sure auto-compete isn’t changing things when you update that password.



  • @Wayne-Workman

    Still having an ftp issue… When I enabled that option, in that column I get:

    FOGFTP: Login failed. Host: 10.1.1.42, Username: fog, Password: , Error: ftp_login(): Login incorrect.

    I checked FOG Configuration -> FOG Settings -> TFTP Server FOG_TFTP_FTP_USERNAME and FOG_TFTP-FTP_PASSWORD and those are correct.

    /opt/fog/.fogsettings did not change anything with this update, and on the troubleshoot ftp page, it says FOG 1.3 should have storageftpuser & storageftppass is it a different file path for an updated .fogsettings file, or do I need to update the old file somehow?



  • @TThax In fog 1.3.0, that feature is turned off by default to improve performance of the image management page. You can turn it on inside FOG Configuration -> FOG Settings -> General Settings -> FOG_FTP_IMAGE_SIZE



  • @Wayne-Workman

    Ok, upgrade complete. In the Image Management screen, it shows Image size: ON CLIENT, but now there isn’t even a column for Image Size: ON SERVER. How would I know if it is recognizing the images?



  • @TThax said:

    @Wayne-Workman

    Forgive my ignorance, but how do I do that? Also, will I lose my current images?

    Pick a method from here, I’d recommend git or svn: https://wiki.fogproject.org/wiki/index.php?title=Upgrade_to_trunk

    You shouldn’t loose anything, db data, images, configuration in /opt/fog/.fogsettings. it all gets carried over.



  • @Wayne-Workman

    Forgive my ignorance, but how do I do that? Also, will I lose my current images?



  • @TThax 14.04 would work better with fog trunk. Seeing how you currently do not have a working fog server, would you be willing to update and try it out?



  • @Wayne-Workman

    It used to work on my old FOG server. The computer took a dump, so I made a new one. I set it up the same way as the old one, except I used Ubuntu 14.04 instead of 12.xx. I copied a couple of images from the old hard drive onto this one, did the permissions change and all that, and new images have never successfully transferred on this machine.



  • @TThax Your problem is absolutely related to FTP not being able to do what it’s supposed to do.

    Let’s go back to the basics… Did it ever work? When did it stop working?



  • @Wayne-Workman

    Ok, after I moved it, I checked permissions and it showed fog fog. I did chmod and chown and now it shows fog root. I still get no size. I’ll show you what I mean. 1_1453308453352_permissions.PNG 0_1453308453342_Image sizes.PNG

    If I get it deployed using task management, it will show an image size on client, but it still doesn’t realize there is an image on the server.



  • @TThax said:

    When I move it manually, it shows “Image size: ON SERVER 0.00iB”

    Check permissions and ownership of the directory after you move it.



  • @Wayne-Workman

    I’m not too opposed to just moving it manually, but is there a way to get FOG to recognize that it is there? When I move it manually, it shows “Image size: ON SERVER 0.00iB”


 

628
Online

5.4k
Users

12.6k
Topics

118.9k
Posts