SOLVED [git 5736] Snap-in installation failes when using sfx files

  • All my sfx snap-ins that previously worked will no longer install. These snap-ins are set to execute an installation script after the files have been extracted. FOG successfully downloads the sfx file and runs it, but nothing happens; the installation script never runs and no files are installed. I can see the sfx file in the fog/tmp folder, and I can find the process in Task manager, but it never finishes installing. I have to restart the computer to get the process to clear out of Task manager.

    These sfx files work correctly if they are run manually on the client computers, and FOG had been installing them correctly up until recently (although I couldn’t tell you exactly at what revision they stopped working). So I think it may have something to do with the FOG client. Also, any snap-in that uses a standard exe/msi still works fine.

  • @Brian-David we have Avast enterprise deployed at work. Although I’ve not been able to test the new client with it yet - I’m having issues just uploading a snapin:

  • @Hanz To be honest, I couldn’t tell you. In the past, Avast has let these snap-ins run after an initial ‘deep-scan’. At this point, it just seem so be cutting them off without any sort of warning or indication. I’ve had to set an exclusion for the FOG directory on all our workstations in order to guarantee that the snap-ins run. There have been some recent updates to Avast, so perhaps the way it treats these files has changed.

  • Senior Developer

    @Hanz the best guess I can give is the way sfx files are created. Exes request the permission as needed but snapins run from the system account. So because the sfx was running to get an elevated account even though it was already running as an elevated account the antivirus was blocking the snapin to prevent unauthorized access. I hope that makes sense.

  • @Brian-David What was it exactly that was stopping the sfx, but not regular exe 's

  • @Brian-David Don’t feel bad. I raise false alerts sometimes too. The important thing is that you come back here and own up to it. Again, I’ve done this a few times.

  • This also turned out to be due to our anti-virus settings. So let this be a lesson to us all; check your anti-virus first! 🙂

    This can be marked as fixed.