SOLVED [git 5736] FOGTray no longer starts up

  • I cannot get the FOG Tray (with client version 0.9.9) to start up. I have experienced this now with two machines: one Windows 8.1; and one Windows 7 (new install). In both instances, when installing the client, I made sure to select to have FOG Tray run. The FOG Service itself starts up fine and the logs show regular communication with the server.

    I wish I had more to go on, but I cannot find any errors in the Windows or Fog logs. Furthermore, if I start the FOGTray.exe from cmd.exe, the application shows up in Task manager, but the icon never appears in the tray.

  • This turned out to be our anti-virus program blocking the FOG executables. I really should have checked that first.

    This can be marked as solved.

  • Senior Developer

    @Brian-David that indicates you have an incomplete installation. When you get time if you can send me a chat with a teamviewer session I may be able to help.

  • @Jbob I don’t see a ‘Tray’ key under HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\FOG. All I see is ‘gracePeriod’ and ‘Sleep’.

  • Senior Developer

    @Brian-David that shortcut should not exist. FOGUserService is responsible for starting the tray. What is the registry value of

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\FOG\Tray If you are on a 32 bit system, remove the Wow6432Node.

  • @Tom-Elliott I did remove the legacy service fully. The new client had been working fine up until I upgraded from 0.9.7 to 0.9.9. It was at that point that these issues started popping up.

    The shortcuts in the Startup folder were indeed not there on either machine. I put them in manually, but this has not fixed the issue; FOGTray.exe is still not starting up.

  • Senior Developer

    @Brian-David Did you remove the legacy service fully before installing 0.9.9?

    Is the Program Files\Startup\tray.exe shortcut still there?

    I think you can check in:

    c:\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp

  • Okay, I jumped the gun on my earlier post; the FOG User Service IS updating the log on the Windows 7 machine, so it does seem to be running even though the tray icon is still not showing up.

    The Win 8 machine does not seem to be running the user service at all.

  • @Jbob Sorry it took a while to get back to you, I usually have the middle of the week off.

    Okay, I looked for the user service and found some strange things:

    1. On the Windows 7 machine, 3 instances of FOGUserService.exe show up under the Processes tab (but not under Applications or Services). However, the last activity I see in the user service log is from Dec. 13th, so it doesn’t appear to be currently running.

    2. On the Windows 8 machine, I do not see FOGUserService anywhere (except the Startup tab, of course). Similar to the Win 7 machine, this one has no activity in the log since Dec. 13th.

    I know I did do a git pull on that day, but I couldn’t tell you from what version to what version. The last time I did a pull was on Monday.

  • Senior Developer

    Can you check if a “FOGUserService” process is running when you log in?

  • Yes. That is the first thing I do after installation.

  • Senior Developer

    Are you restarting the computer after installing the client?