Private Key Failed - New FOG Client



  • SVN 4520 Cloud 5698
    Fedora 23 Server

    0_1449771638954_fog.log

    This server was migrated from Fedora 21. I may or may not have done everything right…

    The new server has the same IP as the old one, I copied over the /opt/fog/snapins/ssl directory to the new server but later found out that there was a cert in /var/www/html/fog/management/other/ssl/srvpublic.crt that was needed.

    To fix that earlier error, I’ve set the CaCreated=“No” and re-ran the fog installer, and then I’ve uninstalled and re-installed the New Fog Client version 0.9.9 onto this Windows 7 laptop a few times with no luck.

    @Developers



  • Got this solved.

    I removed both the CA and ssl directories totally, and then reran the installer with the recreate ca and ssl keys arguments, reinstalled the client once more and one reboot later, it’s working.

    rm -rf /opt/fog/snapins/CA
    rm -rf /opt/fog/snapins/ssl
    ./installfog.sh -yCK

    @Developers I wonder if the installer properly removes the old stuff when the -CK arguments are used?



  • Still not having luck…

    I’ve ran ./installfog.sh -C and ./installfog.sh -CK

    I’ve uninstalled, rebooted, and reinstalled FOG Client version 0.9.9 several times. The logs say this now:

    0_1449774882759_fog.log



  • So - to migrate correctly, you must copy /opt/fog/snappins/ssl and /opt/fog/snapins/CA

    If you don’t care about maintaining control of clients and don’t care about having to reinstall the fog client on every machine to re-gain control (or imaging them) then you can use ./installfog.sh -CK



  • @Tom-Elliott Forgive me for not knowing, exactly what am I copying and to where?


  • Senior Developer

    @Wayne-Workman Because the original install likely created a certificate pair based on the then proper private key, and you replaced it, I would actually recommend rerunning the FOG installer. CACreated=NO will overwrite the CA. SO you need to set CACreated=“Yes”, then copy over the snapins/{ssl,CA} then rerun the installer.


 

519
Online

41.8k
Users

12.3k
Topics

116.0k
Posts