HP Z640 - NVME PCI-E Drive


  • Testers

    Hi Friends,

    We just got these new Z640 workstations and they come with these NVME 256GB SSDs plugged into a pci-e slot.
    They show up in the bios, and when I boot to fog and check compatibility and partition information it says it’s compatible and all the partition info pops up no problem. One possible issue is that it assigns it to something like /dev/nvme instead of the standard /dev/sda

    But then when I try to image or even just do a hardware inventory, FOG gives me a “HDD not found on system” error and then reboots after 1 minute.

    Is this something that just isn’t supported? Do I need to enable something in a custom kernel? What am I missing here?

    Thanks,
    -JJ

    P.S.
    Fog info
    Version svn 5676
    bzImage Version: 4.3.0
    bzImage32 Version: 4.3.0


  • Testers

    @Tom-Elliott Yes, I just did. I marked it as unsolved when it broke again.


  • Senior Developer

    @Arrowhead-IT is it safe to remark as solved?


  • Testers

    @Arrowhead-IT said:

    I’m about to test upload on the updated version.

    Great success, forgot to post that this worked.

    All is working as of 6050


  • Testers

    @Wayne-Workman Oh trust me I value my sleep. I just had to move my desk at the odd request of upper management (I won’t get into that…) But the new placing of my desk makes it so the lights in the room and the light from the monitor hits my eyes just right. And by just right, I mean just right for excruciating melting eye pain. And this made it more difficult to sleep and made me want to close my eyes all day. I fixed the lighting issue though. But point is, trust me I know, I don’t sacrifice sleep, I have had to have sleep studies and fun stuff like that. This situation was just forced upon me.

    Thanks for the good advice though. I always enjoy a good sleep success story.


  • Moderator

    @Arrowhead-IT said:

    because I’m dumb when I’m sleepy.

    You’re not the only one. Number 1 piece of advice I give to college kids, athletes, and just every day people is don’t sacrifice your sleep.

    Short story - I was going through studying for finals in college one semester, staying up late, getting up early for work. Trying to find time to code a custom price markup management piece of software for a business that wanted to further save more paper. Basically double columns of data per page, like rows 1-80 on the left, 81 through 160 on the right, then on the back of the page, and so on…

    I kept screwing it up… couldn’t get the math right. And yes, there’s algebra involved with this problem. I spent days on this. Just couldn’t get it.

    Then, instead of continuing to pound at it, I realized I was really really tired, and I needed to sleep. I took a nap for 3 or 4 hours. When I woke up, I solved the problem in 5 minutes.

    Sleep… so important. Sleep deprivation makes you dumb. You become mentally exhausted, just as you can physically. Physically, your body will be less strong, able to go less distance, lift less weight. Mental exhaustion means your not as clear, don’t have as good memory, not as good focus or attention to detail, and not so creative and not so good at solving problems.

    People brush off sleep like it’s un-necessary. These are the people that consistently unperform, or just barely make par. Really, really value your sleep!


  • Testers

    @Arrowhead-IT Sorry for the delay, my btsync stopped working, still not working and then I broke my local git repo…like 30 different times because I’m dumb when I’m sleepy. Dumb like trying to reset my git repo to the master branch instead of the dev-branch and wondering why it was installing a version in the 3000’s. Fun fact, if you can’t git pull, try git fetch --all && git reset --hard origin/dev-branch But anyway back to working correctly and on 6050

    Resizable download is working again, hooray!
    I did try running fog.upload from the download debug session. But I then redid it in an upload debug session and the same error happened. I’m about to test upload on the updated version.



  • @Tom-Elliott

    All good here Tom, just got r6050 and it works!


  • Developer

    @Arrowhead-IT said:

    The following is the full output (run from ssh) including the looping error once it tried to enter partclone

    From what I can see in the listing this is not resizeable. I mean if I look at the scripts “Restoring Partition Tables (MBR)” should never happen if resizeable image type is selected.

    Failed to create image upload path (prepareUploadLocation)
    

    And now the other one. Hmm??? At this stage FOG just tries to create a folder on the mounted NFS share (which lies on your FOG server). Why would that fail?? Permissions? But then, why does MPS work? I am confused.
    Edit: Might be because you tried uploading in a download debug session…?? (thanks to Tom!)


  • Senior Developer

    @FlowLive Please update and test again. I’m fairly confident that this is fixed now.



  • @Arrowhead-IT

    I don’t want to hijack this thread but I believe I am having the same problem running trunk r6048.

    Here’s a screenshot of the errors

    link


  • Senior Developer

    @Arrowhead-IT I believe the upload issue you’re seeing is simply because you’re debug session is in download mode.

    Why is this important? Because the directory that get’s mounted varies depending on the type of image.

    Seeing as the images directory is already created and most likely mounted for the download mode, this would be an expected failure, I would think.


  • Senior Developer

    @Arrowhead-IT Uploaded and ready for testing whenever you are.


  • Senior Developer

    @Arrowhead-IT I found the problem with downloads. I’ll look at the uploads shortly.

    I’m rebuilding the init’s and will upload them shortly. I’ll let you know when they’re ready.


  • Testers

    Resizable download is giving the same error on normal sda.
    So there is most likely a problem with this version of FOG
    Help me obiwan- @Tom-Elliott -nobi, you are my only hope


  • Testers

    Download and Upload of mps are still working perfectly. It’s just resize that is having trouble.
    I am going to try a normal sda vm resizable download to see if this is an nvme problem or a fog init code problem


  • Testers

    @Tom-Elliott
    This is the output of the upload from the same debug session

    # fog.upload
       +------------------------------------------+
       |     ..#######:.    ..,#,..     .::##::.  |
       |.:######          .:;####:......;#;..     |
       |...##...        ...##;,;##::::.##...      |
       |   ,#          ...##.....##:::##     ..:: |
       |   ##    .::###,,##.   . ##.::#.:######::.|
       |...##:::###::....#. ..  .#...#. #...#:::. |
       |..:####:..    ..##......##::##  ..  #     |
       |    #  .      ...##:,;##;:::#: ... ##..   |
       |   .#  .       .:;####;::::.##:::;#:..    |
       |    #                     ..:;###..       |
       |                                          |
       +------------------------------------------+
       |      Free Computer Imaging Solution      |
       +------------------------------------------+
       |  Credits: http://fogproject.org/Credits  |
       |       http://fogproject.org/Credits      |
       |       Released under GPL Version 3       |
       +------------------------------------------+
       Version: 6048
     * Press [Enter] key to continue
    
     * Verifying network interface configuration.........Done
     * Press [Enter] key to continue
    
     * Checking Operating System.........................Windows 8.1
     * Checking CPU Cores................................8
     * Send method.......................................NFS
     * Attempting to check in............................Done
     * Press [Enter] key to continue
    
     * Mounting File System..............................Done
     * Press [Enter] key to continue
    
     * Checking Mounted File System......................Done
     * Press [Enter] key to continue
    
     * Checking img variable is set......................Done
     * Press [Enter] key to continue
    
     * Preparing to send image file to server
     * Preparing backup location.........................Failed
     * Press [Enter] key to continue
    
    ##############################################################################
    #                                                                            #
    #                         An error has been detected!                        #
    #                                                                            #
    ##############################################################################
    Failed to create image upload path (prepareUploadLocation)
     * Press [Enter] key to continue
    
    

  • Testers

    @Tom-Elliott
    On version 6048 I did a debug download of a resizable image
    The following is the full output (run from ssh) including the looping error once it tried to enter partclone
    It did not seem to ever exit the error loop no many how many steps. It got stuck in this same loop on 6040 in a quickimage and never exited, so I updated and ran it in debug

     # fog
       +------------------------------------------+
       |     ..#######:.    ..,#,..     .::##::.  |
       |.:######          .:;####:......;#;..     |
       |...##...        ...##;,;##::::.##...      |
       |   ,#          ...##.....##:::##     ..:: |
       |   ##    .::###,,##.   . ##.::#.:######::.|
       |...##:::###::....#. ..  .#...#. #...#:::. |
       |..:####:..    ..##......##::##  ..  #     |
       |    #  .      ...##:,;##;:::#: ... ##..   |
       |   .#  .       .:;####;::::.##:::;#:..    |
       |    #                     ..:;###..       |
       |                                          |
       +------------------------------------------+
       |      Free Computer Imaging Solution      |
       +------------------------------------------+
       |  Credits: http://fogproject.org/Credits  |
       |       http://fogproject.org/Credits      |
       |       Released under GPL Version 3       |
       +------------------------------------------+
       Version: 6048
     * Press [Enter] key to continue
    
     * Verifying network interface configuration.........Done
     * Press [Enter] key to continue
    
     * Checking Operating System.........................Windows 8.1
     * Checking CPU Cores................................8
     * Send method.......................................NFS
     * Attempting to check in............................Done
     * Press [Enter] key to continue
    
     * Mounting File System..............................Done
     * Press [Enter] key to continue
    
     * Checking Mounted File System......................Done
     * Press [Enter] key to continue
    
     * Checking img variable is set......................Done
     * Press [Enter] key to continue
    
     * Attempting to send inventory......................
    
    Done
     * Press [Enter] key to continue
     * Using Image: ResizableNVMEUpTest
     * Looking for Hard Disk.............................Done
     * Press [Enter] key to continue
     * Using Disk: /dev/nvme0n1
     * Checking write caching status on HDD..............Enabled
     * Press [Enter] key to continue
    
     * Preparing Partition layout
     * Wiping /dev/nvme0n1 partition information
     * Erasing current MBR/GPT Tables....................
    Done
     * Press [Enter] key to continue
     * Creating disk with new label......................Done
     * Press [Enter] key to continue
    
     * Initializing /dev/nvme0n1 with NTFS partition.....Done
     * Press [Enter] key to continue
    
     * Formatting initialized partition..................Done
     * Press [Enter] key to continue
    
     * Erasing current MBR/GPT Tables....................Done
     * Press [Enter] key to continue
    
     * Restoring Partition Tables (MBR)..................Done
     * Press [Enter] key to continue
    
     * Inserting Extended partitions.....................Done
     * Press [Enter] key to continue
    
     * Attempting to expand/fill partitions..............Done
     * Press [Enter] key to continue
    
       +--------------------------------+
       |  Attempting to download image  |
       +--------------------------------+
       |         Using Partclone        |
       +--------------------------------+
    
    
    Problem opening ############################################################################## for reading! Error is 2.
    The specified file does not exist!
    Problem opening ############################################################################## for reading! Error is 2.
    The specified file does not exist!
    
     * Processing Partition: ############################################################################## ()
    
     * Partition File Missing: /images/ResizableNVMEUpTest/d1p.img*
    error: ##############################################################################: No such file or directory
    Problem opening ############################################################################## for reading! Error is 2.
    The specified file does not exist!
    Problem opening ############################################################################## for reading! Error is 2.
    The specified file does not exist!
    
    error: ##############################################################################: No such file or directory
     * Not expanding (############################################################################## -- imager)
     * Press [Enter] key to continue
    
     * Press [Enter] key to continue
    
    
    Problem opening # for reading! Error is 2.
    The specified file does not exist!
    Problem opening # for reading! Error is 2.
    The specified file does not exist!
    
     * Processing Partition: # ()
    
     * Partition File Missing: /images/ResizableNVMEUpTest/d1p.img*
    error: #: No such file or directory
    Problem opening # for reading! Error is 2.
    The specified file does not exist!
    Problem opening # for reading! Error is 2.
    The specified file does not exist!
    
    error: #: No such file or directory
     * Not expanding (# -- imager)
     * Press [Enter] key to continue
    
     * Press [Enter] key to continue
    
    
    Problem opening # for reading! Error is 2.
    The specified file does not exist!
    Problem opening # for reading! Error is 2.
    The specified file does not exist!
    
     * Processing Partition: # ()
    
     * Partition File Missing: /images/ResizableNVMEUpTest/d1p.img*
    error: #: No such file or directory
    Problem opening # for reading! Error is 2.
    The specified file does not exist!
    Problem opening # for reading! Error is 2.
    The specified file does not exist!
    
    error: #: No such file or directory
     * Not expanding (# -- imager)
     * Press [Enter] key to continue
    
     * Press [Enter] key to continue
    
    
    Problem opening # for reading! Error is 2.
    The specified file does not exist!
    Problem opening # for reading! Error is 2.
    The specified file does not exist!
    
     * Processing Partition: # ()
    
     * Partition File Missing: /images/ResizableNVMEUpTest/d1p.img*
    error: #: No such file or directory
    Problem opening # for reading! Error is 2.
    The specified file does not exist!
    Problem opening # for reading! Error is 2.
    The specified file does not exist!
    
    error: #: No such file or directory
     * Not expanding (# -- imager)
     * Press [Enter] key to continue
    
     * Press [Enter] key to continue
    
    
    Problem opening An for reading! Error is 2.
    The specified file does not exist!
    Problem opening An for reading! Error is 2.
    The specified file does not exist!
    
     * Processing Partition: An ()
    
     * Partition File Missing: /images/ResizableNVMEUpTest/d1p.img*
    error: An: No such file or directory
    Problem opening An for reading! Error is 2.
    The specified file does not exist!
    Problem opening An for reading! Error is 2.
    The specified file does not exist!
    
    error: An: No such file or directory
     * Not expanding (An -- imager)
     * Press [Enter] key to continue
    
     * Press [Enter] key to continue
    
    
    Problem opening error for reading! Error is 2.
    The specified file does not exist!
    Problem opening error for reading! Error is 2.
    The specified file does not exist!
    
     * Processing Partition: error ()
    
     * Partition File Missing: /images/ResizableNVMEUpTest/d1p.img*
    error: error: No such file or directory
    Problem opening error for reading! Error is 2.
    The specified file does not exist!
    Problem opening error for reading! Error is 2.
    The specified file does not exist!
    
    error: error: No such file or directory
     * Not expanding (error -- imager)
     * Press [Enter] key to continue
    
     * Press [Enter] key to continue
    
    
    Problem opening has for reading! Error is 2.
    The specified file does not exist!
    Problem opening has for reading! Error is 2.
    The specified file does not exist!
    
     * Processing Partition: has ()
    
     * Partition File Missing: /images/ResizableNVMEUpTest/d1p.img*
    error: has: No such file or directory
    Problem opening has for reading! Error is 2.
    The specified file does not exist!
    Problem opening has for reading! Error is 2.
    The specified file does not exist!
    
    error: has: No such file or directory
     * Not expanding (has -- imager)
     * Press [Enter] key to continue
    
     * Press [Enter] key to continue
    
    
    Problem opening been for reading! Error is 2.
    The specified file does not exist!
    Problem opening been for reading! Error is 2.
    The specified file does not exist!
    
     * Processing Partition: been ()
    
     * Partition File Missing: /images/ResizableNVMEUpTest/d1p.img*
    error: been: No such file or directory
    Problem opening been for reading! Error is 2.
    The specified file does not exist!
    Problem opening been for reading! Error is 2.
    The specified file does not exist!
    
    error: been: No such file or directory
     * Not expanding (been -- imager)
     * Press [Enter] key to continue
    
     * Press [Enter] key to continue
    
    
    Problem opening detected! for reading! Error is 2.
    The specified file does not exist!
    Problem opening detected! for reading! Error is 2.
    The specified file does not exist!
    
     * Processing Partition: detected! ()
    
     * Partition File Missing: /images/ResizableNVMEUpTest/d1p.img*
    error: detected!: No such file or directory
    Problem opening detected! for reading! Error is 2.
    The specified file does not exist!
    Problem opening detected! for reading! Error is 2.
    The specified file does not exist!
    
    error: detected!: No such file or directory
     * Not expanding (detected! -- imager)
     * Press [Enter] key to continue
    

    And on the fog server, this is the contents of the image

    ls /images/ResizableNVMEUpTest/
    d1.fixed_size_partitions  d1.minimum.partitions  d1.original.swapuuids  d1.partitions
    d1.mbr                    d1.original.fstypes    d1p1.img
    

    I will try an upload of this image as well as the same with my mps test image and post the results


  • Testers

    @Tom-Elliott said:

    @Arrowhead-IT if you can would you be willing to test upload and download again for the resize and multipartition image types?

    I will edit this post like before as I test each scenario.
    If there is a scenario I’m missing here let me know and I’ll test that too.
    I will try to be thorough as I can.

    Download of existing image created from vm

    Resizable (Windows 8.1) - Success! No Issues!

    Resizable (Windows 10) - Success! No issues!

    Multi-partition (Linux CentOS Ext4 and LVM) - Failed - New Error
    0_1452787933089_Capture.PNG
    I think this indicates a problem with the image file itself not the imaging process. I’ll reupload this one and test a different mps image in the meantime.
    Edit Reuploaded the image, this is centOS vm that has no mbr apparently. So this is a different problem entirely related linux lvm images. normal mps images work fine

    Multi-partition (Windows 7) - Success! Edit No Issues!
    before
    Note: Changing hostname said failed after imaging in debug mode. 0_1452788642840_Capture.PNG

    Upload from nvme

    Resizable (Windows 10 ) - retesting

    Multi-partition -

    Download of newly uploaded image from nvme

    Resizable (Windows 8.1 ) - Failed - Could not find hard disk on system - getHardDisk function

    Multi-partition


  • Testers

    @Tom-Elliott It shall be done.


Log in to reply
 

452
Online

38955
Users

10706
Topics

101580
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.