No PXE boot menu on client with FOG 1.2.0 9standlone/iso;ation mode)



  • I am trying to set up fog in isolation mode
    fog 1.2.0
    lubuntu 14.04
    The client is able to see the fog DHCP server but after the message
    http://192.168.1.1/fog/service/ipxe/boot.php…ok
    http://192.168.1.1/fog/service/ipxe/bg.png…ok
    it starts to the windows boot menu. What am i doing wrong
    my config steps
    Install fog
    set sql password
    ensure that the config file has proper pass for the tftp server
    but still no boot menu on the client. Please help
    TIA


  • Senior Developer

    Seeing as the problem of getting the boot menu was the problem of this posting, I’m solving this thread.

    Please create a separate issue in regards to the registration problem. You can link back to this thread too so you don’t have to rewrite all the details. Just give the new posting a title that says (Using /dev/sda) Host Registration Hung or something like that.



  • @Tom-Elliott Thanks commenting the line 632 that worked like a charm for atleast showing the GUI on the client side


  • Moderator

    @Tom-Elliott said:

    @george1421 It always assumes 32 bit in the browser unless you pass, as part of the url, arch=x86_64

    My mistake then, I assumed that it was the other way around. I was trying to draw a connection to this abnormal behavior and the limited insight I had into the OPs environment.


  • Senior Developer

    @george1421 It always assumes 32 bit in the browser unless you pass, as part of the url, arch=x86_64


  • Senior Developer

    I’m assuming, now that you get to the “processing /dev/sda” part that your system is setup for upload?

    If that’s the case try following these instructions:

    https://forums.fogproject.org/topic/3402/stuck-on-dev-sda


  • Moderator

    Lets think about this for a minute.

    We have an issue with the console, now we have an issue with host registration. Both of these actions require the target device to do something.

    I noted the boot.php output and its calling for the 32 bit kernels and inits. That in it self is not strange, but it makes me wonder what is the make and model of computer we are trying to register. I also noted that the DNS reference points to itself (very strange telling a target computer to use itself as a DNS lookup target dns=127.0.0.1). I’m not saying there isn’t something wrong with FOG here, but we ARE talking about 1.2.0 stable and not a trunk release (pre 1.3.0). I would expect 1.2.0 to react in a predictable manner.



  • using disk device…/dev/sda

    • Starting host registration…

    It just sits there doing nothing
    This is what I am getting on the client side. Any way to get it to start the host registration? I did verify that the host registration is enabled on the server side under fog settings Thanks for your time and helping me out



  • @Wayne-Workman Thanks for replying…It hangs at
    Registering host… the dots just keep printing


  • Moderator

    @nutcr0cker What part of host registration? Can you give us a photo of where it hangs?



  • After commenting out the 684th line as stated above I get the GUI but then it gets stuck on host registration. Any ideas how to fix that?



  • @george1421 Thanks



  • @Tom-Elliott Thanks for the tip I commented that out Ill have to try tommorrow



  • My url browser output looks ;like this

    #!ipxe
    cpuid --ext 29 && set arch x86_64 || set arch i386
    colour --rgb 0xff6600 2
    cpair --foreground 7 --background 2 2
    console --picture http://192.168.1.1/fog/service/ipxe/bg.png --left 100 --right 80
    :MENU
    menu
    colour --rgb 0xff0000 0
    cpair --foreground 0 3
    item --gap Host is NOT registered!
    item --gap -- -------------------------------------
    item fog.local Boot from hard disk
    item fog.memtest Run Memtest86+
    item fog.reginput Perform Full Host Registration and Inventory
    item fog.reg Quick Registration and Inventory
    item fog.sysinfo Client System Information (Compatibility)
    choose --default fog.local --timeout 3000 target && goto ${target}
    :fog.local
    exit || goto MENU
    :fog.memtest
    kernel memdisk iso raw
    initrd memtest.bin
    boot || goto MENU
    :fog.reginput
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=127.0.1.1 keymap= web=192.168.1.1/fog/ consoleblank=0 loglevel=4 mode=manreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.reg
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=127.0.1.1 keymap= web=192.168.1.1/fog/ consoleblank=0 loglevel=4 mode=autoreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.sysinfo
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=127.0.1.1 keymap= web=192.168.1.1/fog/ consoleblank=0 loglevel=4 mode=sysinfo
    imgfetch init_32.xz
    boot || goto MENU
    autoboot
    

  • Senior Developer

    Edit the /var/www/fog/lib/fog/BootMenu.class.php and comment the line that states console. I think you are suffering from this as it fails immediately after getting the bg.png file.



  • This post is deleted!

  • Moderator

    This post is deleted!

  • Moderator

    This will sound a bit strange. But from a browser, try to access this page.

    http://<fog_server_ip>/fog/service/ipxe/boot.php

    That should cause FOG to create the ipxe boot menu. You should see something like that starts like this:

    #!ipxe
    set fog-ip 192.168.1.88
    et fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    #!ipxe
    cpuid --ext 29 && set arch x86_64 || set arch i386
    goto get_console
    :console_set
    colour --rgb 0x00567a 1 && colour --rgb 0x00567a 2 && colour --rgb 0x00567a 4 ||
    cpair --foreground 7 --background 2 2 ||
    goto MENU
    :alt_console
    cpair --background 0 1 && cpair --background 1 2 ||
    goto MENU
    :get_console
    console --picture http://192.168.1.88/fog/service/ipxe/bg.png --left 100 --right 80 && goto console_set || goto alt_console
    :MENU
    menu
    colour --rgb 0xff0000 0 ||
    cpair --foreground 1 1 ||
    cpair --foreground 0 3 ||
    cpair --foreground 4 4 ||
    item --gap Host is NOT registered!
    item --gap -- -------------------------------------
    item fog.local Boot from hard disk
    item fog.memtest Run Memtest86+
    item fog.reginput Perform Full Host Registration and Inventory
    item fog.reg Quick Registration and Inventory
    item fog.quickimage Quick Image
    item fog.multijoin Join Multicast Session
    item fog.sysinfo Client System Information (Compatibility)
    


377
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.