SOLVED FOG Configuration->MAC Address update Git 5572

  • Moderator

    I’m unable to update the OUI entries in the 5572 release. This may not be a flaw in FOG depending on how the file is requested (suspect protocol FTP). My FOG systems sit behind a proxy server. I can say that FOG can communicate through the proxy server because the FOG installs and current version report correctly on the management login page.

    FOG Configuration->MAC Address list->Update Current Listings

    0 mac addresses updated

    http error log

    --2015-12-01 19:21:04--  http://standards.ieee.org/develop/regauth/oui/oui.txt
    Connecting to 192.168.1.10:1328... failed: Connection refused.
    [Tue Dec 01 19:21:04 2015] [error] [client 192.168.1.43] PHP Warning:  Invalid argument supplied for foreach() in /var/www/html/fog/lib/fog/fogcore.class.php on line 12, referer: http://192.168.1.88/fog/management/index.php?node=about&sub=mac-list
    
    
  • Moderator

    This issue is confirmed fixed.


  • New push should fix how it downloads the file.


  • @george1421 said:

    http://standards.ieee.org/develop/regauth/oui/oui.txt

    You did fat finger. Apparently it is downloading with wget, not fogurlrequests. I see what i can do to fix it properly.

  • Moderator

    The database has the right value.

    mysql> use fog;

    Database changed
    mysql> SELECT settingValue FROM globalSettings WHERE settingKey='FOG_PROXY_PORT';
    +--------------+
    | settingValue |
    +--------------+
    | 3128         |
    +--------------+
    
    

    I just confirmed again that it says 1328 in the error log with a fresh request

    --2015-12-01 20:26:52--  http://standards.ieee.org/develop/regauth/oui/oui.txt
    Connecting to 192.168.1.10:1328... failed: Connection refused.
    
  • Moderator

    @Tom-Elliott OK let me hit the database and see whats in there.


  • @george1421 That doesn’t make sense. What about direct database query?

    SELECT settingValue FROM globalSettings WHERE settingKey='FOG_PROXY_PORT';

  • Moderator

    I just checked the proxy server and the request is not hitting it, then I noticed something in the error message.

    192.168.1.10:1328...
    The port number is wrong it should be 3128. Thinking that I’m a bit dyslexic I checked the proxy settings in fog and the value is correct at 3128. I checked the bashrc file and those settings are correct too. I don’t know where the 1328 is coming from.


  • There is proxy support already in the FOGURLRequests file, but that doesn’t mean it isn’t broken in some way. I know it worked once before, so it’s most likely I screwed, I just don’t know where.

  • Moderator

    @Tom-Elliott Sorry for the continuing questions, but isn’t curl http based? Does FOG use curl for other off site requests? Just trying to establish a pattern here. Either curl needs its environment setup for proxy support. From the error it appears that its attempting to use the proxy but for some reason its rejecting the request.

    I’ll see if I can get access to the error logs from the proxy server. Hopefully it will give me a better idea (like a malformed http request ??).


  • @george1421 it’s based on the FOGURLRequests class. So CURL I believe.

  • Moderator

    @Tom-Elliott what method is FOG using to get the file wget, or some other process. I’m not doubting that this proxy is a bit finicky with the ftp process. If it is ftp then I’ll need to get a variance.


  • Based on what I’m seeing, you’re behind a proxy? Maybe the proxy isn’t allowing you to get to the text file?

292
Online

9.1k
Users

15.7k
Topics

145.8k
Posts