SOLVED SVN 5481 bzimage32 not loading


  • This is a machine that just yesterday worked fine when imaging, but now gives this error

    0_1448330793260_upload-02c2d2e6-dda0-4b7b-abde-f7ee0fe41d0d

    I let the machine boot without pxe, it then restarted to complete imaging, but came to this.


  • @Tom-Elliott awesome, thanks, it seems to be working ok now…


  • it means it’s fine. there is no more data to return because they’ve all been removed.


  • @Tom-Elliott Zero rows affected ? Should this apply to something ? Or does this mean it’s ok


  • @Hanz truncate table tasks; truncate table snapinTasks; truncate table snapinJobs; truncate table multicastSessions; truncate table multicastSessionsAssoc;


  • @Tom-Elliott I deleted host, manually re-created and bam, works flawlessly, it has to have something to do with the database. Could I delete all tasks and snapin tasks in database possibly to “clean” it up ? I’m not worried about keeping the past “logs” of tasking or snapins at all. I just wan’t to keep groups and I can export hosts seperately. I’m familiar enough now to get it back up and running with plugins and such.


  • @Hanz update and the line 404 error will be fixed.


  • @Tom-Elliott Sorry, wasn’t trying to come across as rude…just wanted to give you all the info I had.

    After doing url test…this was in log, and page errored out

    [Tue Nov 24 10:55:30.174427 2015] [:error] [pid 10332] [client 10.72.2.162:53982] PHP Warning:  printf(): Too few arguments in /var/www/html/fog/lib/fog/FOGPage.class.php on line 404, referer: http://10.72.3.50/fog/management/index.php?node=host&sub=deploy&id=822&type=2
    

    Is it possible this has something to do with the group task settings not working correctly ?

    I have teamviewer if you have a chance to look


  • @Hanz I’m most saying you made any changes, just trying to help figure out the cause. If you see this issue pop up out of nowhere please try to get a copy of the Apache error logs and it may help lead us to the issue, also try looking at the browser and post its output too. The url would be http://fogip/fog/service/ipxe/boot.php?mac=macofhost


  • @Tom-Elliott I hadn’t changed any setting on this machine other than unchecking the "join domain after imaging"section, as my unattend, renames and domains. I did however have an issue with getting this machine to go through without timing out, with undionly.kpxe. It did “task” the re-image after not going through completely, and I tried removing the tasked item a couple times. That’s why I thought it might be something to do with a bad taskID or something like that. It’s the exact same error msg I was getting when I created the other thread about bzimage not loading correctly.

    https://forums.fogproject.org/topic/6169/svn-5419-not-loading-bzimage-correctly


  • @ch3i I ruled out, uncompleted inits and such as the installer now completely downloads these, and then moves on.


  • @Hanz normally, when I see and int 18 error it’s one of two problems. First I assume I screwed up and check the Apache error logs for a hint. Second I take a look at the output results in the browser to try to track what is missing/added to the output that would cause this. The browser test is useful for both of these cases because an int 18 error basically means it’s getting data that is unexpected, or not getting any data. I suspect it was a particular configuration, possibly? Maybe the exit types or something? Just a hunch.

  • Moderator

    @Hanz Hi, I don’t understand why the host deleted and re-added solve the problem, it’s a ipxe loading problem. Have you upgrade your FOG installation before try another boot ? When you had this problem, you had just updated FOG?


  • @Hanz Deleted host and re-added works fine now…probably had something to do with database and/or tasking

293
Online

9.1k
Users

15.7k
Topics

145.8k
Posts