git5419/5469 - "Multiple Partition - Single Disk" -> not uploading



  • Uploading a Image with the settings:

    • default: Windows 7
    • Multiple Partition Image - Single Disk (Not Resizable)
    • Everything
      seems not be possible.
      This is the last screen I can see before the computer restarts:
      0_1448274270165_fog_single_disk_not_resizable.png
      The “Image” size displayed in the image overview is 31.5KiB and only the MBR seems to be uploaded to the image directory. The capture task on the web interface is gone and on the main page the daily counter is increased by 1.

    Changing “Image Type” to “All Disks” is working OK:

    • default: Windows 7
    • Multiple Partition Image - All Disks (Not Resizable)
    • Everything
      This is the last screen I can see before partclone starting to work:
      0_1448274404349_fog_all_disk_not_resizable.png
      The upload is OK and I am able to image this to another computer.

    I tested the function of TFPT guided by the wiki entry without problems.
    The computer has only one hard drive and one DVD drive. No other SATA devices.
    The computer I’m trying to capture from is only used for upload/capturing and it was working some time ago with the “Multiple Partition Image - Single Disk (Not Resizable)” setting. (It’s our default setting for images)

    Are there any more information needed to solve this problem/bug?



  • @Tom-Elliott Thanks Tom.

    Uploading an image with “Multiple Partition Image - Single Disk (Not Resizable)” is running right now.
    Guess it solved the problem. If there is any problem at the end of imaging or when downloading I’ll report again.


  • Senior Developer

    I’ve patched the fog.upload file and pushed the inits, please update and re-run the installer and test. Let me know if it’s working or still having a problem please.

    Thank you,


  • Developer

    But where are the partitions enumerated?


  • Senior Developer

    @Sebastian-Roth If no setting is passed it defaults to the $hd variable.


  • Developer

    @Tom-Elliott Looking at the new script code I think there is a getPartitions $disk call missing in the ‘mps’ section?!


 

336
Online

41.8k
Users

12.3k
Topics

116.0k
Posts