Default Storage node password populates incorrectly in Web UI


  • Moderator

    svn 4405 cloud 5469 Fedora 23 Server minimal

    Storage Node’s password field is filled with “password”.

    I can change it to what is correct, and click update, and I’ve verified in the database that the password gets set.

    But when I refresh the page, the password field for the storage node is again filled with “password”.

    I don’t think that this is auto-fill… I’m using a chromebook.


  • Moderator

    @Tom-Elliott I think storage node passwords are stored in the DB as plain-text.

    It does not change the password in the DB unless I hit the update button - which happened once.

    I was correcting the interface name and did not know the password field was changed, hit “Update” and boom, imaging doesn’t work lol. I figured it out eventually and then narrowed in on what caused it…


  • Senior Developer

    I’m pretty sure this IS auto-fill. When you go through these steps to see that “password” is in the form field, does it change the password in the database to password? Or shall I say the hash value of the password password? While I do have fake fields that are supposed to take the auto fill data, I’ve seen on a couple occasions where it still fills the wrong field with auto fill data.


  • Moderator

    My old fog server on Fedora 21 with the exact same svn 4405 cloud 5469 installed does not exhibit this behavior.

    I’ve tried setting the old fog server’s storage password to “password”, I’m not prompted to save any password, I can refresh the page and obviously it says “password” still, then go to the dashboard and then come back, set the password correctly and click update, the correct password does stay. I can navigate away and back again and it’s still set correctly.

    I’m using the same Chromebook also.

    I think this must be something specific to either Fedora 23 Server - minimal install… ???

    The new Fedora 23 Server has SELinux set to enforcing, per @Jbob 's settings he posted, Firewall is also enabled using his settings. But I really doubt those things would impact this. I’ll try to set SELinux to permissive and disable firewall tomorrow and see what happens… but I doubt it will make any difference. I am thinking this must be Fedora 23 related.


Log in to reply
 

489
Online

38956
Users

10706
Topics

101581
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.