PXE boots fails with minimal errors



  • I finally got FOG up and running on a 14.04 Ubuntu VM and have followed the steps here: https://wiki.fogproject.org/wiki/index.php/Ubuntu_14.04 (some parts of that aren’t super clear, like when/how to connect via PXE) - first time setting up a FOG server

    My target machine to create my initial image boots to PXE, but then displays one of two things - and I hit the same issues when using Clonezilla Server edition (although that did get slightly further into the boot process), so I’m starting to suspect it is my target hardware that is screwing with me. Targeting an HP Pavilion x2 and I have these Insignia USB2 to ethernet adapters that are he only ones (I have tried 8 different ones) that allow the computer to boot to PXE.

    The computer connects to the FOG server…for a split second…and then it shows:

    The selected boot device failed. Press enter to continue
    

    (I have disabled Secure boot)

    OR

    Station IP Address is 192.168.100.11
    Server IP Address is 192.168.100.181 (this is my FOG server address)
    MBP Filename is undionly.kpxe
    MBP file size is 91395 bytes
    Downloading  MBP file..
    
    Succeed to download MBP file.
    

    And then it instantly jumps to trying to boot from ipv6, but nothing ever happens and I’m forced to boot to normal windows.

    Does anyone have anything I could try to find out a little more about what I might be doing wrong, or some other settings to try just to make sure the PXE boot will work to get to the PXE Menu? Not sure if the problem is in the device, the NIC, or in my FOG setup.

    Thanks!


  • Developer

    @fakeblair Any news on this??


  • Moderator

    This post is deleted!

  • Developer

    @fakeblair The messages about NBP file(name) look like UEFI boot being enabled I reckon. If this is the case you need to use an EFI PXE binary (usually ipxe.efi) instead of the BIOS binary undionly.kpxe!!


  • Moderator

    The normal PXE boot sequence is that it waits for the dhcp server to provide the dhcp IP address and then requests the dhcp option values of 66 (boot server IP) and 67 (boot file). For option 66 you should enter the IP address of your FOG server (not the conical name) and for 67 you should enter undionly.kpxe. Those settings will tell teh client what to do next. If you see some messages about iPXE then you have connected to the FOG server.


  • Moderator

    Lets start out by getting some background information.

    I see you are running Ubuntu 14.04. What version of FOG are you running are you running the stable 1.2.0 or the SVN trunk release (pre 1.3.0)? If you are running the trunk release what is the number in the cloud (upper left corner or page) on the management console?

    Now that is out of the way. Have you ever setup PXE booting before (FOG or something else)?

    What did values did you set for DHCP option 66 and 67?


Log in to reply
 

433
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.