Activate plugins window, flashing when hovering over entry. IE11 no display.



  • Just a heads up re some visual/browser issues in the plugins section of latest release.

    I’m updated to latest release 4340 as at Friday 13th Nov 15 to get around an issue with snapin removal and a small bug with the location plugin which Tom Elliot kindly resolved.

    Clean reinstall of FOG and am in process of adding in plugins. I can enable the plugins system but as soon as I try and activate one of the plugins - I’m interested in the Locations, WOL and Pushbullet specifically - the browser just flashes.

    Example GIF can be seen here:

    I’ve found it is possible to click on the plugin and have it activate but takes a few tries to get right. This is happening on Chrome and Firefox. I tried looking at it in IE too (ugh) and in there IE12 on Win 8.1 the front page of FOG web GUI is blank with just a series of bullet points down left hand side. Moving cursor over the page does highlight clickable content (cursor changes to hand icon and the URL shows in popup at bottom of page).

    regards Kiweegie.

    Ninja-Edit:

    Some issues on the WOL plugin also

    I can add new entries but cannot display the entries once added. Also the menu (see URL below) for “List all broadcasts” reads as “List all s”

    http://FOG_Server_IP/fog/management/index.php?node=wolbroadcast&sub=list



  • @Tom-Elliott Hi Tom, updated to latest git release now and indeed its working again. I did only update a few days ago after your last fix re the flashing issue.

    regards Kiweegie.


  • Senior Developer

    Fix has been in place for a while. Can you update again and let me know?



  • @Tom-Elliott Hi Tom, flashing was indeed solved however I now seem to have another niggle with regards the plugins. I managed to enable WOL, Location and Pushbullet plugins and they show on the toolbar fine, however the plugin icon itself has disappeared.

    If I navigate to Fog Configuration > Fog Settings > Plugin System I can see that the checkbox is not ticked. No problem, tick box and click Save. Still no icon. Go back to Fog Configuration > Fog Settings > Plugin System again and once more it’s unchecked.

    @jbob thanks for confirming pushbullet not working. Is a fix in the works? If so I’ll leave it enabled for now and wait on that. If not I can just remove it - assuming i can get the plugin system itself showing again :)

    thanks, Kiweegie


  • Senior Developer

    This should all be fixed. Flashing and all.


  • Senior Developer

    @Kiweegie I have confirmed the pushbullet plugin is now broken. @Tom-Elliott.



  • @Wayne-Workman Hi Wayne, I could get past the issue and have the plugins installed now but it may throw off new users hence reason I flagged up.

    Additionally the pushbullet plugin does not seem to be accepting tokens. Not a deal breaker for me but again just pointing it out to add to the snagging list. :)

    Cheers, Kiweegie.


  • Moderator

    I actually experienced the flashing you described on Friday Morning, using svn 4338 cloud 5323

    We thought somehow the mouse track-pad we were using was malfunctioning… seems it wasn’t. We did get it after a few tries, just as you described. This was with adding the Location plugin.


Log in to reply
 

436
Online

38995
Users

10715
Topics

101715
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.