SOLVED Surface Pro 3 Fog 1.2 Compatibility?

  • I have seen lots of stuff about the Surface Pro 3 and Fog, but I havent seen a clear answer that it does in fact work with Fog 1.2? I am able to get the surface to boot to Fog using the Trunk efi files (, but no matter what kernel I use it goes into a kernel panic “Kernel panic - not syncing: VFS Unable to mount root fs on unkown block(1,0)”. Other settings I have set right now are…
    Host Kernel Arguements = has_usb_nic=1
    Host Primary Disk = /dev/mmcblk0

    So I guess my two questions are:

    1. Does Fog 1.2 work with the surface pro 3’s?
    2. If so, what kernel am I supposed to use(if known).

    Thanks so much!

  • @dustindizzle11

    We are requesting that all community members who have Surface Pros to please do a packet capture, to capture the DHCP conversation the client sends out at boot time via the ethernet dock, and upload the capture here. The intent is to gather more information about the Surface Pro, so fog can better support network booting it.


  • Moderator

    @dustindizzle11 So I’ll mark this solved for now. Feel free to start another thread or post here is you see new issues.

  • Moderator

    You may need to check that the UEFI Windows Boot Manager option in the BIOS is pointed at the right location.

  • @Sebastian-Roth Sorry about the late reply. I made a test station that was upgraded to trunk and I was able to get the surface to take an image, but it never actually loaded the image (wouldn’t boot what was thrown onto the HDD). Thats where I left off. The trunk option was what solved all my major issues with the kernel panic.

  • Moderator

    @dustindizzle11 Have you tried my suggestions or upgrading to trunk yet. Any news on this?

  • Moderator

    I would strongly suggest using the latest “trunk” version of FOG, as well as making sure you have your Surface’s firmware completely up to date, because earlier versions of the Surface firmware made using UEFI network boot nearly impossible.

  • Moderator

    @dustindizzle11 I am pretty sure you can’t make this work in FOG 1.2.0 without some minor modifications.

    • Kernel in 1.2.0 (3.15.6) has an issue with EFI_STUB
    • FOG 1.2.0 is missing the kernel option initrd=init.xz which is one of the major things causing the error you see
    • Maybe something else I just cannot remember right now…

    Try adding the kernel option (might be init_32.xz in your case, I am not sure) and using the latest kernel/init.xz. See how you go. Please always post the complete error message you see (just as you did in your first post) so we are able to help.