boot.php.....ok


  • Testers

    Trying to get a node to allow pxe booting and present the menu to a set of machines on a different VLAN than the master.

    I have the node setup and replicating the image, I can see the node in my FOG page.

    To install it this way I installed as a Normal install, changed the .fogsettings to node, added mysql host form master server using same user and pass.

    I also edited the installfog.sh script and added “configureTFTPandPXE;”

    added tftpd-hpa tftp-hpa for config.sh

    Everything seems to work except the webpage. Maybe I am dong oit wrong. I even tried making a symbolic link back to the fog folder in /var/www/fog to /var/www/html and creating an index.php file still no dice.

    I am not sure it actually has anything to do with it at all. but I know it worked when it was a master and what I am working towards is a multi-node network with the master being the DB and the other sub-nets being nodes. Let me know what I may be doing wrong here.


  • Senior Developer

    @Wayne-Workman won’t matter.



  • @Tom-Elliott And, it’s a good idea to disable the FOGImageReplicator on the non-master full servers, correct?


  • Senior Developer

    I remoted in.

    If you’re going to do a centralized DB, but ultimately have them as full nodes so you can access them as server’s.
    The only difference between them is node you can only access through a single server, the nodes don’t present a gui.

    If you centralize the DB and connect servers to it, it will operate as you expect, but you also have multiple points of entrance.

    First things first. To have multiserver->central db, you need to make sure bind-address is off and/or defined for your specific accessible (external) IP addresses. So in the my.cnf (/etc/mysql/my.cnf debian | /etc/my.cnf redhat) ensure skip-networking is commented, and simplest to make sure bind-address is disabled.

    Perform the full install as normal, but then edit the /opt/fog/.fogsettings file and change the snmysqluser to fogstorage, snmysqlpass to whatever the fogstorage password is in FOG COnfiguration->FOG Settings->FOG Storage->FOG_STORAGE_MYSQLPASS and snmysqlhost to the central DB server.

    Restart mysql and then re-run the FOG installer so the new settings are in place. Do not make them into nodes though.



  • @Psycholiquid Did you install this box as a storage server or as a normal server?

    For a fully functional web server with all the bells and whistles, you would do a normal install and then after installation, just change the /opt/fog/.fogsettings mysql user and pass to point to the master. You’d also have to have remote access enabled on the master’s mysql service. There’s a bit in the wiki about it here: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_MySQL

    Also, after the full installation on the remote server, it’d be wise to totally disable the FOGImageReplicator on that server. Only the master server should be running that.


  • Testers

    @Wayne-Workman said:

    10.30.65.19/fog/management

    I cannot I get server error 500 however apache is running I can see it if I just hit the ip address.



  • @Psycholiquid And you can browse to 10.30.65.19/fog/management and see everything as if you were using the master?


  • Testers

    @Wayne-Workman Remote node. I keep looking at that thinking it doesn’t seem right



  • Is 10.30.65.19 the remote node or the master?


  • Testers

    Here is what I am getting on the boot of a client PC:

    upload-a4249eec-5912-4d29-aaf1-8589d01907e8

    Maybe I need to change the network to E1000, I haven’t had to before but I am willing to try.


 

330
Online

41.6k
Users

12.1k
Topics

114.4k
Posts