WIndows 7, sysprep, auto login and snapins



  • Hello - First I want to thank the developers of FOG for their fine efforts! What a cool tool!

    I work at a public library and maintain about 80 public pc’s. I had been using ghost but had been looking at FOG over the years and have now made the switch and I am never going back.

    My goal is to have one Windows 7 image for all of my public computers. I have created an image that works well - it has an AutoIT script that handles all the various changes that need to be made to the desktop and registry so that a PC knows what building, floor, and department it belongs to.

    My struggle is to get windows 7 to autologin twice after imaging and sysprep does its thing. I have worked with it for a long time now. It tries to log in but always complains about incorrect username or password, no matter what username or password I put in my autounattend.xml. The first time it boots it complains, then it just reboots even without logging in. I am guessing that the FOG service is changing the hostname? Updating the hostname is WAY cool, by the way. On the second reboot it needs the password again and then my script runs and it shuts down. On third reboot the public user is logged in and everything works as it should.

    I am wondering if a snapin could be made such that the FOG service runs my script instead of having to use a broken auto logon. The goal is to not have to even touch the PC’s and to only have one image.

    Thanks again for a fine product!



  • Hi Mark
    I have exactly the same problem and know for fact that it’s not the FOG service.
    I finaly fix it by putting the password for account in registry under HKLM\software\microsoft\windows NT\current version\winlogon
    I setup the key called DfaultUserPassword.

    there is a program called windowsautologin.exe that does all that for you.
    I also noticed that the password will be removed from registry after the number of autologon is over.

    I appreciate if you tell mw what solution you found.
    thanks



  • I was unable to make psexec to elevate the script when ran as a user. What I did discover, however, is that when I set control userpasswords2 to NOT auto login, then run sysprep, sysprep’s auto login works like it should - so I am all set. Thanks for all the ideas!



  • [quote=“Blackout, post: 298, member: 1”]Are you sure sysprep removes this? My sysprep does not remove it.

    You could have a run once script setup in your sysprep.
    Use psexec to elevate to Administrator[/quote]
    Ah - now that’s an idea. I will try it when I get back to work. Thanks, and Happy New Year!


  • Developer

    Are you sure sysprep removes this? My sysprep does not remove it.

    You could have a run once script setup in your sysprep.
    Use psexec to elevate to Administrator



  • [quote=“Blackout, post: 282, member: 1”]The FOG Service runs regardless of being logged in or not. So you don’t need auto login for this.

    For the second part, i would setup your image to auto login with the desired user.
    [LIST=1]
    []Start -> Run
    [
    ]Type: control userpasswords2
    []Click ‘OK’
    [
    ]Untick the box ‘Users must enter a user name and password to use this computer’
    []Click ‘OK’
    [
    ]It will now ask you username and password you want it to auto logon with.
    []Click ‘OK’
    [
    ]Now that is done - sysprep, take image up with FOG, deploy
    [*]Profit
    [/LIST]
    Does your Autoit script do anything else that could be simplified?[/quote]

    Thanks, Blackout - I know about control userpasswords2. sysprep wipes that out. That is what my script does, is set that back up so that the public user is automatically logged in, plus set up our printing software and a few other things that lets the software know what floor the PC is on. But the script has to run as admin, so I have to log in admin first. I will keep whacking away at it.


  • Developer

    The FOG Service runs regardless of being logged in or not. So you don’t need auto login for this.

    For the second part, i would setup your image to auto login with the desired user.
    [LIST=1]
    []Start -> Run
    [
    ]Type: control userpasswords2
    []Click ‘OK’
    [
    ]Untick the box ‘Users must enter a user name and password to use this computer’
    []Click ‘OK’
    [
    ]It will now ask you username and password you want it to auto logon with.
    []Click ‘OK’
    [
    ]Now that is done - sysprep, take image up with FOG, deploy
    [*]Profit
    [/LIST]
    Does your Autoit script do anything else that could be simplified?



  • [quote=“Blackout, post: 250, member: 1”]Why do you want auto login? You want an interaction-less Image so you can set and forget.[/quote]
    These are public library computers, and they need to log themselves in so that patrons can use them. In any case, my autoit script handles that part just fine. What I need is for the admin user to log in twice, once for the FOG service to change the host name and the second time my autoit script runs. to change it over to auto login the public user. The issue is I can’t get my autounattend.xml gile to work correctly - when it boots it complains that the username or password is incorrect, yet I can log in with the same credentials that the xml file has and it works.


  • Developer

    Why do you want auto login? You want an interaction-less Image so you can set and forget.



  • Thanks, Blackout. My AutoIT script runs just fine - it’s the autologin that is busted. Typical Microsoft BS. I have tried everything I can think of - it tries to log in, but keeps complaining about invalid username or password. I know that’s not a FOG problem, but in order to bypass that problem I wanted to know how to run programs using the FOG service.


  • Developer

    I was using the auto login X amount of times with no issues, not sure what the issue is there.

    I run a batch file during mini setup, you could probably do the same with your AutoIt script

    From my AutoUnattend.xml
    [code] <settings pass=“specialize”>
    … other components here
    <component name=“Microsoft-Windows-Deployment” processorArchitecture=“x86” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <RunSynchronous>
    <RunSynchronousCommand wcm:action=“add”>
    <Order>1</Order>
    <Path>cmd /c c:\windows\defaults.bat</Path>
    </RunSynchronousCommand>
    </RunSynchronous>
    </component>
    </settings>[/code]


Log in to reply
 

449
Online

39010
Users

10725
Topics

101894
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.