Update, now 404 on FOG



  • SVN update ran but now /fog gives a 404. Checking in the /var/www/ directory all I have is download.php FOGCrypt.zip FOGService.msi index.php favicon.ico FogPrep.zip and FogService.zip.

    Ubuntu 14.04
    SVN v5283 installer.



  • Thanks for the help everyone, it seems up and working now, but I can’t say I know why. I didn’t get to change the MaxRequestWorkers before it came up.

    I did notice in /var I have a fog and a wwwfog directory which I never remember seeing.


  • Moderator

    I found this bug report for 14.04 of ubuntu.

    https://bugs.launchpad.net/ubuntu/+source/php-apcu/+bug/1422484

    In a nutshell the fix seems to be:

    sudo apt-get purge php5-apcu
    sudo service apache2 restart
    

    Not a FOG issue more about ubuntu.



  • @Scott-B There is a setting you can change that allows more simultaneous connections to mysql. An example can be found here: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_MySQL

    That said, it’s only a band-aid and there’s probably a larger issue going on here.


  • Moderator

    @Wayne-Workman Sorry I thought that was a recent solution to add that link back in.

    Thinking a bit more the 404 is page not found error (which lead me back to the files not being where expected).

    The /var/log/httpd/error_log or /var/log/httpd/error.log should show the root issue either way like Tom suggested.



  • @Tom-Elliott said:

    @Scott-B What is the error that you see in apache error logs?

    [Mon Nov 09 10:15:30.289314 2015] [core:warn] [pid 19961] AH00045: child process 20839 still did not exit, sending a SIGTERM
    [Mon Nov 09 10:15:32.291371 2015] [core:error] [pid 19961] AH00046: child process 20839 still did not exit, sending a SIGKILL
    [Mon Nov 09 10:15:33.292477 2015] [mpm_prefork:notice] [pid 19961] AH00169: caught SIGTERM, shutting down
    [Mon Nov 09 10:15:34.009790 2015] [mpm_prefork:notice] [pid 20864] AH00163: Apache/2.4.16 (Ubuntu) PHP/5.6.14-1+deb.sury.org~trusty+1 OpenSSL/1.0.1f configured -- resuming normal operations
    [Mon Nov 09 10:15:34.009857 2015] [core:notice] [pid 20864] AH00094: Command line: '/usr/sbin/apache2'
    [Mon Nov 09 10:15:44.193424 2015] [mpm_prefork:error] [pid 20864] AH00161: server reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting
    [Mon Nov 09 10:16:28.129848 2015] [mpm_prefork:notice] [pid 20864] AH00169: caught SIGTERM, shutting down
    [Mon Nov 09 10:16:28.804913 2015] [mpm_prefork:notice] [pid 21984] AH00163: Apache/2.4.16 (Ubuntu) PHP/5.6.14-1+deb.sury.org~trusty+1 OpenSSL/1.0.1f configured -- resuming normal operations
    [Mon Nov 09 10:16:28.805012 2015] [core:notice] [pid 21984] AH00094: Command line: '/usr/sbin/apache2'
    [Mon Nov 09 10:16:47.986259 2015] [mpm_prefork:error] [pid 21984] AH00161: server reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting
    
    


  • @george1421 , here just recently, @Tom-Elliott has put in code to delete symbolic links.


  • Moderator

    If I remember right on Ubuntu (sorry redhat person here), you needed to make a symbolic link between
    /var/www/fog and /var/www/html/fog since the files are not where its expected.


  • Senior Developer

    @Scott-B What is the error that you see in apache error logs?


 

433
Online

41.9k
Users

12.4k
Topics

116.8k
Posts