Authentication ERROR, invalid security token [svn 5221]



  • Hello,
    my config:
    fedora 22
    svn 5201
    I have installed new fog client on win 8.1 64bit, and I get this messages in fog.log

    2015-11-04 14:08 Client-Info Version: 0.9.5
     2015-11-04 14:08 GreenFOG Running...
     2015-11-04 14:08 Middleware::Communication URL: http://fog-server/fog/service/servicemodule-active.php?moduleid=greenfog&mac=30:5A:3A:7A:6C:91||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&newService=1
     2015-11-04 14:08 Middleware::Communication Response: Success
     2015-11-04 14:08 Middleware::Communication URL: http://fog-server/fog/service/greenfog.php?mac=30:5A:3A:7A:6C:91||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&newService=1
     2015-11-04 14:08 Middleware::Communication Response: Invalid host certificate
     2015-11-04 14:08 Middleware::Communication URL: http://fog-server/fog/management/other/ssl/srvpublic.crt
     2015-11-04 14:08 Middleware::Authentication ERROR: Could not get security token
     2015-11-04 14:08 Middleware::Authentication ERROR: Nie można odnaleźć pliku 'C:\Windows\system32\token.dat'.
     2015-11-04 14:08 Data::RSA CA cert found
     2015-11-04 14:08 Middleware::Authentication Cert OK
     2015-11-04 14:08 Middleware::Communication POST URL: http://fog-server/fog/management/index.php?sub=authorize
     2015-11-04 14:08 Middleware::Communication Response: Invalid security token
    

    I can get to this url http://fog-server/fog/management/other/ssl/srvpublic.crt
    certyikat_FOG.png
    Certificates are installed, I can see them in IE settings
    cert_FOG_IE.png
    Issuer is FOG Server CA, is valid to year 2025.

    Regards.



  • This post is deleted!


  • @Wayne-Workman
    After reset encyption data works fine.
    Thanks for help
    Regards


  • Moderator

    Has resetting the encryption on the problem host been attempted?



  • @Tom-Elliott just one machine, but after resetting encryption data…it worked correctly…I uninstalled and reinstalled client…and then reset encryption data


  • Senior Developer

    @Hanz So, is all your systems doing this, or just this one machine?



  • 11/4/2015 10:03 AM Client-Info Version: 0.9.5
     11/4/2015 10:03 AM Middleware::Communication URL: http://10.72.3.50/fog/management/other/ssl/srvpublic.crt
     11/4/2015 10:03 AM Data::RSA CA cert found
     11/4/2015 10:04 AM Middleware::Authentication Cert OK
     11/4/2015 10:04 AM Middleware::Communication POST URL: http://10.72.3.50/fog/management/index.php?sub=authorize
     11/4/2015 10:04 AM Middleware::Communication Response: Invalid security token
     11/4/2015 10:04 AM Bus Registering ParseBus in channel Power```


  • This post is deleted!


  • I too am having this issue, certs are there, but there is no token.dat file under \windows\system32…I’d like to add that this is a windows 10 machine


  • Senior Developer

    According to @jbob, it doesn’t matter, so something else is going weird. Maybe permissions to the token.dat file? I don’t know @Jbob, when you can please chime in to help as he has two systems, one that works and the other that doesn’t which tells me it’s not the SVN at the moment, or seemingly at the least.



  • @Tom-Elliott
    But Tom on another pc I don’t have this problems - I think ;)

    ---------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     2015-11-04 15:02 Client-Info Version: 0.9.5
     2015-11-04 15:02 TaskReboot Running...
     2015-11-04 15:02 Middleware::Communication URL: http://fog-server/fog/service/servicemodule-active.php?moduleid=taskreboot&mac=30:5A:3A:7A:66:03||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&newService=1
     2015-11-04 15:02 Middleware::Communication Response: Success
     2015-11-04 15:02 Middleware::Communication URL: http://fog-server/fog/service/jobs.php?mac=30:5A:3A:7A:66:03||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&newService=1
     2015-11-04 15:02 Middleware::Communication Response: Invalid host certificate
     2015-11-04 15:02 Middleware::Communication URL: http://fog-server/fog/management/other/ssl/srvpublic.crt
     2015-11-04 15:02 Data::RSA CA cert found
     2015-11-04 15:02 Middleware::Authentication Cert OK
     2015-11-04 15:02 Middleware::Communication POST URL: http://fog-server/fog/management/index.php?sub=authorize
     2015-11-04 15:02 Middleware::Communication Response: Success
     2015-11-04 15:02 Middleware::Authentication Authenticated
     2015-11-04 15:02 Middleware::Communication URL: http://fog-server/fog/service/jobs.php?mac=30:5A:3A:7A:66:03||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&newService=1&newService=1
     2015-11-04 15:02 Middleware::Communication Response: No jobs
    

    So how and where I can change issuer from FOG Server CA to ip address?
    Regards


  • Senior Developer

    @Tom-Elliott , the client doesn’t care about the server address.


  • Senior Developer

    The problem is, your server name is currently (on the clients) set to fog-server, where the FOG CA is set to scan for the IP address of the fog server. You can, of course, readjust this but it would require repinning the CA certificate to all the clients.


Log in to reply
 

445
Online

38940
Users

10697
Topics

101495
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.