Upload image to FOG not working



  • Getting mount: permission denied error when trying to upload image to FOG



  • @Sebastian-Roth said:

    I am sure you need to spend a lot more days! Take it one step at a time. I don’t know anyone who learned linux and FOG in just a couple of days.

    Took me 3 weeks just to get the web interface functional with 1.2.0 on Fedora 21 Workstation… Prior Linux experience, basically zilch. Another 2 weeks to figure out the FTP secomp_sandbox setting needed set… a few more weeks to understand the client and BEGIN to grasp how easy fog can make my job.

    This whole FOG ordeal started in February this year (2015) for me. Still learning. And I still occasionally royally screw up too, thank you snapshots and hyper-V!


  • Developer

    @greggill said:

    I am a week into using Ubuntu. … Spent 4 days trying to get this to work, why is this so difficult?

    I am sure you need to spend a lot more days! Take it one step at a time. I don’t know anyone who learned linux and FOG in just a couple of days.

    Please post the exact (copy&paste) commands and output you get. We won’t be able to help if we don’t know exactly what you did and saw!

    When a client boots up to upload an image “using disk device” means the local disk in that client. Most likely sda (first hard drive). This has nothing to do with the disk you have your images stored on the server.

    To me this sounds like something is wrong with your mounts and/or NFS exports. Please post the contents of /etc/exports and cat /proc/mounts



  • The directories are shared via nfs



  • Another thing I have noticed when trying the upload from the client, the “using disk device” is /dev/sda. The images folder I am trying to upload to is on /dev/sdb. How do I change this on the client, and is why I am getting the permission denied errors?



  • I have also tried to recursively set images permissions to world-writable, chmod -R 777 to my images folder but now Ubuntu says that the file or directory doesn’t exist. Spent 4 days trying to get this to work, why is this so difficult?


  • Moderator

    Are these directories shared via nfs (using the command I provided)?

    and to answer your question if you cd to the /images folder then issue a

    ls -la *   
    

    command that will show you file ownership and access rights.



  • How do I check into directory file ownership and permissions, I am a week into using Ubuntu.


  • Moderator

    Another quick command you can run from a linux command shell would be

    showmount -e localhost
    

    That should show you the nfs shares currently enabled. If the /images share is available, then check into directory file ownership and permissions.



  • @greggill said:

    image to FOG

    Check your /etc/exports file to be sure entries are created for both the /images directory and the /images/dev directory. The installer does this for you automatically. Also, you cannot re-export a directory that is already imported.

    Also, you can temporarily recursively set your images permissions to world-writable for troubleshooting purposes.

    These things are all outlined here: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_NFS


 

489
Online

41.8k
Users

12.3k
Topics

116.1k
Posts