SOLVED Trunk Update Failing

  • Testers

    Trying to update to latest trunk failing on Adding needed repository.

    help?

    I am using SVN from Sourceforge, if that is incorrect let me know I will adjust.

  • Testers

    Yep upgrade worked like a champ. So in short all it needed on my end was the upgrade and update. But adding the code wouldn’t be a bad idea as most of us wouldn’t think it that far through. Still not sure what happened with NTP.

  • Testers

    trying it now will update


  • @Psycholiquid so it worked after rollback?

  • Testers

    I’m not sure if this has anything to do with the Trunk but I had to roll back the server (Wouldn’t image anymore TFTP seemed to be messed) but the time was correct so I am wondering if something in the Trunk changed ntp on me. The ntp.pool.org was there when I rolled back to the snapshot.

    All that being said alot was messed with so it could have been anything.


  • I’m adding code to the add-apt-repository element that will: #NOTE this is specific to Ubuntu/maybe Debian

    1. Try installing the ppa.
      a. ensure python-software-properties, software-properties-common, and ntpdate are installed.
      b. update the date on the server
      c. attempt adding the repository.
    2. If it cannot install the ppa:
      a. Update the repository data (apt-get update)
      b. Install python-software-properties and ntpdate
      c. Update the time server.
      d. Ensure the en_US.UTF-8 locale is generated on the system
      e. attempt adding the repository with: LANG='en_US.UTF-8' LC_ALL='en_US.UTF-8' add-apt-repository -y ppa:ondrej/php5-5.6

    Hopefully this will prevent any more such issues and you’ll have an updated time system.

  • Testers

    @Tom Elliot was able to find the issue.

    Apprently the time was off.

    added ntp server and updated and now everything works as intended,

  • Moderator

  • Testers

    No sir direct connection to the internet


  • @Psycholiquid Are you behind a proxy by chance?

  • Testers

    @Wayne-Workman said:

    @Psycholiquid So what’s the correct format? A quick google search yeilded this: http://serverfault.com/questions/666754/ppaondrej-php5-5-6-on-ubuntu

    I wasn’t trying to be a smart ass when I posted that I was just copying what outputted to my screen.

    I tried the URL you suggested and get the following:```

    root@CINDSV10011:/home/ladmin# locale -a
    C
    C.UTF-8
    en_AG
    en_AG.utf8
    en_AU.utf8
    en_BW.utf8
    en_CA.utf8
    en_DK.utf8
    en_GB.utf8
    en_HK.utf8
    en_IE.utf8
    en_IN
    en_IN.utf8
    en_NG
    en_NG.utf8
    en_NZ.utf8
    en_PH.utf8
    en_SG.utf8
    en_US.utf8
    en_ZA.utf8
    en_ZM
    en_ZM.utf8
    en_ZW.utf8
    POSIX
    root@CINDSV10011:/home/ladmin# locale-gen en_US.UTF-8
    Generating locales...
      en_US.UTF-8... up-to-date
    Generation complete.
    root@CINDSV10011:/home/ladmin# export LANG=en_US.UTF-8
    root@CINDSV10011:/home/ladmin# dd-apt-repository -y ppa:ondrej/php5-5.6
    No command 'dd-apt-repository' found, did you mean:
     Command 'add-apt-repository' from package 'software-properties-common' (main)
    dd-apt-repository: command not found
    root@CINDSV10011:/home/ladmin# add-apt-repository -y ppa:ondrej/php5-5.6
    Cannot add PPA: 'ppa:ondrej/php5-5.6'.
    Please check that the PPA name or format is correct.
    root@CINDSV10011:/home/ladmin# LC_ALL=en_US.UTF-8 add-apt-repository -y ppa:ondrej/php5-5.6
    Cannot add PPA: 'ppa:ondrej/php5-5.6'.
    Please check that the PPA name or format is correct.
    root@CINDSV10011:/home/ladmin# locale -a
    C
    C.UTF-8
    en_AG
    en_AG.utf8
    en_AU.utf8
    en_BW.utf8
    en_CA.utf8
    en_DK.utf8
    en_GB.utf8
    en_HK.utf8
    en_IE.utf8
    en_IN
    en_IN.utf8
    en_NG
    en_NG.utf8
    en_NZ.utf8
    en_PH.utf8
    en_SG.utf8
    en_US.utf8
    en_ZA.utf8
    en_ZM
    en_ZM.utf8
    en_ZW.utf8
    POSIX
    
  • Moderator

    for clarity I found those commands in <fog_trunk>/lib/common/functions.sh In case you want to update your way to an answer.


  • @Psycholiquid

    You followed the second answer on that page?

    The proper way is to enable UTF-8 support in your terminal.
    First check your locales:
    locale -a
    Then, install an UTF-8 locale, for en_US, the example as follows:
    locale-gen en_US.UTF-8
    Then you need to export it:
    export LANG=en_US.UTF-8
    Then the add-apt-repository command will work okay.
    If this still doesn’t still work, try using this line:
    LC_ALL=en_US.UTF-8 add-apt-repository -y ppa:ondrej/php5-5.6

  • Testers

    I’m not sure, but the site that is the landing for the PPA is showing just fine.

    root@CINDSV10011:/home/ladmin# apt-add-repository ppa:ondrej/php5-5.6 -y
    Cannot add PPA: ‘ppa:ondrej/php5-5.6’.
    Please check that the PPA name or format is correct.

    The change in format didnt make a difference. But even if I manually put it in there it wont allow the installer to work since it will still be trying to add it its own way correct?


  • @Psycholiquid So what’s the correct format? A quick google search yeilded this: http://serverfault.com/questions/666754/ppaondrej-php5-5-6-on-ubuntu

  • Testers

    Yeah that has to be it:

    root@CINDSV10011:/home/ladmin# add-apt-repository -y ppa:ondrej/php5-5.6
    Cannot add PPA: ‘ppa:ondrej/php5-5.6’.
    Please check that the PPA name or format is correct.

  • Testers

    I have a snapshot so I will give it a try worse case I roll back. Let give it a try, I was looking through the install.sh to see if I could find something also, lol.

  • Moderator

    I’m just pecking in the dark here. But looking at the installer script (actually a called subfunction). This is what is going on in that area.

     add-apt-repository -y ppa:ondrej/php5-5.6 
     if [ "$?" != 0 ]; then
        apt-get update
        apt-get -yq install python-software-properties
        add-apt-repository -y ppa:ondrej/php5-5.6
    fi
    

    I might suggest that you try the apt commands one at a time and see what fails. Again I’m just guessing here, these commands will not do anything destructive.

  • Testers

    I just saw an updated trunk go up but still no dice. Dang I was hoping for a win today, I need one…

  • Testers

    Yes, just imaged 4 machines during this forum posts. I didnt break it since it was never able to update.

323
Online

9.1k
Users

15.7k
Topics

145.9k
Posts