Any ideas? - Unable to upload/download images to the new Fog Server 1.2.0 / Ubuntu 14.04 LTS



  • Hi All - I have an issue uploading an image in my new fog server. What happens is - the PC (Optiplex 3020) reboots after the “configuring net 0 x.x.x.x” shows up. I have a dell 2950 server. I hope someone has a resolution for this one - Thanks much!



  • I have used this configuration and it works! Link from Wayne Workman! Kudos to you my brother! Thanks!

    Example 1

    Here’s a complete configuration example where TFTP and DNS is on the same Server. No router is defined in this configuration but can easily be added by changing X.X.X.X and un-commenting the line.

    option space PXE;
    option PXE.mtftp-ip    code 1 = ip-address;
    option PXE.mtftp-cport code 2 = unsigned integer 16;
    option PXE.mtftp-sport code 3 = unsigned integer 16;
    option PXE.mtftp-tmout code 4 = unsigned integer 8;
    option PXE.mtftp-delay code 5 = unsigned integer 8;
    option arch code 93 = unsigned integer 16; # RFC4578
    
    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    next-server 192.168.1.1;
    authoritative;
    
    subnet 192.168.1.0 netmask 255.255.255.0 {
            option subnet-mask              255.255.255.0;
            range dynamic-bootp 192.168.1.10 192.168.1.254;
            default-lease-time 21600;
            max-lease-time 43200;
            option domain-name-servers      192.168.1.1;
        #option routers      x.x.x.x;
     
        class "UEFI-32-1" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00006";
        filename "i386-efi/ipxe.efi";
        }
    
        class "UEFI-32-2" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00002";
         filename "i386-efi/ipxe.efi";
        }
    
        class "UEFI-64-1" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00007";
         filename "ipxe.efi";
        }
    
        class "UEFI-64-2" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00008";
        filename "ipxe.efi";
        }
    
        class "UEFI-64-3" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00009";
         filename "ipxe.efi";
        }
    
        class "Legacy" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00000";
        filename "undionly.kkpxe";
        }
    }
    

  • Moderator

    @Uncle-Frank said:

    Optiplex 3020 is known to be working: https://wiki.fogproject.org/wiki/index.php/WorkingDevices

    In legacy mode… I’ve never been able to UEFI boot to fog with any device ever, at home or work. Maybe I have the worst combination of devices ever, or maybe I’m doing something wrong…

    I can verify with TCPDump that the right file name is given to UEFI enabled devices, and the file transfer happens… New Dells don’t seem to like ipxe.efi very much…


  • Developer

    Kind of weird. Optiplex 3020 is known to be working: https://wiki.fogproject.org/wiki/index.php/WorkingDevices

    The message Configuring (net0 xx:xx:xx:xx:xx:xx)... comes from iPXE trying to get an IP via DHCP. This being the second time - after the PXE ROM on the NIC got an IP the first time already. Does it seam to timeout (taking several seconds) or reboot straight away? It guess it’s a timeout or you probably wouldn’t see the message anyway.

    Why should the DHCP answer only on the first request? Could you please capture a packet dump on the DHCP server and upload it to the forum?

    sudo apt-get install tcpdump
    sudo tcpdump -i eth0 -w timeout.pcap port 67 or port 68 or port 69
    

    Let tcpdump sit there and startup the client. After the reboot stop tcpdump (Crtl+c).

    Spaning Tree on the switch? Maybe use portfast.



  • ISC DHCP - Thanks for the link - I will give it a try and will keep you posted.


  • Moderator

    Sounds like the computer is being given the wrong boot file for it’s firmware operating mode.

    For example, giving it undionly.kpxe or undionly.kkpxe when it’s set to network boot in UEFI mode…

    Here’s a article on this subject: https://wiki.fogproject.org/wiki/index.php/BIOS_and_UEFI_Co-Existence

    What’s handling giving out boot options? dnsmasq? ISC-DHCP? Windows DHCP?


Log in to reply
 

400
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.