Multicast Problem "Starting to restore.."



  • Hi all,

    I have the fog 's version 1.2.0 installed in my Ubuntu 15 Desktop.
    The Unicast deployment works fine but multicast to my host group doesn’t.
    On theses machines, I have this message on the screen :
    “Starting to restore image (-) to device (/dev/sda1)”

    the restart of the Multicast did not solve the problem.
    Theses commands did not solve too :

    mysql -u root <-p password> fog
    truncate table multicastSessions;
    truncate table multicastSessionsAssoc;
    exit;

    sudo service FOGMulticastManager stop
    sudo killall udp-sender
    sudo killall udp-sender
    sudo killall udp-sender
    sudo service FOGMulticastManager start

    But its not better…

    Thanks


  • Moderator

    @baboun said:

    I understood that FOG should be the master node in the case of Multicast but with not enough space, how it works when I want to upload?

    You can setup the storage nodes however you like.

    The master node of a storage group does not have to be the fog server. It can be what you define it to be.

    All uploads go to the master node of a storage group first, then are replicated to other storage nodes in the storage group - so keep that in mind.

    For multicast to work, the interface name must be correct. It also has to be running Linux, so that the FOGMulticastManager can run and do the job. The interface name must be correct for multicast to work for that storage node.

    So, you have options for the master node, it just takes configuration. While 1.2.0 is not as flexible with this, I’m sure it can be done.



  • Hello,

    I have indicated a local directory of fog in Web GUI (storage node) but has not got a very large capacity and all images should be saved on QNAP.
    In the storage group, I have now my FOG as master node and QNAP as member of group.
    I understood that FOG should be the master node in the case of Multicast but with not enough space, how it works when I want to upload?

    Will FOG be able to know that the images are too heavy for it ? And redirect the save to the QNAP?

    Thanks.


  • Senior Developer

    @baboun no but that doesn’t mean what you want cannot be done. I just don’t have the time or resources to spend on trying to do that.



  • @ch3i said:

    You can’t export a NFS mount as NFS share.

    Try the configuration I’ve posted.

    After a new capture, I will try again the multicast task.
    So, even for the capture, FOG must be the master node and QNAP the membership of his group ?
    I was wondering whether the image was going to be saved to the QNAP without having to indicate it (cause it’s the second node of the group which has the more capacity ?).
    Cause when I create an image, I cannot choose the storage node and it’s the storage path of the master node which appears. I would not want the image to be saved in FOG.

    Thanks for your patience :blush:

    @Tom-Elliott said:

    Or install the proper services and items on the QNAP (e.g. Apache2, udp-cast, tfpt, etc…)

    Do you mean that there is a FOG package for QNAP, that can be installed?


  • Senior Developer

    Or install the proper services and items on the QNAP (e.g. Apache2, udp-cast, tfpt, etc…)


  • Moderator

    @baboun said:

    I understant but how FOG will going to find the images to the QNAP if it’s fog which is the master node.
    I have to mount the QNAP 's storage path to the path of local storage (master node) ?
    Thanks and sorry for my english …

    ps : I was in a labo test but is it normal that all my images created before were removed ? I think its occured when i change the master node :) . Good to know

    You can’t export a NFS mount as NFS share.

    Try the configuration I’ve posted.



  • I understant but how FOG will going to find the images to the QNAP if it’s fog which is the master node.
    I have to mount the QNAP 's storage path to the path of local storage (master node) ?
    Thanks and sorry for my english …

    ps : I was in a labo test but is it normal that all my images created before were removed ? I think its occured when i change the master node :) . Good to know


  • Moderator

    @baboun The QNAP is not the multicast server. You have to :

    • Create a local storage (small size…)
    • Create a new storage in your FOG web UI with the new local storage
    • Configure the group storage with the local and QNAP storage
    • Set the local storage as Master Node.

    With those settings, it’s the FOG server which push the image via multicast, not the QNAP.



  • Yes it is. I have only one storage Node and it’s the QNAP (NFS)


  • Moderator

    @baboun is your storage node (QNAP) configured as master node in your storage group ?



  • My output log file /opt/fog/log/multicast.log :

    StorageNode Not fount on this system.
    StorageNode Not fount on this system.
    StorageNode Not fount on this system.
    StorageNode Not fount on this system.
    StorageNode Not fount on this system.
    StorageNode Not fount on this system.
    StorageNode Not fount on this system.

    every 10 sec “StorageNode Not fount on this system”. Is it normal ?
    My storage Node is a QNAP’s NAS.



  • Thanks for your reply ch3i
    No, I have only one.
    Yes I saw many topics about this but nothing resolve mine

    The problem occurs with Two operating systems ubuntu 15 and debian 8


  • Moderator

    @baboun Hi, Have you multiple network interfaces ?

    Try to search on forums, there are lot of topic about that error : https://cse.google.com/cse/publicurl?cx=013831856522586480408:mlbymhymgxs&q=Starting to restore


Log in to reply
 

359
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.