Best Linux distro for FOG trunk



  • Hi there, I have not be able to successfully PXE boot to menu. I get the dreaded Open TimeOut error.
    I have installed Centos 7 (64bit) with FOG trunk. The installation completed successfully. I get the Web UI fine but I cannot load the FOG boot menu.
    The fog installation is not using proxyDhcp as I am leveraging our existing DHCP server. So 66 & 67 have been configured appropriately.
    The ability to perform TFTP -i xxx.xxx.xxx.xxx get undionly.pxe (from windows) and TFTP -v xxx.xxx.xxx.xxx -c get undionly.pxe (from Fog host server) all works tine.

    The security layer on the fog server has been disabled.

    The permissions for images, tftp, and ipx (under var/www/html/fog/services/) have been changed to 777.
    The owners for the above folders are fog:root.

    The network is a multiple vlan /subnet environment and STP and RSTP are turned at the switch level.

    So I need some help with:

    1. Troubleshooting why the PXE boot menu is not loading? is this due to the TFTP session is actually timing out or something else.
    2. What is the best combination for installing FOG i.e. is Ubuntu better than Centos?

    Thanks


  • Moderator

    @tprice What new documentation (for future readers)?



  • Celebration. It works. The things that I have changed was a complete new build of Centos 7, FOG (Version: 7306), and followed new documentation. This allowed me to register a machine and perform inventory but I could not start an upload (could not load images directory (/bin/fog. Upload).

    Did some check regarding services and found NFS was not running. Once the latter was started, the ability to perform the partclone was successful.

    I am very happy, thank you all


  • Moderator

    @tprice You stated that your fog server is on the .54 vlan, but @Sebastian-Roth pointed out that your redundant DHCP servers are both giving out a .50.45 address for option 066 and pxeboot.0 for option 067.

    I think you have a DHCP mis-confguration, I don’t think there is anything wrong with your switches or fog server.

    I don’t think pxeboot.0 has been used since .32 and older, so I assume you’ve had fog working before.



  • @Sebastian-Roth Hi there, I did not get this solved. I need to look at my switch and TFTP communication.



  • Another consideration on hyper-v is integration services. Ubuntu is not very integration services friendly (NIC and SMP issues mainly). Centos is a better choice for hyper-v guests.



  • Hi there, I did not get it solved. But I think the issue within my Switch configuration. I have nine vlans. I have attached the Fog server on the vlan which is used by the workstations (.54) and the DHCP server is on a different vlans (.50).

    I can ping the qdn, fqdn and reverser ping the FOG server within the main vlans.

    The fog server is sitting on a Hyper-v host. The virtual switch is bridging the physical NIC.

    So I need to figure out why the switch is answering the TFTP request. I suspect the ip helper and DHCP relay on the switch is the root cause.

    Troy


  • Developer

    What do you mean by “port 0 relaying”? Sounds a bit like it does not work. But I am pretty sure you would be fine with the quick fix (linking pxeboot.0). Did that work for you?



  • Hi there, thanks for the response. I need to figure out why the tftp response is looping through my the switch.

    It appears the IP Helper on the switch’s are enabled with port 0 relaying to our DHCP server.


  • Developer

    @tprice Did you get this solved?



  • We started off with Ubuntu Desktop, then Server (no gui), then I switched up to Debian Server, and now I’m running CentOS 7 no GUI on a minimal server install for my development server. Whatever I’m using for dev eventually makes it out to our production/live servers.

    IMO Debian is head and shoulders better than Ubuntu, and I’ve found CentOS to be the most stable and trouble free of the bunch.



  • @tprice said:

    1. What is the best combination for installing FOG i.e. is Ubuntu better than Centos?

    Just my personal preference, but I’ve always been happy with FOG on Ubuntu and formerly Fedora.


  • Developer

    In the packet dump I can see two DHCP servers answering (IP .54.1 and .54.253). Both offering the same information - so I guess this is configured for redundency. They point the client to another server on a different subnet (IP .50.45). This should be alright as the gateway/router information in the DHCP packet seams fine - if this really is your FOG server. Or is it only serving TFTP??

    One thing I wonder about is the filename offered to the client: pxeboot.0

    As a quickfix you can create a link to that file on your TFTP server:

    cd /tftpboot
    ln -s undionly.kpxe pxeboot.0
    

    The result from PCAP show now response from FOG server or anything related to port 69.

    If you want to see that traffic you need to capture on .50.45!



  • Hi there, I am using undionly.kpxe in the Windows DHCP server.

    The result from PCAP show now response from FOG server or anything related to port 69.

    Regards
    ,timeout_issue.pcap



  • Hi Uncle Frank, the options for STP & RSTP are enabled at a global level. I will follow your suggestion and post results.

    Thanks


  • Moderator

    @tprice

    1. Troubleshooting why the PXE boot menu is not loading? is this due to the TFTP session is actually timing out or something else.

    You’re using undionly.pxe ? Can you try undionly.kkpxe ?

    1. What is the best combination for installing FOG i.e. is Ubuntu better than Centos?

    Depends on who you ask. If you ask me, I think CentOS 7 has less problems with fog. Fedora is also really solid, but it’s more cutting edge.


  • Developer

    @tprice Good to hear that you’ve gone through a lot of testing and provided all the information. In your sentence on STP/RSTP there is one word missing I think - on/off?? Please capture a packet dump while you boot a client and we should be able to see what’s going on.

    yum install tcpdump
    tcpdump -i eth0 -w timeout_issue.pcap port 67 or port 68 or port 69
    

    tcpdump will sit there and wait (no more output). Boot the client and wait till you see the error. Hit Ctrl+c and upload the PCAP file to the forums.


Log in to reply
 

371
Online

38975
Users

10712
Topics

101675
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.