/images on a mounted drive Mounting File System timeout



  • Hi there,

    I installed FOG 1.2.0 on Ubuntu 14.04. System is on /dev/sda and I mounted a big disk (/dev/sdb1) on /images (before fog install)
    I uploaded several images to /images but I couldn’t download them back on laptop.

    At boot, I got stuck at Mounting File system…
    At that point, /images and subdir had 777 root:root

    So I umount /dev/sdb1, then I found that /images had 755 root:root ??
    Changed it to 777 root:root and mounted /dev/sdb1 to /images again.

    That solved the issue.


  • Developer

    @OvandHo Issue solved?



  • I’ve seen images stop in the middle of the imaging process.

    It’s when the destination HDD runs out of space. :-)


  • Developer

    @OvandHo Is your second drive connected through external USB by any chance? Or is it build into the server and connected via IDE/SATA…?

    Stopping in the middle of downloading does not sound like a permissions problem to me. More like “availability”. Maybe NFS died or the hard drive lost the plot? Do you see anything in /var/log/syslog when this happened?


  • Senior Developer

    Anything in error logs?



  • Oh no, it’s not working anymore.

    So after the first post I downloaded the image but in the middle of the download, it stopped working. No errors, just no traffic anymore.
    So reboot, task was still there, and again the Mounting File system … and nothing

    So i went back on the server, did a
    service nfs-kernel-server stop
    umount /dev/sdb1
    service nfs-kernel-server start

    and the laptop suddenly continued its task and downloaded the full image

    so upload works on /dev/sdb1 mounted on /images but download doesn’t
    Upload from /images on system disk works.

    I rechecked and everything is with 777 root:root both on /images on system and on the big disk

    I’m out of ideas here. Any help appreciated


  • Senior Developer

    The base directory should’ve been created with 777 so it becoming 755 leads me to think maybe somebody else created the /images folder first?


 

386
Online

41.5k
Users

12.0k
Topics

113.4k
Posts