Deploying an Image



  • Hi Guys,

    I tried searching for my issue but I think I’m not searching correctly.

    Environment

    • Xen 6.5
    • Ubuntu 14.04.03 LTS
    • FOG 1.2.0
    • Windows 7 64 Bit

    So what I did was I built out a windows 7 64 Bit VM and installed all the software and updates there (the software aren’t licensed or activated or computer dependent). I then uploaded that image onto the fog server and tried to deploy it onto a Dell Optiplex 3020 SFF. When it restarts and boots up, it goes to

    *Launch Windows Repair
    *Start Windows Normally

    When I select Start Windows Normally, it just boots back to that screen.

    I apologize if this has been answered, I don’t know where to start to search for this specific situation.



  • Ok so imaged the PC with the Bios set to ATA. this time no errors. Already purchased new License for windows. Thanks Tom


  • Moderator

    @Jordonlovik I’ve successfully captured/deployed Optiplex 9020s both on AHCI and “RAID On” SATA Operation modes.


  • Senior Developer

    @Jordonlovik because you’re using an OEM disk and that OEM his license for the gigabyte motherboard not the Dell



  • @shoong after uploading i changed the new host to ATA and it booted. However It will not let me authenticate my windows 7 key. Says that my bios is not licensed and so im stuck there. Would the next step be to play with the Bios on the Host im taking the image from? This Host is extremely important and i would hate to F something up on his computer. The new host i deployed to was set to Raid in the bios (which i then changed to ATA after deployment).

    In the Optiplex Bios
    On Raid(default): Will not boot
    ATA: boots but gets below error
    AHCI: Will not boot

    FullSizeRender.jpg

    For clarification purposes. I am trying to take a Custom Build Host1 (gigabyte MotherBoard) to an Optiplex 9020 Host2


  • Senior Developer

    I fixed the link.



  • @jordonlovik so when you created the image, you set it to ATA first or when you deployed it to another machine, you set it to ATA and it worked? where there any additional configurations or issues after?



  • I had the same issue moving from one Bare metal Machine to an Optiplex. Set the SATA port to ATA and it booted. I will be uploading the image with better compatability like need2 mentioned here.

    @need2 said:

    Windows 7 still thought SATA was a little hard. Before you upload the image, you should generalize the way Windows handles its storage drivers. HowTo:

    http://www.overclock.net/t/1227636/how-to-change-sata-modes-after-windows-installation

    What that will do is force Windows to try multiple different types of storage driver on boot, instead of just the last one it used. The reason you are having this is that the VM likely used a form of IDE driver, and your Dell Optiplex 3020 defaults to AHCI mode on its SATA port.

    If you really didn’t want to upload the image again, you could go to the BIOS and change the SATA mode to IDE or Compatibility. This should allow you to boot at least, but you will be running the drive controller much slower than it is capable of.

    FYI that link is broken.



  • oh yeah, same. they are AHCI, when i switch to ATA it gives me the same error.


  • Developer

    No I only meant SATA options as already mentioned in this thread…



  • aww crap i assumed that part. Are we talking firmware versions? or small settings like boot order etc?


  • Developer

    Same BIOS settings on both machines??



  • Hi Guys,

    So I created a fresh image off of the box and was able to deploy it back to the box that the image came from. However, when I try to deploy it to another box I get the same error. These are Dell Optiplex 3020 SFF.

    Image Name "windows7x64"
    Storage Group "Default"
    Operating System "Windows 7 -(5)"
    Image Type: “Multiple Partition Image - Single Disk (not Resizeable)”



  • Thanks for your help. I’m going to go ahead and kick off a fresh install and image upload.


  • Moderator

    If you can reupload the image, then yes, I would do a fresh install on the 3020 and overwrite the VM image.

    The mode you would want to switch to to make the current image boot is ATA by the way.



  • So I’m checking BIOS and for SATA Operation all I’m getting is

    • Disabled
    • ATA
    • AHCI

    If compatibility isn’t there, I would need to upload the image from the Optiplex and do away with the VM correct?


  • Moderator

    Windows 7 still thought SATA was a little hard. Before you upload the image, you should generalize the way Windows handles its storage drivers. HowTo:

    How to change sata modes after windows installation
    What that will do is force Windows to try multiple different types of storage driver on boot, instead of just the last one it used. The reason you are having this is that the VM likely used a form of IDE driver, and your Dell Optiplex 3020 defaults to AHCI mode on its SATA port.

    If you really didn’t want to upload the image again, you could go to the BIOS and change the SATA mode to IDE or Compatibility. This should allow you to boot at least, but you will be running the drive controller much slower than it is capable of.



  • BSOD:

    Technical Information

    *** STOP: 0x0000007B (0xFFFFF880009A97E8, 0xFFFFFFFFC0000034, 0x0000000000000000, 0x0000000000000000)

    Seems like it’s a driver issue at start up?


  • Moderator

    Press F8 and select “Disable Automatic Restart on System Failure”, then look for a BSOD.


Log in to reply
 

405
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.