Upload issues on laptop with hybrid drive



  • I have an HP Envy Pro 4-b000 laptop that has the hybrid drive on it. I have done a clean install of windows 7 onto the main hdd. When I did the install, the drives came up as disk 1 8GB, disk 2 320GB. I installed it on disk 2. Everything installed just fine, created an upload task and the task went through just fine except for one thing, the image didn’t actually upload to the server. I saw no errors or anything out of the ordinary on the laptop while the upload task was taking place, everything made it to 100% and then it rebooted, took about 55 minutes. Am I missing something on this for it to not upload?


  • Moderator

    I would ask that you try the suggested fixes in this thread, and report back on their results.



  • @Tom-Elliott Sorry for the confusion, was just saying that at that time, before reading your post on the 14.04 issue with mysql, the only way I had been told to fix that problem was to go through the install process of fog again.

    As for the image type question, I didn’t know if that would have any effect on this or not.


  • Moderator

    Hybrid drives are an interesting beast, especially when the hybrid is done via the motherboard. Usually if you want Windows to handle the hybrid solid state storage properly, you have to format it a special way, give it specific flags, and sometimes even label it a specific way, all before installing the driver that handles the hybrid feature. And what you need to do for each of those steps varies by manufacturer.

    Now of course FOG will see the drives completely differently since it is running a Linux kernel in the PXE boot. There could be some issues with how FOG is seeing the drives, especially since hybrid drives on laptops typically use unique storage controllers. I would suggest trying the “All Disks, non resizeable” option. Is this image you are making meant to go onto a different system? If so, I would strongly suggest building the image on a more generic build, such as a virtual machine or regular desktop.

    Lastly, Ubuntu changed a lot of things in 14.04 and beyond, and those changes are unlike any other Linux distro. As such, there are some things that are still buggy in FOG and Ubuntu 14.04. I would strongly suggest going with a different Linux distro such as Debian, RedHat, or Fedora. If you must stay on your current setup, then I suggest backing things up, then upgrading FOG to the SVN branch (see wiki for How To). There are a lot of improvements in the SVN branch that are being prepared for the next major release of FOG. You may still need to work around an issue or two running FOG on Ubuntu 14.04, but your overall experience should be better.

    If upgrading or switching Distros are not options, then we’ll need you to try a few of the troubleshooting steps that Tom listed. There are workarounds for the bugs in Ubuntu 14.04, but we will need a bit more information from you to help point you towards the right fixes.


  • Moderator

    @the_duke

    We will always try to help you and everyone else here the best we can, but we want you to try to help yourself first. The Forums has a search feature at the top, the WiKi has a search feature too.

    The information that has been given to you so far here will likely solve your problems, you just have to read.

    Please stay on topic. If you have a separate question that is general, it should be posted into the general section.

    Everyone here that is trying to help you are all simply volunteers. The active community is not paid nor has any obligation to help, but chooses to do so out of kindness and interest in the FOG project. They are not throwing answers at you because they have to, but because they are trying to help out. Not following advice can make those trying to help you feel not appreciated.

    And, for your question about image types, I’d suggest “all disks” only because in your OP, you stated that Windows saw the two volumes as two separate disks.


  • Senior Developer

    @the_duke I’m lost.

    I have no idea what you’re trying to say. What does reinstalling FOG have to do with anything in regards to the problem you’re having with uploading images? Yes, if you’re having problems with mysql, it would affect uploads as well. However, seeing as you are uploading the image and it’s failing after the image is complete, it’s most likely FTP related.

    In regards to the problem you have with Ubuntu 14.04 and mysql, the link I gave should help you fix the problem you’re seeing.

    Please, don’t keep iterating information that has no relevance, especially if the information We (the devs, moderators, or whomever) are trying to give you to help has not even been attempted.

    We’re not just throwing information out to confuse you, the info we’re giving (and sometimes asking you for) is simply so we can help, and better help, a problem or series of problems you are having.

    You came to this thread saying you’re having problems with uploading the image. We direct you to the Troubleshoot_FTP wiki because uploading (moving from /images/dev/ to /images/imagename) happens from FTP.

    You then stated you’re having problems with Ubuntu 14.04 and getting a Database Schema issue? What does this have to do with image uploading? You understand how confusing it is to follow what is actually happening?



  • @Tom-Elliott After reinstalling fog again to be able to access the web interface, I looked in my images path and it is listed in for to go directly to the /images/hpenvy folder. One question that I have is that with this being a hybrid drive and the OS only on one of the drives, does it matter which image typed that it is; type 2 or type 3 for single disk vs all disk?
    No I have not gone through the troubleshoot_ftp yet


  • Senior Developer

    How does that have any relation to the information I gave previously?

    Did you run through Troubleshoot_FTP wiki?

    For ubuntu 14.04: Have you tried this? https://github.com/fogproject/fogproject/issues/1



  • @Tom-Elliott Well, my problem is that with my system, I have ubuntu 14.04 and fog 1.2.0 and it has been very buggy ever since I upgraded to 14.04. If my computer ever restarts, I basically have to go back and reinstall fog because I get the error on the web interface saying that the schema needs to be updated or installed. I just ran the backup script and am planning on going back to 12.04 and then import my database after I install fog.

    I know which system that it is and what image is supposed to be assigned to it. I gave the system and the image a specific name, however the image did not get uploaded that way to my /images folder in fog.


  • Senior Developer

    The files in the dev folder are based on the uploading systems mac address. Find that system and you will see what image is assigned to that system. From there you can look at the image and find out the path your system is expecting it to be.

    For what it’s worth, you should also check your FTP settings:

    https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP



  • @ch3i In my /images/dev, I have a few folders with numbers for the name. Are you telling me that I need to rename one of these as my Image? How would I know which one is which?


  • Moderator

    @the_duke In your /images/dev/ have you something ? it’s was there is a “R” here >> ls -alR /images



  • I’m using version 1.2.0. I know it’s not uploading because the image is not in /images, and if I try to push it out to another computer I get an error saying that I need to upload an image first


  • Developer

    Which version of FOG do you use? How do you see that “the image didn’t actually upload to the server”?? What do you see running this command on your FOG server: ls -alR /images


Log in to reply
 

353
Online

39.5k
Users

11.1k
Topics

105.7k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.