Trying to setup FOG to use one network card just for PXE boot and the other one for the internet interface



  • Hello. I want to setup fog on a computer that has two ethernet adaptors. I want the web interface to be accessible through the network but I want FOG only to have access for PXE booting, reimaging through a different card that will be used on an isolated network. How can I set this up exactly? I got a little bit lost through the setup, I actually managed somehow but I think I changed some configuration afterwords and it stopped working.
    Thank you in advance.



  • Yes, I tried changing it between and it’s still the same. By the way, how exactly can I edit the initial setup settings? I found the the fogsettings file located in the fog user folder but I have no permission over it and don’t know the default password for it.
    Are the settings in the web interface all there is? Because I tried there to change between eth0 and 1 but got nothing still.
    Thanks.


  • Testers

    @ciprian you said that when you set it up that eth1 was what you were using as the dedicated imaging nic, but it is set to eth0. Can you try changing that setting to eth1 and let us know if that works?



  • The correct network interface is written there, eth0 which is the dedicated network card I chose for reimaging. That’s what doesn’t add up for me.


  • Developer

    Take a look at FOG Configuration -> FOG Settings on the web interface. ‘Multicast Settings’ and ‘NFS Server’ have interface settings. What do they look like?



  • Well I did a fresh install again and when the setup asked me which interface to use I wrote eth1 instead of eth0, I made sure eth1 is the dedicated network card for it but it isn’t working. I pluged the cable in the main interface I use for web and the PC boots through that one. Can’t I change them now somehow?
    I appreciate your answer.



  • I have that setup here. Basically you just install your two NIC adapters. I have one setup for DHCP and hooked to the outside line. The other i assigned a static IP address and use it for my FOG server and run it into a image switch. I use just the one gateway from my DHCP so that i can access the Internet on the server adapter. The biggest thing for me was that when i was setting up the server, to make sure i assigned the correct interface name when installing the FOG server. In my Linux setup is wasn’t just ETH0 or eth1. It was a totally different net name. So make sure you use IFCONFIG to see what your interfaces are. If your using Linux that is.


Log in to reply
 

706
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.