error when running install-script



  • I’m trying to upgrade from svn 3427 to latest of today. When I run the install script I get an error telling:

    ./installfog.sh
    …/lib/common/functions.sh: line 305: syntax error in conditional expression: unexpected token (' ../lib/common/functions.sh: line 305: syntax error near+(
    …/lib/common/functions.sh: line 305: if [[ "$linuxReleaseName" == +(*[Ff]'edora'*) ]]; then' ../lib/common/config.sh: line 62: syntax error in conditional expression: unexpected token(’
    …/lib/common/config.sh: line 62: syntax error near +(*' ../lib/common/config.sh: line 62: if [[ “$linuxReleaseName” == +(
    ‘Ubuntu’|‘Debian’) ]]; then’
    ./installfog.sh: line 45: syntax error in conditional expression: unexpected token (' ./installfog.sh: line 45: syntax error near+(

    ./installfog.sh: line 45: ` if [[ “$linuxReleaseName” == +([Dd]‘ebian’|‘buntu’) ]]; then’

    I’m running Centos 5.11 and php 5.6.8


  • Developer

    @pmonstad said:

    syntax error in conditional expression: unexpected token (

    Probably CentOS 5.11 has a pretty old version of bash running which cannot handle regular expressions in condition clauses. I guess there is no easy solution to this but update your OS. Probably best if you can setup a new server for testing FOG and if you are happy with it you can still consider updating your existing OS.


  • Moderator

    I’m fairly certain it’s failing because you’re running it on CentOS 5.11.

    The latest FOG Trunk has been tested working on the RH varieties CentOS 7, Fedora 21 and 22.

    Past that, you’ll need to get in touch with the @Developers to see if they are willing to make it work with CentOS 5.11, or if they are willing to help you hack something together on it just for you.

    I’d advise you to migrate to something newer.


Log in to reply
 

475
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.