Fog server to serve 2 separate subnet with independant DHCP and TFTP servers



  • Hello,

    I’m trying to create a storage node in order to serve 2 separate subnets with fog.
    I already have a working fog 1.2.0 installation on first subnet (eth0) with independant tftp and dhcp server.
    On second subnet(the one that should be served by storage node) there is also independant tftp and dhcp server.
    I create a storage node on subnet2.

    Here is my config:

    fog_main_server(Ubuntu 14.04):
    eth0 192.168.1.1
    eth1 192.168.2.1

    subnet1 : 192.168.1.0/24
    dhcp_and_tftp_1:
    eth0 192.168.1.2

    subnet2 : 192.168.2.0/24
    dhcp_and_tftp_2:
    eth0 192.168.2.2
    storage node(Ubuntu 14.04):
    eth0: 192.168.2.3
    client2
    eth0: 192.168.2.4

    here is ipxe script for subnet2
    #!ipxe
    menu
    item fog Launch FOG

    choose --default fog --timeout 3000 target && goto ${target}

    :fog
    cpuid --ext 29 && set arch x86_64 || set arch i386
    params
    param mac ${net0/mac}
    param arch ${arch}
    chain http://192.168.2.1/fog/service/ipxe/boot.php##params

    When I launch client2, it loads undionly.ipxe, I get my ipxe menu, then I get an error when chainloading:
    http://192.168.2.1/fog/service/ipxe/boot.php … network unreachable

    What I’m doing wrong (maybe something I misunderstand)?

    Any help would be appreciated.

    Thanks.

    Christophe


  • Developer



  • Hi Uncle franck,

    I added dhcp in my script and my client is now able to chain correctly.
    But i’m facing another problem, I try an upload from my client, it starts correctly, but it hangs at ‘clearing NTFS flag’. Something seems to be uploaded on storage node in /images/dev/. I followed some tips and check directory images rights on storage node, but it seems normal (777 , fog:root owner).
    And when I check main server web pages for tasks, the task is still in queued state.



  • hi Uncle Franck,

    Thanks for your answer,
    I will check this tomorrow.

    Cheers.


  • Developer

    Well, iPXE does not use IP settings from previous DHCP messages. When the machine comes up it asks for an IP, loads a boot file via TFTP (if told so in the DHCP answer) and then “forgets” about the network information. iPXE has to send another DHCP request to hook up to the network itself. So your script should read like:

    ...
    dhcp && chain http://192.168.2.1/fog/service/ipxe/boot.php##params
    

 

443
Online

5.4k
Users

12.6k
Topics

118.9k
Posts