Imaging stuck on upload after finished



  • Please see my picture to see if anyone has seen this before. I got stuck after the “Clearing NTFS flag” and now it is just displaying a bunch of starts down the middle of the screen.

    [url="/_imported_xf_attachments/0/972_photo.JPG?:"]photo.JPG[/url]


  • Senior Developer

    [quote=“Jim Holcomb, post: 32006, member: 15162”]Buehler? Anyone? Guys, I have seen multiple posts on here about this issue. Do we have any idea what’s going on, or when a fix might be in order?[/quote]

    There are two places you probably need to check.

    When you install fog we set a random password for the linux side’s fog user.

    This password is then the password that is supposed to be set for Storage Management and your relevant storage node. This can be changed on the linux side with a few commands:
    [code]sudo passwd fog[/code]
    Enter your password twice and remember it
    Log into the FOG GUI and set this username and password in
    Storage Management->All Storage Nodes-><YOUR STORAGENODE>->Management User and Management Password.

    Then goto:
    FOG Configuration (? Icon)->FOG Settings->TFTP Server->FOG_TFTP_FTP_USERNAME and FOG_TFTP_FTP_PASSWORD and set the same username/password pair.

    Then test.

    To make absolutely sure it’s not a permissions issue run:
    [code]chown -R fog:root /tftpboot
    chown -R fog:root /images
    chmod -R 777 /images[/code]



  • Buehler? Anyone? Guys, I have seen multiple posts on here about this issue. Do we have any idea what’s going on, or when a fix might be in order?



  • Ok, so other troubleshooting steps taken.
    I tried [FONT=monospace][COLOR=#000000]tftp x.x.x.x. get [/COLOR][/FONT][FONT=monospace][COLOR=#000000]undionly.kpxe and got positive results. However, when I try [/COLOR][/FONT][FONT=monospace][COLOR=#000000]tftp -v X.X.X.X -c get undionly.kpxe from the FOG server (via putty) I get permission denied. Any thoughts?[/COLOR][/FONT]



  • John, have no idea what you just said here. How do I do this?
    [QUOTE]o fix my issue I had to set the unix user password to the plain text password. The entry in the config page still needs to be fogcrypt’d.[/QUOTE]



  • I’ve been following this post as I too ran into the last step of an image update stalling with *s. I finally received the message about invalid ftp password, and I have since fixed my issue. I had the “2. Fog Configuration > Fog Settings > TFTP Server > FOG_TFTP_FTP_PASSWORD” configured as the fogcrypt’d password. I also had, i’m assuming since I first installed fog, the unix user set to the fogcrypt’d password also. It used to work this way, I don’t know if it should have, but it did.

    To fix my issue I had to set the unix user password to the plain text password. The entry in the config page still needs to be fogcrypt’d.



  • My humble of apologies! I did not see the 2nd page in this thread. Silly me. Trying that now…



  • [quote=“Jim Holcomb, post: 31679, member: 15162”]Anyone??? I upgraded to v1.1.2 and still the same issue appears (TFTP invalid password)[/quote]

    Did you try/verify anything I said at all? It was a direct response and everything.



  • Anyone??? I upgraded to v1.1.2 and still the same issue appears (TFTP invalid password)



  • i have reinstall fog 1.1.2 and now it’s ok !!!



  • hello;

    Fresh reinstall of FOG 1.1.2 and same probem with my first upload:
    It ok on the defaut storage but not on a new storage group and node.
    after the upload i have this:

    and in the log from apache:
    PHP Parse error: syntax error, unexpected ‘;’ in /var/www/fog/service/Post_Stage2.php on line 24



  • We have come up with this problem too. I’ve noticed that when this error happens we have these lines in the log file

    [06-26-14 10:21:15 am] * No tasks found!
    [06-26-14 10:21:25 am] | StorageNode Not found on this system.
    [06-26-14 10:21:35 am] | StorageNode Not found on this system.
    [06-26-14 10:21:45 am] | StorageNode Not found on this system.
    [06-26-14 10:21:55 am] | StorageNode Not found on this system.
    [06-26-14 10:22:05 am] | StorageNode Not found on this system.
    [06-26-14 10:22:15 am] | StorageNode Not found on this system.
    [06-26-14 10:22:16 am] * Starting FOG Multicast Manager Service
    [06-26-14 10:22:21 am] * Checking for new tasks every 10 seconds.
    [06-26-14 10:22:21 am] * Starting service loop.
    [06-26-14 10:22:21 am] * No tasks found!

    I was in the process of updating to the latest version and it seems that when the service was restarted it finished uploading the image.



  • [quote=“Jim Holcomb, post: 31356, member: 15162”]Tom, I am on v1.1.1 and I just updated an image. All went well, and got the image upload success message. Now the laptop is looping on the FTP login incorrect message. I do not recall setting up an FTP password. Can I just change the password via the FOG interface or does this need to be does elsewhere at the server level? (Ubuntu 12.04)[/quote]

    The password for FTP is that of the fog user on the server, and has to match two locations in the configuration.

    1. Storage Management > All Storage Nodes > Select Storage Node > Management Password
    2. Fog Configuration > Fog Settings > TFTP Server > FOG_TFTP_FTP_PASSWORD


  • Tom, I am on v1.1.1 and I just updated an image. All went well, and got the image upload success message. Now the laptop is looping on the FTP login incorrect message. I do not recall setting up an FTP password. Can I just change the password via the FOG interface or does this need to be does elsewhere at the server level? (Ubuntu 12.04)



  • I am on version 1.1.2. Did the upgrade from 1.1.1 to 1.1.2 this morning.



  • then you may need to look at doing a fresh install. When did you do the upgrade? what version are you on?



  • I have deleted the old image file that I am replacing this with. The file is never being created for the new one.



  • Did this happen after the update? If so, is there a way you can delete your image from the image management portion and the image file in /images, then try and create a new one and associate whatever machine you are using to upload that new image ID? You can also (once the the old one is deleted) change the sql to reflect the new image with the old number:

    user@machine:~$ mysql -u root
    mysql>use fog;
    mysql>select imageid, imagename from images;

    ±--------±--------------------+
    | imageID | imageName |
    ±--------±--------------------+
    | 8 | StudentSpare-HL91 |
    | 4 | BSELAB |
    | 11 | MS16372Teacher2 |
    | 10 | MS163KTeacher2 |
    ±--------±--------------------+
    You want to change this to be:
    [COLOR=#b3b3b3][SIZE=11px]Code:[/SIZE][/COLOR]
    ±--------±--------------------+
    | imageID | imageName |
    ±--------±--------------------+
    | 1 | StudentSpare-HL91 |
    | 2 | BSELAB |
    | 3 | MS16372Teacher2 |
    | 4 | MS163KTeacher2 |
    ±--------±--------------------+
    You’ll execute the following lines at the mysql> prompt.
    [COLOR=#b3b3b3][SIZE=11px]Code:[/SIZE][/COLOR]
    mysql>update images set imageID=1 where imageID=8 limit 1;
    mysql>update images set imageID=2 where imageID=4 limit 1;
    mysql>update images set imageID=3 where imageID=11 limit 1;
    mysql>update images set imageID=4 where imageID=10 limit 1;
    This changes the imageID value for each image definition. You can reorder them however you want, just adjust the imageID values in each statement. the “limit 1” on the end of each statement makes sure you change just 1 record, because logically there can be only 1.

    What this has done is broken the link between the host records and the image records. At this point, the hosts no longer have a valid image associated with them, because they know the image by it’s previous ID, which is no longer valid.

    Now you have to update the hosts table so that any hosts which used the old image ID, now uses it’s new image ID.
    [COLOR=#b3b3b3][SIZE=11px]Code:[/SIZE][/COLOR]
    mysql>update hosts set hostImage=1 where hostImage=8;
    mysql>update hosts set hostImage=2 where hostImage=4;
    mysql>update hosts set hostImage=3 where hostImage=11;
    mysql>update hosts set hostImage=4 where hostImage=10;



  • Also when it goes to the upload screen its says its cloning /dev/sda1/ to /tmp/pigz1 is this correct?



  • I have deleted the image file, tried recreating it and it has not shown up in /images. I’m guessing the permissions aren’t working correctly or something isn’t matching. Here is what it looks like when I run ls -l /images

    drwxrwxrwx 2 fog root 4096 Jun 23 13:02 360WIN7
    drwxrwxrwx 2 fog root 4096 Jun 25 08:42 520STUDENTWIN7
    drwxrwxrwx 2 fog root 4096 Jun 13 10:35 6300STUDENT
    drwxrwxrwx 2 fog root 4096 Jun 13 12:15 6300TEACH
    drwxrwxrwx 2 fog root 4096 May 19 14:29 740TEACHWIN7
    drwxrwxrwx 2 fog root 4096 May 16 13:33 745STUDENTWIN7
    drwxrwxrwx 2 fog root 4096 May 16 13:32 755TEACHWIN7
    drwxrwxrwx 2 fog root 4096 May 16 13:16 760TEACHWIN7
    drwxrwxrwx 2 fog root 4096 May 19 13:58 760WIN7HS
    -rwxrwxrwx 1 fog root 8980811625 Feb 10 14:56 acer_2011
    drwxrwxrwx 2 fog root 4096 Mar 3 11:55 D531WIN7
    drwxrwxrwx 7 fog root 4096 Jun 24 09:07 dev
    drwxrwxrwx 2 fog root 4096 Mar 12 11:34 E6410WIN7
    drwxrwxrwx 2 fog root 4096 May 19 13:30 HP6200Student
    drwxrwxrwx 2 fog root 4096 May 19 14:51 HP6200Teacher
    drwxrwxrwx 2 fog root 4096 May 16 10:43 HPNETWIN7
    drwxrwxrwx 2 fog root 4096 Jan 27 10:39 HPProDesk600
    drwxrwxrwx 2 fog root 4096 Mar 27 09:09 LENOVO
    drwxrwxrwx 2 fog root 16384 Jun 29 2010 lost+found
    drwxrwxrwx 2 fog root 4096 Jun 29 2010 _olddev
    drwxrwxrwx 2 fog root 4096 May 21 13:00 WYHS740WIN7
    drwxrwxrwx 2 fog root 4096 May 19 14:00 WYHS755WIN7


Log in to reply
 

366
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.