Nothing to Boot error..any solution?



  • Hi

    I run fog client and restarting the Pcs…its then boot up to network(iPXE)…then it says "Nothing to boot: No such file or directory (http://ipxe.org/2d03e13b) No more network devices.

    Btw both fog server and win7 pc are on virutal box…


  • Developer

    Great to see that you got it solved yourself. Quite different to how I would have done it but that’s the good thing about FOG and IT in gerneral: There is always more than one way of doing it. Have fun with FOG!



  • @Uncle-Frank upload.jpg

    Hi

    It success upload image now.\0/. THANKS

    Any private IP address can be set. In virtualbox environment, I just want to test that the Fog server is able to contact with client DIRECTLY without any dhcp server in the middle between fog server and client…This is what I did

    step 1
    just install fog server with you reference link or wiki.when it comes to part saying “If you already have DHCP configured, Press NO to disable FOG DHCP”…click YES. the reason is you want your fog server act as dhcp server and will give IPs to client.

    step 2
    Make sure both client and fog server interface adapter on virtualbox are set into Internal Network. On client system boot order on virtualbox, set to harddisk first.

    Step 3
    Set static IP for server and set obtain DHCP on client.(fog server will give IP to client)

    Step 4
    On Fog server run command ufw disable, service tftpd-hpa restart and service isc-dhcp-server restart. While on client just monitor until client received IP from FOG server. Once received IP, test both can ping each other.

    Step 5
    Once both can ping each other, install FogPrep on client then click shutdown. On Fog server run upload image (follow reference link)

    Step 6
    Go to client system boot order, change to Network. and then start client virtual. Fog GUI will appear.

    Done.


  • Developer

    Could you please help us with some more information. Why have you changed IP addresses (is there a reason we should know)? Seams like you have configured a “normal” DHCP now, not proxyDHCP. Also your FOG server MAC address seams changed. Please tell us what you’ve done and best also post the configs you are running. Otherwise it is all very hard guesswork.



  • @adi said:

    @Uncle-Frank
    here is my tcpdumplog1.pcap

    fog server :192.168.100.10
    client:192.168.100.11(get ip via dhcp from fog server)



  • @Uncle-Frank
    here is my tcpdumplog1.pcap



  • @Uncle-Frank

    Hi

    boot.jpg

    Seem like it tried to contact fog server…but it keeps on restarting


  • Developer

    @adi I was a little confused about not seeing TFTP traffic in the packet dump (meaning that iPXE binary didn’t get transferred to the client to boot from) but you still see an iPXE error message. Haven’t used virtualbox for netbooting much lately and so I did not know that it actually uses iPXE as network boot binary in the first place (http://www.virtualbox.org/svn/vbox/trunk/src/VBox/Devices/PC/ipxe/src/usr/autoboot.c).

    IMHO the easiest solution for you here is to add a proxyDHCP using dnsmasq on the FOG server. The virtualbox DHCP server will go on handing the IP address to the client and dnsmasq will add the important information to netboot the client.

    sudo apt-get install dnsmasq
    sudo apt-get remove isc-dhcp-server tftpd-hpa
    

    The second command might fail but I just want to make sure that ISC DHCP and TFTPd are not getting in the way as dnsmasq will do the job for you. Then edit /etc/dnsmasq.conf to your needs. Here is an example for your setup. I am not able to test this so there could be minor errors in it. Look over it and make sure to correct things as needed:

    # Don't function as a DNS server:
    port=0
    
    # Log lots of extra information about DHCP transactions.
    log-dhcp
    
    # Dnsmasq can also function as a TFTP server.
    enable-tftp
    
    # Set the root directory for files available via FTP.
    tftp-root=/tftpboot
    
    # The boot filename, Server name, Server Ip Address
    dhcp-boot=undionly.kpxe,192.168.56.102,192.168.56.102
    
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    dhcp-no-override
    
    # PXE menu.
    pxe-prompt="Press F8 for boot menu", 3
    
    # Tells the client to load undionly.0 from TFTP
    pxe-service=X86PC, "Boot from network", undionly
    
    # This range(s) is for the public interface, where dnsmasq functions
    # as a proxy DHCP server providing boot information but no IP leases.
    dhcp-range=192.168.56.102,proxy
    

    And to finish things up you need to link the boot file and restart dnsmasq:

    sudo ln -s /tftpboot/undionly.kpxe /tftpboot/undionly.0
    sudo service dnsmasq restart
    

    Then bootup your windows client and keep fingers crossed.



  • @Uncle-Frank
    How do I setup my fog server as dhcp server?



  • @Uncle-Frank
    let me check back the cconfig…both virtualbox config with host-only adapter…


  • Developer

    In the pcap file I only see DHCP answers from 192.168.56.100. Which machine is this?

    This seams kind of weird as there is no information about next-server or filename set in those DHCP answers. The client actually does not even try to boot from network or even get iPXE via TFTP.

    Please run this again to the point where you see the above error.

    Again my question: How are your network interfaces configured in virtualbox (hostonly, bridge, …)?


  • Senior Developer

    Just asking but based on the error from ipxe this particular error presents most often because the next-server and/or filename parameters of the dhcp server are not set, or in reachable. This is represented in Windows dhcp as option 66 and option 67. If these are set then I’d double check the VM nics and verify they are in a bridged not natted mode.



  • @Wayne-Workman
    See attached file.issue.pcap

    my fog server IP: 192.168.56.102
    win7 client IP:192.168.56.101



  • @adi As @Uncle-Frank said, a packet dump would be very helpful in figuring out what’s going on. Here’s an alternative guide that uses Linux to do the packet dump. Look in the “troubleshooting” section here: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_TFTP



  • @Uncle-Frank
    Both virtual machines can ping each other and firewall were off…


  • Developer

    How is the network configured for those two virtual machines? Please make sure those two machines can reach each other (e.g. boot both and ping from one to the other).

    Would be a real help if you could capture a packet dump with the traffic from the windows machine while it tries to boot up into iPXE. Follow this article: https://www.virtualbox.org/wiki/Network_tips

    Upload the pcap file here in the forums and we’ll have a look!



  • @ch3i
    the transfer output was successful:865 bytes in 1 second.


  • Moderator

    @adi said:

    @ch3i
    I already disable firewall…how to test ?

    On a Windows host, enable tftp client via “Turn Windows feature on or off” and select tftp client. After that test your connection via command line interface on the windows like that :

    tftp xxx.xxx.xxx.xxx GET boot.txt boot.txt (where xxx.xxx.xxx.xxx is your fog server IP !)
    

    If it’s ok :

    Transfer successful: 865 bytes in 1 second(s), 865 bytes/s
    


  • @ch3i
    I already disable firewall…how to test ?


  • Moderator

    @adi said:

    fog version 1.2.0…n os linux mint 17.2(rafaela)

    Have you a firewall ? Can you access your tftp server with a tftp client (to test) ?


 

421
Online

41.8k
Users

12.3k
Topics

116.1k
Posts