SOLVED Fog Client Installer issue 4378

  • Not sure why this isn’t working, but I’m getting an error trying to install the Fog Client MSI.

    It tells me Unable to Install Fog Project CA: The system cannot find the specified file. I did check and ensure that the fog address is correct during the install process and the web root is /fog

    I’m having issues with the join to AD and renaming of machines with the OLD client, but version 0.9.5 seemed to work fine on whatever machines already had it (I had version 0.9.3/0.9.4 installed on some test machines and they appeared to “auto upgrade”). The rename and join to AD worked after clicking “reset encryption data”

  • So, after uninstalling the Legacy Client, and not rebooting but just immediately re-trying the new client, it works, it installed without error.

  • @Jbob I’m having the same issue here as the OP, but with SVN version 4223, Cloud number is 5090.


    I do have the legacy client installed currently. I’ll pull that off and try again.

  • @Marcus-Allen Hmm…this only seems to work on existing machines. From a newly re-imaged computer, the renaming still doesnt work…but I have another topic open about that.

  • @Jbob
    To follow up. If I remove the legacy client first, then it installs. I’m now wondering if there is a way to install the new client through GPO after removing the old client?

  • Senior Developer

    @Marcus-Allen said:

    Unable to Install Fog Project CA

    This error is with installing us (fogproject) as a CA on the machine. I’ll be in contact via PM to further debug this.

  • I should also follow up with this:

    Currently on this machine is the legacy version of Fog. I will need to find a way to remove the legacy version and install the new version, without touching 3500 computers. I’m going to remove the legacy version manually first, then try to reinstall the new version to see if that helps.