MAC format invalid & other MAC issues



  • I have recently setup V 2922 on Fedora 21-5. I have been having an issue getting anything to register.
    Initially when i try to register from the client doing a full registration i get a message about no MAC found. This is after it has pulled an IP and gone through the little bit of asci art. I thought id give manually registering a machine in fog a shot and ended up getting a MAC format invalid. This is happening on HP Z230’s. I have looked on the forums and didn’t find much about this particular issue. Would you have any insight as to what might be happening ? much appreciated.



  • @Tom-Elliott looks like it is .ipxe that is showing up, I had to record a video and play it back to see it. Yes the thread has moved in the direction of some machines are booting and others aren’t. It was originally a thread about none of the machines being able to register due to a MAC issue.
    I’ll change the boot file to .kkpxe and see if that works with the machines that won’t boot.


  • Senior Developer

    @AustinR, there is no such file as default.kpxe presented to any of our underlying code. If you have edited the file to get default.kpxe, maybe this is the issue altogether?

    If you mean default.ipxe which is stored it /tftpboot, all this file is is a text file that is telling the ipxe (undionly.kpxe) what to look for. What I’d recommend is changing from the bootfile undionly.kpxe to undionly.kkpxe.

    Then I again I am still kind of lost on what this thread is about, so forgive my misunderstanding. If I understand it correctly, some systems are booting fine, while others are hanging or erroring out. My best guess is this is due to the bootfile and I’d start by trying the undionly.kkpxe. If this still doesn’t work, at least we know we’re heading somewhere.



  • @Wayne-Workman , I just verified that the only scope using 66,67 is the 10.1.12.x that workstations get their IP’s from. Is there a log created during the pxe startup on the client machine ? i see something flash by but to fast to see what it says, its only these few machines now. The Optiplex 9020,7010 and the HP z230 are all booting and exiting properly now. honestly we don’t have very many of the others left. I think i’ll just move on. I appreciate all the help you provided.

    Thank you.


  • Moderator

    @AustinR

    So… DHCP… and DHCP Scopes - and DHCP Global settings… somewhere or another you likely have default.kpxe set as option 067.

    I’ve seen situations in organizations that have the correct settings set lower in the DHCP scope for a site, but a global setting simply overrides it. Please double check if this is the case.

    Also - do you have dual DHCP servers or redundant DHCP servers? Are you sure DHCP is not running on the FOG server? Is dnsmasq or CrucibleWDS ProxyDHCP running anywhere? Do you have an active WDS Server on your network?



  • FOG Configuration
    FOG Version Information
    Version: 4704

    Kernel Versions
    DefaultMember
    bzImage Version: 4.2.0
    bzImage32 Version: 4.2.0


  • Moderator

    @AustinR That’s interesting because I’m on FOG Trunk just as you are, but I cannot find any such file called default.kpxe on my FOG server.

    Look into “FOG Configuration” and tell us what kernel it says it’s using.


  • Moderator

    This post is deleted!


  • Here is the output, also i was able to successfully grab an image from the z230 i was working on It failed but at least the registration portion is working. The issues are now only with the inspiron laptops and a the surface pro’s we purchased. I’m not to concerned about the surface as i couldn’t get them to work properly in the prior version either.
    Wayne, sorry about not responding to the IM, somehow the avatar circle was placed under the new post button and i literally just realized it was there.

    /var/www/html/fog/service/ipxe/default.kpxe
    /opt/fog_trunk/packages/tftp/default.kpxe
    [root@Fogsrv01 ~]#
    [root@Fogsrv01 ~]# /var/www/html/fog/service/ipxe/default.kpxe
    -bash: /var/www/html/fog/service/ipxe/default.kpxe: Permission denied
    [root@Fogsrv01 ~]# /opt/fog_trunk/packages/tftp/default.kpxe
    -bash: /opt/fog_trunk/packages/tftp/default.kpxe: cannot execute binary file: Exec format error


  • Moderator

    @AustinR

    Can you run this command on the FOG server and provide the results?
    find / | grep default.kpxe

    Also look at this: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_TFTP



  • Good morning, It would seem that the fog server is in fact partially working. I by chance had an optiplex 7010 boot into the imaging selection menu. It would seem that the HP Z230 and the older dell inspiron with a yukon chipset still can not boot. They both timeout at tftp://10.1.9.9/defualt.kpxe. The DHCP server is still set to use undionly.kkpxe so i’m a bit confused as to why its trying to use the default.kpxe.



  • Hi, The error log is pretty short, I verified that Bootfile in DHCP was set to undionly.klpxe. This had not changed. I had a function FOG server setup for over a year however the VM it was hosted on died. I found out later that we had no backup. live and learn i supose…
    [Sun Sep 20 03:21:01.991263 2015] [auth_digest:notice] [pid 837] AH01757: generating secret for digest authentication …
    [Sun Sep 20 03:21:01.992304 2015] [lbmethod_heartbeat:notice] [pid 837] AH02282: No slotmem from mod_heartmonitor
    [Sun Sep 20 03:21:01.992342 2015] [ssl:warn] [pid 837] AH01882: Init: this version of mod_ssl was compiled against a newer library (OpenSSL 1.0.1k 8 Jan 2015, version currently loaded is OpenSSL 1.0.1j-fips 15 Oct 2014) - may result in undefined or erroneous behavior
    [Sun Sep 20 03:21:02.085664 2015] [mpm_prefork:notice] [pid 837] AH00163: Apache/2.4.16 (Fedora) OpenSSL/1.0.1j-fips PHP/5.6.13 configured – resuming normal operations
    [Sun Sep 20 03:21:02.085754 2015] [core:notice] [pid 837] AH00094: Command line: ‘/usr/sbin/httpd -D FOREGROUND’
    [Sun Sep 20 03:21:02.097933 2015] [:error] [pid 15812] avahi_entry_group_add_service_strlst(“10.1.9.9”) failed: Invalid host name
    [Sun Sep 20 03:21:02.100265 2015] [:error] [pid 15812] avahi_entry_group_add_service_strlst(“10.1.9.9”) failed: Invalid host name


  • Moderator

    @AustinR said:

    thanks for the response, I had a feeling it wasn’t clear. in fog settings under tftp i believe there was a drop down to select the pxe file, the options were several different files. I don’t remember the names available but there were at least 4.
    That selection box is no longer available it shows just a blank space with no box for drop down. I’ll provide a vid in the morning when i get to work. Thanks again for such a quick response.

    Ok we understand more now. So you know, that drop-down box has never actually done anything. Now I’m suspecting that you have DB or Apache issues… Can you provide us with your Apache error logs? They are here: FOG Configuration -> Log Viewer -> Apache Errors.

    Additionally, I would still recommend trying to use undionly.kkpxe Follow these steps to change your boot file: https://wiki.fogproject.org/wiki/index.php/Modifying_existing_DHCP_server_to_work_with_FOG



  • thanks for the response, I had a feeling it wasn’t clear. in fog settings under tftp i believe there was a drop down to select the pxe file, the options were several different files. I don’t remember the names available but there were at least 4.
    That selection box is no longer available it shows just a blank space with no box for drop down. I’ll provide a vid in the morning when i get to work. Thanks again for such a quick response.


  • Moderator

    @AustinR said:

    it went ok except I can not select the boot file now. It’s just a blank area with no way of selecting anything. When booting a machine now it’s looking for default.kpxe

    How were you selecting the boot file before? Can you provide photographs or a short video (via YouTube) of what you’re seeing?


  • Senior Developer

    Yeah I’m totally lost.


  • Developer

    You mean you cannot add a host manually via the web interface?? I am just a bit confused. Re-reading everything I still don’t really get what’s going wrong for you.

    Where do you want to “select the boot file”??



  • thanks, i have tried the mentioned and still no joy, This is happening with different vendors , dell HP and lenovo. I did an update to the svn version 4704 a few minuts ago as mentioned here https://forums.fogproject.org/topic/5265/invalid-mac-address-when-trying-to-add-hosts and it went ok except I can not select the boot file now. It’s just a blank area with no way of selecting anything. When booting a machine now it’s looking for default.kpxe


  • Moderator

    Try to switch your DHCP option 067 to undionly.kkpxe and also try to do a firmware update on the Z230.

    Please try to network boot on other hardware to figure out if it’s a host hardware issue or a FOG issue.


Log in to reply
 

408
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.