Uploaded Images are not Moving for DEV folder to Image folder.



  • I am running Ubuntu 12.04. I have what I believe to be a clean install of fog. I can add machines to the database and upload an image. However when I go to bring down the image onto another machine it says the Image location cannot be found. For some reason after the image is uploaded it will not move out of the temporary dev folder to the Images folder. Any advice? Thanks!


  • Moderator

    @bsmaby

    Everything is in the link Wayne posted. Specifically, https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP#Permissions and https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP#Credentials_.2F_Passwords

    Let us know if you continue to run into issues.



  • @Atton said:

    Thanks! My issue was 2 things. First my images folder belonged to the Root user and not the fog user. Second I needed to change the fog config on the GUI to match the username and password of the Machine.

    I believe I am having the same issue as this but I am a noob at Linux and might need some more clarification.

    So first of all my images also seem to be stuck in the /images/dev/ folder after the upload completes. Second I noticed that the folder the image is in and also the image it self has an owner of root when I am working under a user of fog. So it appears to me that I am having the same issue as you but don’t exactly know how to fix it.

    Can someone explain what I need to change in the config file on the GUI? The only place I found a username and password was under the TFTP setting. (currently it has a username of fog there with a blank password). Next if i need to have the owner of the files be my “fog” user, how do I change that? How do I ensure that all the images that come in are owned to my “fog” user? Thanks for any help!


  • Senior Developer

    I’d recommend adjusting the /opt/fog/.fogsettings file specifically the password and storageftppassword this way this doesn’t get changed in the future if you update.



  • Thanks! My issue was 2 things. First my images folder belonged to the Root user and not the fog user. Second I needed to change the fog config on the GUI to match the username and password of the Machine.


  • Moderator

    @Atton This is a common problem, and an easy fix. It’s most likely your FTP credentials that need fixed. Here is an article on it: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP

    If you need further help, don’t hesitate to ask. We are here to help.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.