Multicast issue: FOG specifying wrong interface when starting udp-sender



  • Hello. I’ve noticed an issue where FOG is not using the correct interface when starting udp-sender, which results in it quitting right away and not running the multicast task. My interface name, as specified in fog_udpcast_interface is “enp4s0” but FOG appears to keep trying to use “eth0”, as shown in the log below

    [09-08-15 11:37:49 pm]  * No tasks found!
    [09-08-15 11:37:59 pm]  | Sleeping for 10 seconds to ensure tasks are properly submitted
    [09-08-15 11:38:09 pm]  | Task (48) abc is new!
    [09-08-15 11:38:09 pm]  | Task (48) abc has been cleaned.
    [09-08-15 11:38:09 pm]  | Task (48) /images/OldAcer image file found.
    [09-08-15 11:38:09 pm]  | Task (48) 1 client(s) found.
    [09-08-15 11:38:09 pm]  | Task (48) abc sending on base port: 62188
    [09-08-15 11:38:09 pm]  | CMD: cat /images/OldAcer/d1p1.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 1 --max-wait 660 --portbase 62188 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/OldAcer/d1p2.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 1 --max-wait 660 --portbase 62188 --full-duplex --ttl 32 --nokbd --nopointopoint;
    [09-08-15 11:38:09 pm]  | Task (48) abc has started.
    [09-08-15 11:38:19 pm]  | Task (48) abc is no longer running.
    [09-08-15 11:38:19 pm]  | Task (48) abc has been cleaned as complete.
    [09-08-15 11:38:29 pm]  | Task (48) abc is new!
    [09-08-15 11:38:29 pm]  | Task (48) abc has been cleaned.
    [09-08-15 11:38:29 pm]  | Task (48) /images/OldAcer image file found.
    [09-08-15 11:38:29 pm]  | Task (48) 1 client(s) found.
    [09-08-15 11:38:29 pm]  | Task (48) abc sending on base port: 62188
    [09-08-15 11:38:29 pm]  | CMD: cat /images/OldAcer/d1p1.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 1 --max-wait 120 --portbase 62188 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/OldAcer/d1p2.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 1 --max-wait 120 --portbase 62188 --full-duplex --ttl 32 --nokbd --nopointopoint;
    [09-08-15 11:38:29 pm]  | Task (48) abc has started.
    [09-08-15 11:38:39 pm]  | Sleeping for 10 seconds to ensure tasks are properly submitted
    [09-08-15 11:38:49 pm]  | Task (48) abc is no longer running.
    [09-08-15 11:38:49 pm]  | Task (48) abc has been cleaned as complete.
    

    Additionally, the log file for that task “multicast.log.udpcast.48”

    Udp-sender 20120424
    No suitable network interface found
    The following interfaces are available:
            lo      127.0.0.1
            enp4s0  10.255.6.20
    cat: write error: Broken pipe
    Udp-sender 20120424
    No suitable network interface found
    The following interfaces are available:
            lo      127.0.0.1
            enp4s0  10.255.6.20
    cat: write error: Broken pipe
    


  • @Wayne-Workman I checked that, but I’ll check @tom-elliott’s suggestion next time I’m working with it.


  • Senior Developer

    @nengelhardt Storage Management Page.


  • Moderator

    @nengelhardt said:

    @Tom-Elliott

    Where else is there besides that setting in the web interface that you just said is not used anymore, and in .fogsettings? Both of those are right.

    The interface field in the .fogsettings file is only used when the installer is ran.



  • @Tom-Elliott

    Where else is there besides that setting in the web interface that you just said is not used anymore, and in .fogsettings? Both of those are right.


  • Senior Developer

    Seeing as you’re on trunk, the FOG_MULTICAST_INTERFACE setting you described that you set is not what is used. Seeing as Multicast is ultimately dependent upon the master node of a group, it only seemed appropriate to move the interface definitions to the node’s panel. Check your nodes and ensure they’re setup to point at the correct interface as well as anywhere else you think needs this definition specified. You may need to restart the fogmulitcastmanager service.



  • I forget. I’m not at work right now. Whatever the latest git version was at about 1800 UTC-6 yesterday.


  • Senior Developer

    What version of FOG?


Log in to reply
 

395
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.