Fog 1.2 replicating issue on master node



  • This might be a simple one, but I haven’t been able to figure it out yet so I thought I would ask.

    I upgraded to Fog 1.2 a while back, but noticed yesterday that the master node wasn’t replicating the new image I had just uploaded (I updated an image from partimage to make it partclone). When I look in the replicator log, I see this message. (The partclone image is Windows7x64BASE). I have tried changing permissions and I still get the error.

    [09-04-15 10:57:08 am] * [09-04-15 10:57:08 am] SubProcess -> Making directory `Windows7x64BASE’

    [09-04-15 10:57:08 am] * [09-04-15 10:57:08 am] SubProcess -> ln: Fatal error: 500 Unknown SITE command.

    [09-04-15 10:57:08 am] * [09-04-15 10:57:08 am] SubProcess -> Mirroring directory `Windows7x86-b’

    [09-04-15 10:57:09 am] * [09-04-15 10:57:09 am] SubProcess -> mirror: Access failed: 550 Failed to change directory. (/images/Windows7x64BASE)

    I appreciate any ideas that can help me fix the issue. Thanks!

    Dustin


  • Developer

    if you’re still having issues with the “vista” setting, your best bet would be to upgrade to a trunk version of fog where it’s already fixed.



  • @Tom-Elliott Thanks Tom.

    I upgraded all the nodes. What cleared the error is below.

    The issue was that this was a “part-image” type of image that I updated and re-uploaded which converted it into a partclone image. The master node overwrote the old file when I uploaded the image. The other nodes though, which get the image updated from the master still had the old image on them which was a file, not a directory which partclone seems to use. Once I deleted the old image from the nodes, it replicated to the others without the error.


  • Senior Developer

    It’s straight forward. FOG may make updates to the Web files (even obliterating any customizations you’ve done) but it does not destroy the images. It doesn’t destroy the database, directly, either. So all definitions that you have (beyond simple modifications of things) will remain as well.



  • @Wayne-Workman I haven’t updated them. If that is supposed to happen, that could be the problem. Is there a wiki for this or a guide for updating a storage node? Or is it pretty straight forward (run the installer and images will not be wiped out?)


  • Moderator

    @dustindizzle11 Have you updated all of your storage nodes to 1.2.0 ?


Log in to reply
 

478
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.