SVN version 4547 blank page on Create New Image link



  • Hello again…

    I upgraded to latest SVN version of FOG this morning (4547) during troubleshooting of another issue - pulling image from remote storage node with the location plugin. While that issue is now resolved I find that if I click on the Create New Image link it hangs on a blank page while trying to navigate to: http://fqdn_of_main_fog_server/fog/management/index.php?node=image&sub=add

    I did try and add the LDAP plugin just beforehand which prevented me from logging in at all to the web GUI. I got around this by renaming the plugin directory

    mv /var/www/html/fog/lib/plugins/ldap /var/www/html/fog/lib/plugins/ldap1
    
    

    I have since upgraded to svn version 4551 to see if that would solve things but same issue occurs.

    The LDAP plugin may not be the issue here. I can login to the GUI and then rename the ldap1 to ldap again so I can use the LDAP plugin and remove all entries there but the issue still happens. I’ve also disabled the plugin system completely in FOG Configuration > FOG settings > Plugin System but once again issue persists.

    Is this perhaps a bug in latest svn version? Or is the fact I can’t delete plugins indicative of an issue within the plugins system which could be somehow impacting the create new image link in some way?

    regards Kiweegie



  • Oh ok I was able to get it back by copying the image the image management page.php file form the old verison I had before It was in the 3000s build and was able to get the page to load but now when i go to edit a image i get a basic page with no formatting lol


  • Senior Developer

    Somewhere, apparently, threads got crossed. I thought this thread was in reference to the installfog issue, where it kept reporting “Sorry, answer not recognized” but apparently this is not the case.



  • I get a blank page when i hit create a new image


  • Senior Developer

    @darkxeno What is the same problem? Exactly? What? “It don’t work” isn’t good enough, sorry.



  • Im have this same issue on 4571 what did you have to do to fix this?



  • @Tom-Elliott Thanks again for the help Tom, greatly appreciated. Please mark this call as resolved.

    regards, Kiweegie


  • Senior Developer

    This is now fixed. Apparently that bugs been there for a while.


  • Senior Developer

    Remoted in and found there was an error in the reading of the linux release name.



  • @Wayne-Workman well that was quick, but not successful.

    using latest git version same error is occuring - “Sorry, answer not recognised”

    I have followed the steps on installing on Centos from the wiki so selinux and iptables etc are disabled and all repos are added on.

    What could be triggering that last stanza in the installfog.sh file?

    cheers Kiweegie



  • @Wayne-Workman Thanks Wayne. A possibly (and feel free to omit the possibly) stupid question. How does one find a list of valid SVN release version numbers? I’m sure when I had this working before on the FOG icon on the web GUI it shows the revision number.

    This is from another of our FOG servers which is running ok.

    Imgur link

    Yet when I try and download that version on my faulty FOG server I get this

    [root@fogserver svn]# svn co -r 4457 https://svn.code.sf.net/p/freeghost/code/trunk trunk/
    svn: No such revision 4457
    

    If on the working server I go to Fog Configuration it shows the following version info

    Version: 4457

    You are not running the most current version of FOG!

    You are currently running version: 4457

    Latest stable version is 1.2.0

    Latest svn version is 3959

    Latest git version is 4557

    So I tried downloading the 3959 version via SVN and no dice - same error as before “Sorry, answer not recognised”.

    Do the GIT and SVN versions get updated separately? I’m trying git now based on this wiki link:

    regards Kiweegie.


  • Moderator

    @Kiweegie https://wiki.fogproject.org/wiki/index.php/Upgrade_to_Revision

    so for example -

    cd ~
    cd svn/trunk
    svn co -r 2922 https://svn.code.sf.net/p/freeghost/code/trunk
    

    DO NOT use 2922 !!! It is SOOO OLD! This is just an example!!!



  • @Wayne-Workman Hi Wayne thanks for getting back to me,

    No, the directory /opt/fog does not exist. But given this is a brand new OS install now and I haven’t been able to install FOG yet due to the error below, I wouldn’t expect to see it yet.

    Sorry, answer not recognized
    
    

    Something I’ve been meaning to ask elsewhere but may help in this case, how does one pull down a specific version of the trunk via SVN version, is that possible? Wondering if i specify an earlier SVN version it could rule out issue with this particular installer?

    Just a thought…

    regards Kiweegie.


  • Moderator

    @Kiweegie Does this file exist? What’s in it? /opt/fog/.fogsettings

    cat /opt/fog/.fogsettings
    ls -la /opt/fog
    


  • OK, I appear to be missing something here. I ended up wiping my existing FOG Server VM and rebuilding from scratch.

    On a clean install of Centos 6.5 and the latest SVN download I’m still getting the repeated error below when launching /opt/svn/trunk/bin/installfog.sh

    Sorry, answer not recognized
    

    Am I missing somethign obvious? The README.md file within the downloaded SVN trunk folder suggests the method I’ve used is correct.

    regards Kiweegie.


  • Senior Developer

    @Kiweegie The ./installfog.sh line I gave, I forced it to have a new line in my prior message. I was just warning you not to use it from the forums.



  • Hi Tom, appreciate the quick reply.

    Steps I’ve followed to get and install latest svn version are:

    sudo mkdir /opt/svn
    cd /opt/svn
    sudo svn checkout https://svn.code.sf.net/p/freeghost/code/trunk
    cd trunk/bin
    sudo ./installfog.sh
    

    This line in your reply doesn’t compute my side though, could you elaborate please?

    (That line has a purposeful New line but displays as a regular single line command) this could pose the issue.

    Am I somehow running the installer incorrectly? This has worked just fine in the past up to and including yesterday morning.

    Happy to use MysQL commands provided to disable plugins - I can access the GUI but there is no delete option there to remove them. However I need to get FOG reinstalled first…

    regards, Kiweegie.


  • Senior Developer

    How are you running the installer?

    My guess is you’re copying pasting from another tutorial? For example, if you’re running the command as:

    ./installfog.sh

    (That line has a purposeful New line but displays as a regular single line command) this could pose the issue.

    One of the easiest ways to disable plugins is obviously to use the plugin page on the GUI, but if you can’t get to the page obviously that won’t work. The next way is to use either phpmyadmin or other remote GUI SQL tool to modify the database fog on the table plugins. Look for your selected plugin and disable it by setting the pState and pInstalled values to 0.

    The other way, and my preferred when possible, is to run it directly out of MySQL.

    mysql -u root [-p'PASSIFSET'] fog (Only run the -p if you have a mysql password set.)

    Then the command:

    UPDATE plugins SET pInstalled=0,pState=0 WHERE pName='LDAP';

    This should essentially turn off the plugin and no longer require it’s hooks to be active.



  • Thanks Tom, that makes sense. I can’t remove the plugin so was looking to do a clean reinstall of FOG to wipe out and start again. I’ve run this to clear settings

    mv /opt/fog/.fogsettings /opt/fog/fogsettings-firstInstall
    

    then removed all FOG related files

    #Uninstall FOG
    
    #remove service
    sudo rm -rf /etc/init.d/FOGImageReplicator
    sudo rm -rf /etc/init.d/FOGMulticastManager
    sudo rm -rf /etc/init.d/FOGScheduler
    
    #delete fog database
    sudo mysql
    #(or 'sudo mysql -u root -p' if you set a root password for mysql)
    drop database fog;
    quit
    
    #Remove files
    sudo rm -rf /var/www/fog 
    sudo rm -rf /opt/fog 
    sudo rm -rf /tftpboot 
    sudo rm -rf /images 
    
    #delete fog system user
    sudo userdel fog
    

    Tried installing latest SVN version but getting repeated error:

    Sorry, answer not recognized
    

    I can see that this is coming from the last few lines of the installfog.sh file

            ;;
            [nN]*)
            echo "  FOG installer exited by user request."
            exit 1;
            ;;
            *)
            echo "";
            echo "  Sorry, answer not recognized."
            echo "";
            ;;
        esac
    done
    
    

    but cannot see why. I’ve read on other posts that this can happen when copy/pasting and the installer reading a carriage return or similar but I’m typing commands by hand.

    regards, Kiweegie.


  • Senior Developer

    I’m still siding with the idea that it’s LDAP plugin related, almost directly.

    I say this because under the same revision and even after, I’m not seeing any issues. Only difference is I haven’t tried using the LDAP Plugin.


Log in to reply
 

439
Online

38940
Users

10697
Topics

101497
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.