Host keeps rebooting in PXE after registration



  • Hi everyone!

    I setup Fog 1.2.0 on Ubuntu 12.04, and it seemed to be working correctly. I was able to get a VM (Oracle Box) to correctly pxe boot, and performed host registration. Fog said it succeeded, and I can see the Host added in the Fog Management console if I go to Hosts with correct image etc.

    However, after that the VM reboots, it starts to go into PXE boot, and then just restarts. There’s no error message, and no tasks running against it, but no matter what it keeps restarting during PXE boot before I even see the FOG menu. The VM just sticks in this loop on PXE boot.

    I tried setting up FOG from scratch again, and the same thing happened. I tried a different VM with the same results - the host registration succeeds but then keeps restarting after PXE. I’ve even tried creating a task in FOG for the host but same thing happens - restart.

    Anyone seen this happen before or know where I should be looking?

    Thank you!


  • Senior Developer

    So let me get this straight, the only “PXE Reboots after…” is happening on the VirtualBox VM?

    I am aware of issues with Virtual Box, specifically, and the only fix that I found (if you’re using undionly) is to do a power off, then power on. The other, more appropriate, fix is to use ipxe.pxe file rather than the undionly, but i also know that not all Physical systems will work with the ipxe.pxe.


  • Developer

    How did you configure network settings for your VMs? host-only, bridged, …?

    Is FOG running as a VM too or on the host system? If you are keen enough try capturing the network traffic using wireshark while the loop is going on. Share the PCAP file and we might be able to find the cause.



  • Another update to this. I was able to pull an image from a VM successfully, and then the VM starts rebooting in PXE again. I started another VM, and that one got tot he Fog Boot Menu correctly, even though the original one keeps rebooting. It seems after FOG does something with it (registers it, or pulls an image etc) it just keeps rebooting in PXE for some reason. Only way I know to fix it is to restart the FOG server. I tried restarting TFTP and DHCP and that does NOT resolve it.

    I tried what Wayne mentioned and set HD to boot as first device, and hit F12 and choose PXE instead. Now the VM that had something done on it has the error /default.ipxe…Connection time out however other VM’s get to the FOG boot menu fine until I run something there (REgister a host, or something to that affect).

    It’s really strange…



  • Restarted the system and the DHCP and TFTP services manually, and it looks like its working now. Weird that it keeps happening after I register a host. I’ll try to register Host1 and then Host2 and see if that works. But an image is uploadng right now as expected. Thanks for the help!


  • Moderator

    What happens when you set the boot priority to HDD first and network second?


  • Senior Developer

    This usually means the system is failing to get dhcp. Can you power down the system completely then power it back on?


Log in to reply
 

399
Online

38937
Users

10696
Topics

101490
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.