Alternative Multicasting Methods?



  • I have a 36 node imaging network setup with FOG 1.2.0 running on Ubuntu 14.04.3 on VMWare Player. I need to image around 270 machines in the next two days.

    My question is about starting a multicast session. All of my machines are registered via the csv file, but when I go grab a batch of 36 machines from the stack, I have no way of knowing which exact machines I have grabbed. I’m not excited about looking up each MAC manually. What I would like to do is set up a multicast session with image XYZ, PXE boot all the clients (all of which are registered already with image associations), then, when I’m done, come back to the server and click “Go”. To this point, I have only found where I can say “watch for these specific MAC’s, then when you see the last one come up, start multicast session”.

    Perhaps I could add a menu option that joins a multicast session with the registered image (similar to “quick image”), then I could just go back to FOG server and set it off?

    Is there any way of doing this deployment without digging up the MAC address for each one?

    Thanks!



  • @Tom-Elliott Is the console.h file an actual image? Where is it located?


  • Senior Developer

    @zacksiga This is now fixed. Apparently when I updated one time, the console.h file didn’t transfer over properly. It isn’t even seen on SVN history for whatever reason. I have now fixed this. The background image should display properly as it used to.



  • @zacksiga try the bond0 interface.



  • @Tom-Elliott
    The menu used to show up with the fog logo and everything before we update the svn.



  • @Wayne-Workman I have another machine that has Ubuntu 12.04 that has multicast issues, for the interface it has eth0 and ip link shows

    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: eth0: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc mq master bond0 state UP qlen 1000
    link/ether 00:1e:c9:d7:2f:d2 brd ff:ff:ff:ff:ff:ff
    3: eth1: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc mq master bond0 state UP qlen 1000
    link/ether 00:1e:c9:d7:2f:d2 brd ff:ff:ff:ff:ff:ff
    4: bond0: <BROADCAST,MULTICAST,MASTER,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP
    link/ether 00:1e:c9:d7:2f:d2 brd ff:ff:ff:ff:ff:ff

    what are your thoughts, I tried using load balancing feature, but I don’t think its working


  • Senior Developer

    @zacksiga I don’t follow what the problem is.

    The “black and blue screen” you see there is because the system can’t use the “vesafb” method.



  • @zacksiga said:

    Couple of area of concern for the new svn, compare to the last svn

    ?? I don’t see any issues, could you be more specific? thanks for the photos though.

    Also - All the props and thanks should go to @Tom-Elliott he knew exactly what the issue was, I was just a milder sounding-board. :-)



  • @Wayne-Workman Thank you very much that was my the big problem, soon as I changed the interface everything seem to work. Couple of area of concern for the new svn, compare to the last svn 20150818_151202-compressed.jpg Screenshot_2015-08-18-15-45-02-compressed.jpg



  • @zacksiga Well, after you set the interface name inside of the storage node settings, you hae to restart the FOGMulticastManager.

    Apologies for not including this earlier.



  • @Developers, @Tom Elliott, @Wayne-Workman . Funny thing is that when you created a session it only last for 10 sec or so , and disappear, same thing with multicast when you do it with a group, it shows up in active multicast for 10 sec and disappear like it was never multicast session to being with .



  • @zacksiga So according to that output, your interface name is ens32

    You should set this as the interface name in your storage node settings and then try to multicast again.



  • @Wayne-Workman here the output you requested ip link.JPG



  • @zacksiga Tom was on the right path, Fedora 21 and Fedora 22 do not use simple interface names like eth0.

    for instance, at home my Fedora 21 Server build uses enp2s0. My Fedora 22 build in my living room uses the same (same model of PC). My Fedora 21 server build at work in Hyper-V however is eth0.

    Run this and provide the output please so we can be sure - then we can move forward:

    ip link show
    


  • @Wayne-Workman So I tried your method, and it doesn’t seem to work.



  • Interface setting is set to eth0, which right because there only one network port in the virtual machine and also uni cast images work


  • Senior Developer

    @zacksiga Check that the interface setting for the image’s relevant storage node master is set to the actual interface name of that system. If not, change it and restart the FOGMulticastManager service.



  • @zacksiga look at this, bear in mind it’s a very rough work in progress: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_Downloading_-_Multicast



  • Hi, currently I have svn 4451, I think I tried that new feature and it didn’t work at all, I am aware that svn have bugs, is there anyway we can solve my problems. For starter when I create the session it shows up, then when go to login or join session on the first machine it give me and error and destroy the session in all, I know because second I tried join session says their no session name exists. Same with multicast when I try to multicast a group it doesn’t work at all. I did change the FOG_UDPCAST_MAXWAIT to 15 min hoping that it will solve the problem, if any machine was hanging or they got delayed to boot. that didn’t solve it. My current setup is install in Vmware Hypervisor 6 virtual machine running fedora 22. All my switches are multicast enable and I ran throw troubleshooting a multicast guide and I was able to successfully run throw the whole guide. I can’t find exact location for config.php file. I checked the /opt/fog/services/etc and /var/www/fog/commons and none of these location have the file. Please help me find a solution to my problem.



  • Thanks for the replies. I neglected to mention this is my first real deployment with FOG, so I’m still getting to know it. The reason I asked about this feature was because I wanted to make sure it was an error on my part during setup or configuration.

    I was virtually unaware of the trunk version, (I’m new like I said) so that will definitely be a good thing to look at.

    Thanks for your help!


 

423
Online

41.8k
Users

12.3k
Topics

116.0k
Posts